Bug 1486056 - [RFE] RGW Multi-site integration with Multi-site Keystone [NEEDINFO]
Summary: [RFE] RGW Multi-site integration with Multi-site Keystone
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW-Multisite
Version: 2.3
Hardware: x86_64
OS: All
medium
medium
Target Milestone: rc
: 4.*
Assignee: Matt Benjamin (redhat)
QA Contact: Tejas
URL:
Whiteboard:
: 1480927 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-28 21:18 UTC by Vikhyat Umrao
Modified: 2021-03-11 15:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-23 15:19:48 UTC
Target Upstream Version:
flucifre: needinfo? (nnarang)


Attachments (Terms of Use)

Description Vikhyat Umrao 2017-08-28 21:18:11 UTC
Description of problem:

[RFE] RGW Multi-site integration with Multi-site Keystone 

Design and documentation and coding effort for integrating RGW Multi-site with Multi-site Keystone 

This feature will track integration of Multi-site Keystone with RGW multi-site 

Expectation is if two OpenStack and  Ceph environment is deployed in two sites and they have RGW Multi-site configured and if both sites RGW's are integrated with respective side Keystone services 

1. Container Creation
2. User Creation
3. ACL set
4. any other metadata ops.

and all ops should work properly in both the sites to make RGW multi-site really active-active with Openstack Keystone.


Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 2.3

Comment 3 Vikhyat Umrao 2017-08-28 21:29:01 UTC
Here Keystone is not replicated both OpenStack environments are different. RGW is Multi-site and it has replication enabled.

Comment 9 Tejas 2019-08-22 04:09:37 UTC
*** Bug 1480927 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.