Bug 1486122 - gluster-block profile needs to have strict-o-direct
Summary: gluster-block profile needs to have strict-o-direct
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 3.12
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1485962
Blocks: glusterfs-3.12.0 1486115
TreeView+ depends on / blocked
 
Reported: 2017-08-29 05:46 UTC by Pranith Kumar K
Modified: 2017-10-26 14:36 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1485962
Environment:
Last Closed: 2017-09-05 17:40:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2017-08-29 05:46:43 UTC
+++ This bug was initially created as a clone of Bug #1485962 +++

Description of problem:
    tcmu-runner is not going to open block with O_SYNC anymore
    so writes have a chance of getting cached in write-behind
    when that happens, there is a chance that on failover some
    data could be stuck in cache and be lost. So strict-o-direct should be on


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-08-28 10:52:31 EDT ---

REVIEW: https://review.gluster.org/18120 (gluster-block: strict-o-direct should be on) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 1 Worker Ant 2017-08-29 05:48:08 UTC
REVIEW: https://review.gluster.org/18126 (gluster-block: strict-o-direct should be on) posted (#1) for review on release-3.12 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Worker Ant 2017-08-29 13:36:30 UTC
COMMIT: https://review.gluster.org/18126 committed in release-3.12 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 4d7f81c4ff3c42e84bfa65cf71755bc3553bc02c
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Aug 28 19:33:30 2017 +0530

    gluster-block: strict-o-direct should be on
    
           Backport of https://review.gluster.org/18120
    
    tcmu-runner is not going to open block with O_SYNC anymore
    so writes have a chance of getting cached in write-behind
    when that happens, there is a chance that on failover some
    data could be stuck in cache and be lost.
    
     >BUG: 1485962
     >Change-Id: If9835d914821dfc4ff432dc96775677a55d2918f
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    
    BUG: 1486122
    Change-Id: If9835d914821dfc4ff432dc96775677a55d2918f
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/18126
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Tested-by: Krutika Dhananjay <kdhananj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 3 Shyamsundar 2017-09-05 17:40:02 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.