Bug 1486737 - firefox-55.0.2-3.fc26 coredump on ppc64le in fc26 Updates
Summary: firefox-55.0.2-3.fc26 coredump on ppc64le in fc26 Updates
Keywords:
Status: CLOSED DUPLICATE of bug 1498561
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 26
Hardware: powerpc
OS: Other
unspecified
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-08-30 12:28 UTC by Michel Normand
Modified: 2018-02-14 13:00 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-14 13:00:08 UTC


Attachments (Terms of Use)
firefox coredump backtrace via gdb (8.29 KB, text/plain)
2017-08-30 13:30 UTC, Michel Normand
no flags Details

Description Michel Normand 2017-08-30 12:28:02 UTC
firefox-55.0.2-3.fc26 coredump on ppc64le in fc26 Updates

problem identified while running openQA test for Fedora Updates fc26
the "server_cockpit_default" test is failing when trying to start firefox.

I am able to recreate the problem on a ppc64le guest trying to start firefox.
coredumpctl is reporting two failures (1)
The gdb subcommand is unable to access the dump file as per (2) & (3)
But is reporting the crash on "mozilla::ipc::MessageChannel::OnChannelErrorFromLink"

=== (1)
$sudo coredumpctl 
TIME                            PID   UID   GID SIG COREFILE  EXE
Wed 2017-08-30 07:27:32 EDT    2492  1000  1000  11 present   /usr/lib64/firefox/firefox
Wed 2017-08-30 07:27:34 EDT    2576  1000  1000  11 present   /usr/lib64/firefox/firefox
=== (2)
$sudo coredumpctl gdb 
           PID: 2576 (Web Content)
           UID: 1000 (michel)
           GID: 1000 (michel)
        Signal: 11 (SEGV)
     Timestamp: Wed 2017-08-30 07:27:19 EDT (25min ago)
  Command Line: /usr/lib64/firefox/firefox -contentproc -childID 1 -isForBrowser -intPrefs 5:50|6:-1|18:0|28:1000|33:20|34:10|43:128|44:10000|49:0|51:400|52:1|53:0|54:0|59:0|60:120|61:120|91:2|92:1|106:5000|117:0|119:0|130:10000|155:24|156:32768|158:0|159:0|167:5|171:1048576|172:100|173:5000|175:600|176:4|177:1|200:60000| -boolPrefs 1:0|2:0|4:0|26:1|27:1|30:0|35:1|36:0|37:0|38:0|41:1|42:1|45:0|46:0|47:0|48:0|50:0|55:1|56:1|57:0|58:1|62:1|63:1|64:0|65:1|66:1|67:0|68:1|71:0|72:0|75:1|76:1|80:1|81:1|82:1|83:0|85:0|86:0|87:1|88:0|93:1|94:0|100:0|105:0|108:1|109:0|111:1|114:1|118:0|122:0|124:1|125:1|131:0|132:0|133:1|135:0|146:0|153:0|154:0|157:1|160:0|162:1|164:1|165:0|170:0|174:1|179:0|180:0|181:0|182:1|183:0|184:0|185:1|192:0|193:0|194:1|195:1|196:0|197:1|198:1|199:1|201:0|202:0|204:0|212:1|213:1|214:0|215:0|216:0| -stringPrefs 3:7;default|134:3;1.0|151:332;  |152:8;moderate| -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 2492 tab
    Executable: /usr/lib64/firefox/firefox
 Control Group: /user.slice/user-1000.slice/session-7.scope
          Unit: session-7.scope
         Slice: user-1000.slice
       Session: 7
     Owner UID: 1000 (michel)
       Boot ID: 98a6c3e7b0cb4784a63001bfca18fde7
    Machine ID: 516a75fad2d84acfb007b26892e148ed
      Hostname: fc26ppc64le
       Storage: /var/lib/systemd/coredump/core.Web\x20Content.1000.98a6c3e7b0cb4784a63001bfca18fde7.2576.1504092439000000.lz4
       Message: Process 2576 (Web Content) of user 1000 dumped core.

                Stack trace of thread 2577:
                #0  0x00007fff729fb37c _ZN7mozilla3ipc14MessageChannel22OnChannelErrorFromLinkEv (libxul.so)

Failed to invoke gdb: No such file or directory
=== (3)
$ls -ltr /var/lib/systemd/coredump/
total 42M
-rw-r-----+ 1 root root  35M Aug 30 07:27  core.firefox.1000.98a6c3e7b0cb4784a63001bfca18fde7.2492.1504092436000000.lz4
-rw-r-----+ 1 root root 6.6M Aug 30 07:27 'core.Web\x20Content.1000.98a6c3e7b0cb4784a63001bfca18fde7.2576.1504092439000000.lz4'
=== (4)
$grep firefox journalctl_20170830.log >firefox_trace_in_journalctl.log

Aug 16 09:14:43 fc26ppc64le userhelper[2442]: running '/usr/libexec/mock/mock --uniqueext=firefox -r default --init' with root privileges on behalf of 'michel'
Aug 16 09:18:12 fc26ppc64le userhelper[2821]: running '/usr/libexec/mock/mock --uniqueext=firefox --no-clean -r default ./firefox-55.0.1-1.fc28.src.rpm' with root privileges on behalf of 'michel'
Aug 30 05:41:32 fc26ppc64le sudo[13031]:   michel : TTY=pts/0 ; PWD=/home/michel ; USER=root ; COMMAND=/bin/dnf install firefox
Aug 30 07:27:04 fc26ppc64le dbus-daemon[2531]: [session uid=1000 pid=2531] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.1' (uid=1000 pid=2492 comm="/usr/lib64/firefox/firefox " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")
Aug 30 07:27:16 fc26ppc64le audit[2492]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=7 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=2492 comm=444F4D20576F726B6572 exe="/usr/lib64/firefox/firefox" sig=11 res=1
Aug 30 07:27:19 fc26ppc64le audit[2576]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=7 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=2576 comm="Chrome_~dThread" exe="/usr/lib64/firefox/firefox" sig=11 res=1
Aug 30 07:27:32 fc26ppc64le systemd-coredump[2581]: Process 2492 (firefox) of user 1000 dumped core.
Aug 30 07:27:47 fc26ppc64le abrt-notification[2646]: Process 2492 (firefox) crashed in void WasmFaultHandler<(Signal)0>(int, siginfo_t*, void*)()
Aug 30 07:27:49 fc26ppc64le abrt-notification[2694]: Process 2576 (firefox) crashed in mozilla::ipc::MessageChannel::OnChannelErrorFromLink()()
===

Comment 1 Michel Normand 2017-08-30 13:12:23 UTC
note that if I disable the Fedora Update repository and so install the GA level (firefox 54.0.2) on a new fc26 ppc64le guest then there is no such crash.

So problem is related to new firefox 55 version as per above description.

Comment 2 Michel Normand 2017-08-30 13:30:16 UTC
Created attachment 1320074 [details]
firefox coredump backtrace via gdb

I am able to extract the firefox backtrace after install of gdb and firefox debuginfo packages; as detailed in attached log file.

Comment 3 Michel Normand 2017-10-19 11:28:15 UTC
Still same problem with update of last firefox-56.0.5.fc26 on fc26 release
but also on f27 as per last openQA test:

https://openqa.stg.fedoraproject.org/tests/183053#step/server_cockpit_default/23

Comment 4 Michel Normand 2018-02-14 13:00:08 UTC
I assume still same problem on Rawhide (f28) compose 20180204 firefox-58.0-4
as per openqa test 
https://openqa.stg.fedoraproject.org/tests/236286#step/server_cockpit_default/22

But reports this bug as duplicate bug#1498561 used for investigation.

*** This bug has been marked as a duplicate of bug 1498561 ***


Note You need to log in before you can comment on or make changes to this bug.