Bug 1498561 - firefox crashes at ContextToFP() on ppc64le f27
Summary: firefox crashes at ContextToFP() on ppc64le f27
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 27
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1486737 1578429 (view as bug list)
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-10-04 15:57 UTC by Menanteau Guy
Modified: 2018-12-07 10:08 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-05-18 10:10:10 UTC


Attachments (Terms of Use)
msg at screen (3.97 KB, text/plain)
2017-10-04 15:58 UTC, Menanteau Guy
no flags Details
dmesg (21.25 KB, text/plain)
2017-10-04 15:58 UTC, Menanteau Guy
no flags Details
journalctl (307.00 KB, text/x-vhdl)
2017-10-04 15:59 UTC, Menanteau Guy
no flags Details
coredump thru gdb (15.03 KB, text/plain)
2017-10-04 15:59 UTC, Menanteau Guy
no flags Details
firefox with strace (1.11 MB, text/plain)
2017-10-04 16:00 UTC, Menanteau Guy
no flags Details
start of ppc64le patch which avoid the crash (1.19 KB, patch)
2018-05-16 11:35 UTC, Menanteau Guy
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 1462566 None None None 2019-04-12 15:08 UTC

Description Menanteau Guy 2017-10-04 15:57:18 UTC
firefox is used in openqa tests for ppc64le and ppc64
since Fedora-27-20171001.n.2 there is segmentation fault when running firefox

I reproduced the problem manually to get some traces (see attachments)
I installed a ppc64le VM with the Fedora-Server-dvd-ppc64le-27-20171003.n.0.iso
Then I start firefox thru a ssh -X session
firefox start but then scratch with a panel "Gah. Your tab just crashed." and the  window disappears.

Note that firefox was running correctly for last time with Fedora-27-20170929.n.0

Comment 1 Menanteau Guy 2017-10-04 15:58 UTC
Created attachment 1334363 [details]
msg at screen

Comment 2 Menanteau Guy 2017-10-04 15:58 UTC
Created attachment 1334364 [details]
dmesg

Comment 3 Menanteau Guy 2017-10-04 15:59 UTC
Created attachment 1334365 [details]
journalctl

Comment 4 Menanteau Guy 2017-10-04 15:59 UTC
Created attachment 1334366 [details]
coredump thru gdb

Comment 5 Menanteau Guy 2017-10-04 16:00 UTC
Created attachment 1334367 [details]
firefox with strace

Comment 6 Menanteau Guy 2017-10-18 12:55:30 UTC
for info, problem is still there in firefox-57.0-0.4

Comment 7 Michel Normand 2017-10-19 11:31:52 UTC
most probably a duplicate of previous bug #1486737 identified before for fc26 update tests.

Comment 8 Michel Normand 2018-02-14 13:00:08 UTC
*** Bug 1486737 has been marked as a duplicate of this bug. ***

Comment 9 Menanteau Guy 2018-05-16 11:35 UTC
Created attachment 1437274 [details]
start of ppc64le patch which avoid the crash

I started to test this patch sometimes ago but get blocked because of different other problems that crash firefox before I reach this code. The problem blocking my test is currently the bug #1578429

So my patch could not be completely satisfactory as is working ok in normal mode but I still have error when I put firefox in debug mode.

Comment 10 Martin Stransky 2018-05-16 11:56:14 UTC
*** Bug 1578429 has been marked as a duplicate of this bug. ***

Comment 11 Martin Stransky 2018-05-16 11:56:54 UTC
I added your patch to firefox-60.0-6.* builds at https://koji.fedoraproject.org/koji/packageinfo?packageID=37

Comment 12 Menanteau Guy 2018-05-17 13:47:26 UTC
firefox-60.0-6 seems working ok so far for ppc64le. I update my openqa environment to have next tests running on rawhide using this new firefox and I will update this bug if tests are ok. 
Also, jemalloc has been disable when building for powerpc, is there a plan to make jemalloc working for powerpc ?

Comment 13 Martin Stransky 2018-05-17 14:03:03 UTC
(In reply to Menanteau Guy from comment #12)
> Also, jemalloc has been disable when building for powerpc, is there a plan
> to make jemalloc working for powerpc ?

I don't have such intention.

Comment 14 Martin Stransky 2018-05-18 07:01:29 UTC
Do you mind to file upstream (at bugzilla.mozilla.org) bug or should I do so? Will be good to have this patch upstreamed.

Comment 15 Menanteau Guy 2018-05-18 08:53:45 UTC
Done, see https://bugzilla.mozilla.org/show_bug.cgi?id=1462566
Please, feel free to add any comments. Thanks


Note You need to log in before you can comment on or make changes to this bug.