Bug 1487538 - [RFE] Don't allow to run against different --target-version if one upgrade is already in progress
Summary: [RFE] Don't allow to run against different --target-version if one upgrade is...
Keywords:
Status: CLOSED DUPLICATE of bug 1487539
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 08:28 UTC by Ivan Necas
Modified: 2019-04-12 15:04 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-16 14:34:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 20597 0 None None None 2017-09-01 08:28:36 UTC

Description Ivan Necas 2017-09-01 08:28:33 UTC
At the moment, it's possible to end up in the middle of upgrade and
the upgrade prevent the user to specify different `--target-version`.

Steps to reproduce:

1. foreman-maintain upgrade run --target-version 6.2.z
2. simulate it failed in the migration phase
3. foreman-maintain upgrade --target-version 6.3

Current results:

The second upgrade scenario starts without issues.

Related issue to this is, when the upgrade fails at the installer run phase, the list of available versions
is already updated to the next versions, making it impossible to continue with the upgrade.

Expected results:

The upgrade to 6.3 will fail because another upgrade is already in progress

Comment 1 Ivan Necas 2017-09-01 08:28:39 UTC
Created from redmine issue http://projects.theforeman.org/issues/20597

Comment 2 Satellite Program 2017-09-07 22:03:14 UTC
Upstream bug assigned to inecas@redhat.com

Comment 3 Satellite Program 2017-09-07 22:03:17 UTC
Upstream bug assigned to inecas@redhat.com

Comment 4 Satellite Program 2017-09-12 16:03:08 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20597 has been resolved.

Comment 5 Nikhil Kathole 2017-12-19 13:16:35 UTC
VERIFIED

Version Tested:
# rpm -q rubygem-foreman_maintain
rubygem-foreman_maintain-0.1.1-1.el7sat.noarch

Steps:

# foreman-maintain upgrade run --target-version 6.2.z

# manage to fail upgrade run in packages-update 

# foreman-maintain upgrade run --target-version 6.3
Can't set target version 6.3, 6.2.z already in progress

Comment 6 sthirugn@redhat.com 2018-02-16 14:34:00 UTC
Closed as a duplicate of BZ 1487539. Both bugs have the same description, but the other bug has more detailed verification steps.

*** This bug has been marked as a duplicate of bug 1487539 ***


Note You need to log in before you can comment on or make changes to this bug.