Bug 1487539 - Don't allow to run against different --target-version if one upgrade is already in progress
Summary: Don't allow to run against different --target-version if one upgrade is alrea...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Nikhil Kathole
URL:
Whiteboard:
: 1487538 (view as bug list)
Depends On:
Blocks: 1496794
TreeView+ depends on / blocked
 
Reported: 2017-09-01 08:30 UTC by Ivan Necas
Modified: 2019-04-12 15:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-19 17:22:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 20597 0 Normal Closed Don't allow to run against different --target-version if one upgrade is already in progress 2020-04-03 10:36:26 UTC
Red Hat Product Errata RHBA-2018:0330 0 normal SHIPPED_LIVE Satellite Maintenance bug fix update 2018-02-19 22:22:51 UTC

Description Ivan Necas 2017-09-01 08:30:19 UTC
At the moment, it's possible to end up in the middle of upgrade and
the upgrade prevent the user to specify different `--target-version`.

Steps to reproduce:

1. foreman-maintain upgrade run --target-version 6.2.z
2. simulate it failed in the migration phase
3. foreman-maintain upgrade --target-version 6.3

Current results:

The second upgrade scenario starts without issues.

Related issue to this is, when the upgrade fails at the installer run phase, the list of available versions
is already updated to the next versions, making it impossible to continue with the upgrade.

Expected results:

The upgrade to 6.3 will fail because another upgrade is already in progress

Comment 1 Ivan Necas 2017-09-01 08:30:25 UTC
Created from redmine issue http://projects.theforeman.org/issues/20597

Comment 2 Ivan Necas 2017-09-01 08:30:30 UTC
Upstream bug assigned to None

Comment 5 Satellite Program 2017-09-07 22:13:32 UTC
Upstream bug assigned to inecas@redhat.com

Comment 6 Satellite Program 2017-09-07 22:13:35 UTC
Upstream bug assigned to inecas@redhat.com

Comment 7 Satellite Program 2017-09-12 16:13:30 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20597 has been resolved.

Comment 8 Nikhil Kathole 2017-12-19 14:05:13 UTC
VERIFIED

Version Tested:
# rpm -q rubygem-foreman_maintain
rubygem-foreman_maintain-0.1.1-1.el7sat.noarch

Trying to upgrade from 6.1 to 6.2 

# foreman-maintain upgrade run --target-version 6.2

Managed to fail upgrade in migration

# foreman-maintain upgrade run --target-version 6.3
Can't set target version 6.3, 6.2 already in progress

Also while verifying https://bugzilla.redhat.com/show_bug.cgi?id=1487538, tried to upgrade from 6.2 to 6.2.z

# foreman-maintain upgrade run --target-version 6.2.z

managed to fail upgrade run

# foreman-maintain upgrade run --target-version 6.3
Can't set target version 6.3, 6.2.z already in progress

Comment 9 sthirugn@redhat.com 2018-02-16 14:34:00 UTC
*** Bug 1487538 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-02-19 17:22:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0330


Note You need to log in before you can comment on or make changes to this bug.