Bug 1487830 - scripts: mount.glusterfs contains non-portable bashisms
Summary: scripts: mount.glusterfs contains non-portable bashisms
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1488119
TreeView+ depends on / blocked
 
Reported: 2017-09-02 10:42 UTC by Kaleb KEITHLEY
Modified: 2017-12-08 17:39 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1488119 (view as bug list)
Environment:
Last Closed: 2017-12-08 17:39:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Debian BTS 873878 0 None None None Never

Description Kaleb KEITHLEY 2017-09-02 10:42:32 UTC
Description of problem:

Default debian shell is dash. I.e. /bin/sh -> dash.

Non-posix idioms used don't work in dash or real /bin/sh

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-09-02 10:56:27 UTC
REVIEW: https://review.gluster.org/18184 (scripts: mount.glusterfs contains non-portable bashisms) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2017-09-04 10:22:21 UTC
REVIEW: https://review.gluster.org/18184 (scripts: mount.glusterfs contains non-portable bashisms) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Worker Ant 2017-09-05 09:17:25 UTC
COMMIT: https://review.gluster.org/18184 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit c0406501f0b4295a9917d31574baa2e462a18799
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Sat Sep 2 06:50:50 2017 -0400

    scripts: mount.glusterfs contains non-portable bashisms
    
    Debian's default shell is dash, i.e. /bin/sh -> dash, which doesn't
    support bash extensions
    
    Reported-by: "Michael Lundkvist" <brels.debian@solske.net>
    Reported-by: pmatthaei@debian.org
    Debian BZ: 873878
    
    Change-Id: I33003183b9bc6459cae28c565125e6b2bd1eaa47
    BUG: 1487830
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/18184
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-12-08 17:39:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.