Bug 1488119 - scripts: mount.glusterfs contains non-portable bashisms
Summary: scripts: mount.glusterfs contains non-portable bashisms
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1487830
Blocks: glusterfs-3.12.1
TreeView+ depends on / blocked
 
Reported: 2017-09-04 11:22 UTC by Niels de Vos
Modified: 2017-09-14 07:42 UTC (History)
2 users (show)

Fixed In Version: glusterfs-glusterfs-3.12.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1487830
Environment:
Last Closed: 2017-09-14 07:42:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2017-09-04 11:22:40 UTC
+++ This bug was initially created as a clone of Bug #1487830 +++

Description of problem:

Default debian shell is dash. I.e. /bin/sh -> dash.

Non-posix idioms used don't work in dash or real /bin/sh

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-09-02 12:56:27 CEST ---

REVIEW: https://review.gluster.org/18184 (scripts: mount.glusterfs contains non-portable bashisms) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Worker Ant on 2017-09-04 12:22:21 CEST ---

REVIEW: https://review.gluster.org/18184 (scripts: mount.glusterfs contains non-portable bashisms) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 1 Worker Ant 2017-09-05 09:19:44 UTC
REVIEW: https://review.gluster.org/18205 (scripts: mount.glusterfs contains non-portable bashisms) posted (#1) for review on release-3.12 by Niels de Vos (ndevos@redhat.com)

Comment 2 Worker Ant 2017-09-06 07:45:10 UTC
COMMIT: https://review.gluster.org/18205 committed in release-3.12 by jiffin tony Thottan (jthottan@redhat.com) 
------
commit 97f547c7822980aca2ec4cbbe236b930bab38b76
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Sat Sep 2 06:50:50 2017 -0400

    scripts: mount.glusterfs contains non-portable bashisms
    
    Debian's default shell is dash, i.e. /bin/sh -> dash, which doesn't
    support bash extensions
    
    Cherry picked from commit c0406501f0b4295a9917d31574baa2e462a18799:
    > Reported-by: "Michael Lundkvist" <brels.debian@solske.net>
    > Reported-by: pmatthaei@debian.org
    > Debian BZ: 873878
    > Change-Id: I33003183b9bc6459cae28c565125e6b2bd1eaa47
    > BUG: 1487830
    > Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    > Reviewed-on: https://review.gluster.org/18184
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > Tested-by: Niels de Vos <ndevos@redhat.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    
    Reported-by: Michael Lundkvist <brels.debian@solske.net>
    Reported-by: Patrick Matthäi <pmatthaei@debian.org>
    Debian BZ: 873878
    Change-Id: I33003183b9bc6459cae28c565125e6b2bd1eaa47
    BUG: 1488119
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: https://review.gluster.org/18205
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Jiffin 2017-09-14 07:42:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.12.1, please open a new bug report.

glusterfs-glusterfs-3.12.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-September/032441.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.