This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1487856 - UEFI installs fail to boot with anaconda-27.20-1 (due to EFI executable name mismatch)
UEFI installs fail to boot with anaconda-27.20-1 (due to EFI executable name ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
27
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1488281 (view as bug list)
Depends On:
Blocks: BetaBlocker/F27BetaBlocker
  Show dependency treegraph
 
Reported: 2017-09-02 12:21 EDT by Adam Williamson
Modified: 2017-09-11 18:14 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-27.20.1-1 anaconda-27.20.1-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-11 18:14:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-09-02 12:21:18 EDT
With the latest Fedora 27 and Rawhide composes - Fedora-Rawhide-20170902.n.0 and Fedora-27-20170901.n.1 - UEFI installs complete successfully, but do not boot correctly.

This is because the UEFI boot manager entry that's created points to 'shim.efi', but as a part of the '32-bit UEFI support' Change (which is a really cool change!), the executable name was changed in the shim packages to be 'shimx64.efi' (or 'shimia32.efi' for 32-bit firmwares).

This was actually fixed in anaconda, both on 27 and master branches:

https://github.com/rhinstaller/anaconda/commit/21f1a546c3d2d203f2718f02e7a4df4879dbe4d6

However, that change went into the anaconda-28.1-1.fc28 and anaconda-27.20.1-1.fc27 builds which are unusable because they break live image composes: https://bugzilla.redhat.com/show_bug.cgi?id=1487326 . So we untagged 28.1-1 from Rawhide and never sent 27.20.1-1 through Bodhi.

That's why I'm marking this bug as MODIFIED: we *have* a fix for this, but we can't use the build that fixes it.

Martin says they think they have a fix for the live image compose bug, and were planning to do new builds on Monday. For Rawhide it makes sense to just go ahead and build the latest state of the art and see what happens. But for F27 we *could*, I guess, ask for a build which is only 27.20-1 plus the fix for this (as we would expect during a freeze), instead of a 27.20.2-1 with all the 27.20.1 changes plus the attempt to fix live image creation.

If we go ahead with a 27.20.2-1 build I wouldn't be too incredibly surprised if there were more possible bugs in it, but it *is* still technically before the freeze. I'm just bringing all this up since we've been having so much trouble getting anywhere with 27 / Rawhide lately. I'm OK with just going ahead with a 27.20.2-1 and trying to squash any further critical bugs that show up during freeze, I just wanted to flag it up as a potential source of more issues.
Comment 1 Adam Williamson 2017-09-02 12:23:23 EDT
Proposing as a Beta blocker on the basis that it breaks UEFI installs. The fallback path might *possibly* help out here a bit in 'real world' use, but I'm not really sure...I did try booting my test install with the hard disk as the only 'bootable' drive in virt-manager, and it boots to a shim interface I've never seen before which gives you 10 seconds to 'Press any key to perform MOK management' and then I guess should boot the fallback path (maybe?), but it didn't, at least here. It just stuck at 'Booting in 1 second'. Not sure what that's all about.
Comment 2 Matthew Miller 2017-09-02 18:43:42 EDT
I guess my take is that given Adam says he's okay with it, I'm also okay with the "just go forward" plan *if* the anaconda team is willing to prioritize making sure any new bugs are resolved with special urgency so they don't hold up the overall process further.

If that special urgency is not possible, I'd prefer cherry-picking the fix and concentrating on fixes-only for F27.
Comment 3 Martin Kolman 2017-09-04 06:08:55 EDT
(In reply to Matthew Miller from comment #2)
> I guess my take is that given Adam says he's okay with it, I'm also okay
> with the "just go forward" plan *if* the anaconda team is willing to
> prioritize making sure any new bugs are resolved with special urgency so
> they don't hold up the overall process further.
> 
> If that special urgency is not possible, I'd prefer cherry-picking the fix
> and concentrating on fixes-only for F27.
I'm ready to help anything that shows up.
Comment 4 Kamil Páral 2017-09-04 12:17:24 EDT
Discussed during blocker review [1]:

AcceptedBlocker (Beta) - violates Alpha "Expected installed system boot behavior" requirements for some, possibly all, UEFI installs

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-04/
Comment 5 Fedora Update System 2017-09-04 19:22:19 EDT
anaconda-27.20.1-2.fc27 initial-setup-0.3.49-1.fc27 python-simpleline-0.5-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5361e86979
Comment 6 Fedora Update System 2017-09-04 19:23:00 EDT
anaconda-27.20.1-2.fc27 initial-setup-0.3.49-1.fc27 python-simpleline-0.5-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5361e86979
Comment 7 Jiri Konecny 2017-09-05 04:38:20 EDT
*** Bug 1488281 has been marked as a duplicate of this bug. ***
Comment 8 Adam Williamson 2017-09-06 17:59:43 EDT
Well, there's a bug in the fix for this:

https://bugzilla.redhat.com/show_bug.cgi?id=1489144

so we'll have to wait for a 27.20.3.
Comment 9 Fedora Update System 2017-09-07 10:29:25 EDT
anaconda-27.20.1-2.fc27, initial-setup-0.3.49-1.fc27, python-simpleline-0.5-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5361e86979
Comment 10 Fedora Update System 2017-09-07 15:14:02 EDT
anaconda-27.20.1-3.fc27 initial-setup-0.3.49-1.fc27 python-simpleline-0.5-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5361e86979
Comment 11 Paul Whalen 2017-09-07 16:38:29 EDT
This also affects installs on aarch64

efibootmgr -v
Boot0000* Fedora	HD(1,GPT,dd6acdcc-8ecd-444c-9501-550f48217d65,0x800,0x64000)/File(\EFI\fedora\shim.efi)
Comment 12 Fedora Update System 2017-09-08 11:24:10 EDT
anaconda-27.20.1-3.fc27, initial-setup-0.3.49-1.fc27, python-simpleline-0.5-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5361e86979
Comment 13 Fedora Update System 2017-09-11 18:14:11 EDT
anaconda-27.20.1-3.fc27, initial-setup-0.3.49-1.fc27, python-simpleline-0.5-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.