Bug 1487956 - Plasma severely broken if plasma-lookandfeel-fedora is not installed manually
Summary: Plasma severely broken if plasma-lookandfeel-fedora is not installed manually
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F27BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-09-03 19:40 UTC by Tomáš Trnka
Modified: 2017-09-27 17:28 UTC (History)
11 users (show)

Fixed In Version: plasma-workspace-5.10.5-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-27 17:28:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Trnka 2017-09-03 19:40:07 UTC
After installing F26 using the netinstall image with the KDE environment group + a few other groups selected, I have got a system where Plasma is nearly unusable due to multiple issues. All of them are caused by the plasma-lookandfeel-fedora package not getting automatically installed.

However, the /usr/share/plasma/look-and-feel/org.fedoraproject.fedora.desktop/ directory exists and contains just a few scripts belonging to the kde-settings-plasma package. This causes various applications to try to use this theme, even though most of its files are missing, and fail in various ways:

1) KSplash renders only a black screen:
ksplashqml[1589]: No metadata file in the package, expected it at: "/usr/share/plasma/look-and-feel/org.fedoraproject.fedora.desktop/"

2) Krunner does not work at all, pressing the global keyboard shortcut causes the current window to lose focus, but no KRunner window ever appears.
krunner[1684]: No metadata file in the package, expected it at: "/usr/share/plasma/look-and-feel/org.fedoraproject.fedora.desktop/"

3) Locking the session leads to a black screen with only a mouse cursor and no obvious way to recover.
kscreenlocker_greet[4094]: No metadata file in the package, expected it at: "/usr/share/plasma/look-and-feel/org.fedoraproject.fedora.desktop/"
kscreenlocker_greet[4094]: No metadata file in the package, expected it at: "/usr/share/backgrounds/f26/default/standard/"

4) The Logout/Shutdown/etc. buttons in Kicker do not work.
ksmserver-logout-greeter[1245]: No metadata file in the package, expected it at: "/usr/share/plasma/look-and-feel/org.fedoraproject.fedora.desktop/"
ksmserver-logout-greeter[1245]: ksmserver: Couldn't find a theme for the Shutdown dialog ""

5) The "look and feel" KCM does not show any themes, even though Breeze is installed and should be usable.
systemsettings5[3642]: No metadata file in the package, expected it at: "/usr/share/plasma/look-and-feel/org.fedoraproject.fedora.desktop/"

Installing the plasma-lookandfeel-fedora makes all of these problems disappear. I guess that kde-settings-plasma should either require plasma-lookandfeel-fedora  or refrain from shipping a largely incomplete theme.

Versions:
plasma-lookandfeel-fedora-5.10.5-2.fc26.noarch
kde-settings-plasma-26-1.fc26.noarch

Comment 1 Fedora Update System 2017-09-04 14:45:47 UTC
plasma-workspace-5.10.5-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-600e2ffc9b

Comment 2 TM 2017-09-05 15:53:28 UTC
On my fresh installation of Fedora 26, this also seem to affect Splash Screen settings in System Settings -> Workspace Theme -> Splash Screen. Without the plasma-lookandfeel-fedora package, the System Settings application crashes when clicking the Splash Screen icon in the left pane.

After installing the plasma-lookandfeel-fedora package manually the Splash Screen dialogue seem stable and presents its options in the right pane.

I will conduct further tests to see if this also resolves the segfault crashes I've been having with ksplashqml.

Comment 3 TM 2017-09-05 16:42:54 UTC
(In reply to TM from comment #2)
> On my fresh installation of Fedora 26, this also seem to affect Splash
> Screen settings in System Settings -> Workspace Theme -> Splash Screen.
> Without the plasma-lookandfeel-fedora package, the System Settings
> application crashes when clicking the Splash Screen icon in the left pane.
> 
> After installing the plasma-lookandfeel-fedora package manually the Splash
> Screen dialogue seem stable and presents its options in the right pane.
> 
> I will conduct further tests to see if this also resolves the segfault
> crashes I've been having with ksplashqml.

Yes! After some initial tests, installing the plasma-lookandfeel-fedora package also seem to resolve the issue when Fedora is locking the screen. If the package plasma-lookandfeel-fedora is not installed, ksplashqml will segfault resulting in a black screen with just a mouse pointer. See excerpt from error below:

Sep  5 16:15:53 my-system /usr/libexec/gdm-x-session[2031]: Cannot find 'org.kde.KSplash.setStage' in object /KSplash at org.kde.KSplash
Sep  5 16:15:55 my-system abrt-notification[2555]: Process 2226 (ksplashqml) crashed in QObject::setProperty(char const*, QVariant const&)()
Sep  5 17:03:53 my-system kernel: ksplashqml[2295]: segfault at 8 ip 00007fd797339907 sp 00007fffe74a9570 error 4 in libQt5Core.so.5.7.1[7fd7970c3000+478000]
Sep  5 17:03:53 my-system audit[2295]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=2295 comm="ksplashqml" exe="/usr/bin/ksplashqml" sig=11 res=1

Comment 4 Fedora Update System 2017-09-06 14:52:58 UTC
plasma-workspace-5.10.5-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Rex Dieter 2017-09-22 13:12:03 UTC
Looks like it affects f27, and f27-beta in particular too, re-opening.

Comment 6 Fedora Update System 2017-09-22 13:13:11 UTC
plasma-workspace-5.10.5-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-07b7238be6

Comment 7 Fedora Blocker Bugs Application 2017-09-22 13:14:48 UTC
Proposed as a Blocker for 27-beta by Fedora user rdieter using the blocker tracking app because:

 plasma spin is (likely?) non functional without plasma-lookandfeel-fedora being present, this latest build (re)adds an explicit dependency for it.

Comment 8 Lukas Brabec 2017-09-25 11:01:39 UTC
I was able to reproduce this with Fedora 27 Candidate Beta-1.2.

(In reply to Fedora Update System from comment #6)
> plasma-workspace-5.10.5-3.fc27 has been submitted as an update to Fedora 27.
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-07b7238be6

this (with plasma-lookandfeel-fedora as dependency), fixed the bug.

Comment 9 Kamil Páral 2017-09-25 16:17:21 UTC
Discussed during blocker review [1]:

AcceptedBlocker (beta) - This bug violates the criterion: "Shutting down, logging out and rebooting must work using standard console commands and the mechanisms offered (if any) by all release-blocking desktops."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-25/

Comment 10 Kamil Páral 2017-09-27 07:36:26 UTC
This is fixed with Beta RC3.

Comment 11 Fedora Update System 2017-09-27 17:28:09 UTC
plasma-workspace-5.10.5-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.