Bug 1488228 - Quagga package misses command "ip ospf area AREANUMBER"
Summary: Quagga package misses command "ip ospf area AREANUMBER"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: quagga
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Ruprich
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 1488825
Blocks: 1709724
TreeView+ depends on / blocked
 
Reported: 2017-09-04 18:36 UTC by Răzvan Sandu
Modified: 2019-12-06 16:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-06 16:06:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Răzvan Sandu 2017-09-04 18:36:17 UTC
Description of problem:

The OSPF command "ip ospf area AREANUMBER", that allows an OSPF interface to be assigned to a *specific* area, is not available (despite being advertised in Quagga's official documentation). 

http://www.nongnu.org/quagga/docs/docs-multi/OSPF-interface.html#OSPF-interface


Version-Release number of selected component (if applicable):
quagga-0.99.22.4-4.el7.x86_64 (CentOS 7.x as of September 3rd, 2017)

How reproducible:
Always.

Steps to Reproduce:
1. Install quagga package from the official repositories.
2. Enable zebra and ospf daemons
3. Launch vtysh, to obtain a Cisco-like CLI
4. Do "conf t", then "interface SOMEINTERFACE"
5. Check "ip ospf" sub commands

Actual results:
There is no "ip ospf area AREANUMBER" command available, limiting configuration options.

Expected results:
"ip ospf area AREANUMBER" command should be available, as documented here
http://www.nongnu.org/quagga/docs/docs-multi/OSPF-interface.html#OSPF-interface

Please update the quagga package to latest features, as advertised.


Additional info:
See further details at https://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/ospfarea.html


Thank  you!
Răzvan

Comment 2 Răzvan Sandu 2017-09-06 08:12:31 UTC
The Quagga RPM package included in current Red Hat Enterprise Linux 7.x and CentOS 7.x is VERY old; the solution of the above bug (missing command) seems to be simply to include a newer version.

For comparison:

- Current stable Quagga is 1.2.1 (http://savannah.nongnu.org/forum/forum.php?forum_id=8811)

- Quagga RPM package included in RHEL/CentOS 7.x is quagga-0.99.22.4-4.el7

- Quagga RPM package included in Fedora 26 is quagga-1.2.1-1.fc26

- Quagga package included in Debian (stable) 9.x is quagga-1.1.1


So please release a newer Quagga package in RHEL/CentOS.


Thank you!
Răzvan

Comment 4 Tomáš Hozza 2019-12-06 16:06:46 UTC
Red Hat Enterprise Linux version 7 entered the Maintenance Support 1 Phase in August 2019. In this phase only qualified Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released as they become available. Other errata advisories may be delivered as appropriate.

This bug has been reviewed by Support and Engineering representative and does not meet the inclusion criteria for Maintenance Support 1 Phase. If this issue still exists in newer major version of Red Hat Enterprise Linux, it has been cloned there and work will continue in the cloned bug.

For more information about Red Hat Enterprise Linux Lifecycle, please see https://access.redhat.com/support/policy/updates/errata/

Comment 5 RHEL Program Management 2019-12-06 16:06:53 UTC
Development Management has reviewed and declined this request. You may appeal this decision by using your Red Hat support channels, who will make certain  the issue receives the proper prioritization with product and development management.

https://www.redhat.com/support/process/production/#howto


Note You need to log in before you can comment on or make changes to this bug.