Bug 1488499 - queue.declare caused a channel exception not_found: "failed to perform operation on queue 'q-reports-plugin' in vhost '/' due to timeout
Summary: queue.declare caused a channel exception not_found: "failed to perform operat...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server
Version: 9.0 (Mitaka)
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 9.0 (Mitaka)
Assignee: John Eckersberg
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-05 14:22 UTC by Jaison Raju
Modified: 2020-12-14 09:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-29 09:27:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jaison Raju 2017-09-05 14:22:00 UTC
Description of problem:
All neutron agent were noticed as down.
No other openstack components were noticed as effected.
=ERROR REPORT==== 22-Aug-2017::10:04:58 ===
Discarding message {'$gen_call',{<0.1053.0>,#Ref<0.0.3.72786>},{basic_consume,false,<5644.21200.217>,<5644.28503.217>,false,0,<<"1">>,false,[],undefined}} from <0.1053.0> to <0.2208.0> in an old incarnation (3) 
of this node (1)


=ERROR REPORT==== 22-Aug-2017::10:04:59 ===
Channel error on connection <0.26111.0> (172.22.178.74:43108 -> 172.22.178.74:5672, vhost: '/', user: 'guest'), channel 1:
operation queue.declare caused a channel exception not_found: "failed to perform operation on queue 'q-reports-plugin' in vhost '/' due to timeout"

No alarms noticed

Version-Release number of selected component (if applicable):
rabbitmq-server-3.6.3-6.el7ost.noarch
RHOS9
python-oslo-messaging-4.5.0-2.el7ost.noarch

How reproducible:
On customer environment , until rabbitmq was restarted.

Steps to Reproduce:
1.
2.
3.

Actual results:
all neutron agents were noticed as down in
neutron agent-list
Restarting individual components does not fix the issue.
Restarting rabbitmq server across all controller fixed the issue.

Expected results:


Additional info:
Looks similar to the following bug, except that its supposed to fixed in above version.
https://bugzilla.redhat.com/show_bug.cgi?id=1418668

Comment 2 John Eckersberg 2017-09-05 15:23:15 UTC
At a glance, this looks like https://github.com/rabbitmq/rabbitmq-server/issues/959 but will require some more log analysis to be sure.


Note You need to log in before you can comment on or make changes to this bug.