Bug 1489604 - AArch64 installations fail to boot using shimaa64.efi - 'Error reported: Unsupported'
Summary: AArch64 installations fail to boot using shimaa64.efi - 'Error reported: Unsu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shim-signed
Version: 27
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: ARMTracker F27BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-09-07 21:12 UTC by Paul Whalen
Modified: 2017-09-25 18:06 UTC (History)
4 users (show)

Fixed In Version: shim-signed-13-0.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-25 18:06:21 UTC


Attachments (Terms of Use)

Description Paul Whalen 2017-09-07 21:12:57 UTC
Description of problem:
AArch64 installations fail to boot using shimaa64.efi - 'Error reported: Unsupported'

Version-Release number of selected component (if applicable):
shim-signed-13-0.4

Steps to Reproduce:
1. Install using Fedora-27-20170901.n.1, boot will fail due to bz#1487856, efi boot entry points to shim.efi rather than the newly named shimaa64.efi

efibootmgr -v
Boot0000* Fedora	HD(1,GPT,dd6acdcc-8ecd-444c-9501-550f48217d65,0x800,0x64000)/File(\EFI\fedora\shim.efi)

2. using the uefi shell, attempt to boot with shimaa64.efi 

FS0:\efi\fedora\> shimaa64.efi
Error reported: Unsupported
FS0:\efi\fedora\> shimaa64-fedora.efi
Error reported: Unsupported

Additional info:
Also tried shim-aa64-13-0.5.aarch64, same result. Booting with grubaa64.efi boots as expected.

Comment 1 Paul Whalen 2017-09-11 14:49:30 UTC
Proposing as a Freeze Exception for aarch64, this breaks uefi installations, violates Alpha "Expected installed system boot behavior".

Comment 2 Kamil Páral 2017-09-11 18:19:15 UTC
Discussed during blocker review [1]:

AcceptedFreezeException (Beta) - this breaks UEFI installs on aarch64, a non-release-blocking arch; obviously can't be fixed with an update, so clearly worth an FE

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-11/

Comment 3 Fedora Update System 2017-09-20 16:18:53 UTC
shim-signed-13-0.6 shim-unsigned-aarch64-13-3.fc27 shim-unsigned-x64-13-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-99e6ffc4c7

Comment 4 Fedora Update System 2017-09-21 23:57:32 UTC
shim-signed-13-0.6, shim-unsigned-aarch64-13-3.fc27, shim-unsigned-x64-13-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-99e6ffc4c7

Comment 5 Fedora Update System 2017-09-25 18:06:21 UTC
shim-signed-13-0.6, shim-unsigned-aarch64-13-3.fc27, shim-unsigned-x64-13-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.