Bug 1489877 - minor typo in /etc/rhsm/rhsm.conf comment
Summary: minor typo in /etc/rhsm/rhsm.conf comment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-08 14:42 UTC by John Sefler
Modified: 2018-04-10 09:51 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:51:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github /candlepin subscription-manager pull 1700 None None None 2017-09-18 14:19:48 UTC
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:51:43 UTC

Description John Sefler 2017-09-08 14:42:54 UTC
Description of problem:
After implementation of RFE Bug 1319927, there is a minor typo in the following comment found in /etc/rhsm/rhsm.conf...

# Manage automatic enabling of yum plugins (product-id, subsription-manager)


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q subscription-manager
subscription-manager-1.20.1-1.git.48.bc07705.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# grep -B1 auto_enable_yum_plugins /etc/rhsm/rhsm.conf
# Manage automatic enabling of yum plugins (product-id, subsription-manager)


Actual results:
subsription-manager

Expected results:
subscription-manager

Additional info:

Comment 1 John Sefler 2017-09-08 14:56:29 UTC
There is also a typo in a gui dialog message...
[root@jsefler-rhel7 ~]# rpm -q --whatprovides /usr/lib/python2.7/site-packages/subscription_manager/gui/managergui.py
subscription-manager-gui-1.20.1-1.git.48.bc07705.el7.x86_64

[root@jsefler-rhel7 ~]# grep Warning /usr/lib/python2.7/site-packages/subscription_manager/gui/managergui.py
                _("Warning - subscribtion-manager plugins were automatically enabled")


Actual:
subscribtion-manager

Expected
subscription-manager

Comment 3 Shwetha Kallesh 2017-11-13 07:38:30 UTC
[root@dhcp35-121 product]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7


[root@dhcp35-121 ~]# grep -B1 auto_enable_yum_plugins /etc/rhsm/rhsm.conf
# Manage automatic enabling of yum plugins (product-id, subscription-manager)
auto_enable_yum_plugins = 1



[root@dhcp35-121 ~]# grep Warning /usr/lib64/python2.7/site-packages/subscription_manager/gui/managergui.py
                _("Warning - subscription-manager plugins were automatically enabled")

Comment 6 errata-xmlrpc 2018-04-10 09:51:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.