Bug 1490072 - Program terminated with signal SIGSEGV, Segmentation fault. #0 0x00007f16279aa68f in _cogl_boxed_value_set_x () from /usr/lib64/mutter/libmutter-cogl-1.so
Summary: Program terminated with signal SIGSEGV, Segmentation fault. #0 0x00007f16279...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: F27BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-09-09 21:57 UTC by Mikhail
Modified: 2017-09-18 19:41 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-09-18 19:41:32 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 787568 None None None 2017-09-12 01:19 UTC
Launchpad 1715330 None None None 2017-09-12 01:19 UTC

Description Mikhail 2017-09-09 21:57:13 UTC
Description of problem:
(gdb) bt
#0  0x00007f16279aa68f in _cogl_boxed_value_set_x () at /usr/lib64/mutter/libmutter-cogl-1.so
#1  0x00007f16279aaa1a in _cogl_boxed_value_set_float () at /usr/lib64/mutter/libmutter-cogl-1.so
#2  0x00007f16253d1d1e in ffi_call_unix64 () at ../src/x86/unix64.S:76
#3  0x00007f16253d168f in ffi_call (cif=cif@entry=0x55982fe02938, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x7ffe2524f628, avalue=avalue@entry=0x7ffe2524f4e0) at ../src/x86/ffi64.c:525
#4  0x00007f1629983606 in gjs_invoke_c_function(JSContext*, Function*, JS::HandleObject, JS::HandleValueArray const&, mozilla::Maybe<JS::MutableHandle<JS::Value> >, GIArgument*) (context=context@entry=0x55982e56f560, function=function@entry=0x55982fe02920, obj=..., obj@entry=..., args=..., js_rval=..., r_value=r_value@entry=0x0) at gi/function.cpp:1026
#5  0x00007f1629984f76 in function_call(JSContext*, unsigned int, JS::Value*) (context=0x55982e56f560, js_argc=3, vp=0x55982eb3e278) at gi/function.cpp:1343
#6  0x00007f1621ed33d8 in js::CallJSNative(JSContext*, bool (*)(JSContext*, unsigned int, JS::Value*), JS::CallArgs const&) (args=..., native=<optimized out>, cx=0x55982e56f560)
    at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/jscntxtinlines.h:226
#7  0x00007f1621ed33d8 in js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) (cx=0x55982e56f560, args=..., construct=<optimized out>) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:498
#8  0x00007f1621ec92cd in Interpret(JSContext*, js::RunState&) (cx=0x55982e56f560, state=...) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:2602
#9  0x00007f1621ed3054 in js::RunScript(JSContext*, js::RunState&) (cx=cx@entry=0x55982e56f560, state=...) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:448
#10 0x00007f1621ed3344 in js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) (cx=cx@entry=0x55982e56f560, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:517
#11 0x00007f1621ed3f73 in js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value const*, JS::MutableHandle<JS::Value>) (cx=cx@entry=0x55982e56f560, thisv=..., fval=..., argc=argc@entry=1, argv=argv@entry=0x7ffe25250bd0, rval=...) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:554
#12 0x00007f1621ed40f4 in js::InvokeGetterOrSetter(JSContext*, JSObject*, JS::Value, unsigned int, JS::Value*, JS::MutableHandle<JS::Value>) (cx=cx@entry=0x55982e56f560, obj=<optimized out>, fval=..., argc=argc@entry=1, argv=argv@entry=0x7ffe25250bd0, rval=rval@entry=...) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:624
#13 0x00007f1621efb577 in js::Shape::set(JSContext*, JS::Handle<js::NativeObject*>, JS::Handle<JSObject*>, bool, JS::MutableHandle<JS::Value>) (this=<optimized out>, cx=cx@entry=0x55982e56f560, obj=..., 
    obj@entry=..., receiver=..., receiver@entry=..., strict=strict@entry=false, vp=..., vp@entry=...) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Shape-inl.h:52
#14 0x00007f1621ed64cf in SetExistingProperty (strict=false, vp=..., shape=..., pobj=..., id=..., receiver=..., obj=..., cx=0x55982e56f560)
    at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/NativeObject.cpp:2214
#15 0x00007f1621ed64cf in js::NativeSetProperty(JSContext*, JS::Handle<js::NativeObject*>, JS::Handle<JSObject*>, JS::Handle<jsid>, js::QualifiedBool, JS::MutableHandle<JS::Value>, bool) (cx=0x55982e56f560, obj=..., receiver=..., id=..., qualified=qualified@entry=js::Qualified, vp=..., strict=false) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/NativeObject.cpp:2250
#16 0x00007f1621efc2b8 in js::SetProperty(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSObject*>, JS::Handle<jsid>, JS::MutableHandle<JS::Value>, bool) (cx=<optimized out>, obj=..., receiver=..., id=..., vp=..., strict=<optimized out>) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/NativeObject.h:1424
#17 0x00007f1621ed6e55 in SetObjectElementOperation (pc=0x55982ecf49be "8Q\343\201QLM\a\377\377\376.QNV", script=<optimized out>, strict=<optimized out>, value=..., id=..., obj=..., cx=0x55982e56f560)
    at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:1394
#18 0x00007f1621ed6e55 in js::SetObjectElement(JSContext*, JS::Handle<JSObject*>, JS::Handle<JS::Value>, JS::Handle<JS::Value>, bool, JS::Handle<JSScript*>, unsigned char*) (cx=cx@entry=0x55982e56f560, obj=obj@entry=..., index=..., index@entry=..., value=value@entry=..., strict=<optimized out>, script=..., script@entry=..., pc=0x55982ecf49be "8Q\343\201QLM\a\377\377\376.QNV")
    at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:3920
#19 0x00007f16220190ea in js::jit::DoSetElemFallback(JSContext*, js::jit::BaselineFrame*, js::jit::ICSetElem_Fallback*, JS::Value*, JS::HandleValue, JS::HandleValue, JS::HandleValue) (cx=0x55982e56f560, frame=<optimized out>, stub_=0x559830603fb8, stack=0x7ffe25250e18, objv=..., index=..., rhs=...) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/jit/BaselineIC.cpp:4999
#20 0x00007f162b6f6c7a in  ()
#21 0x00007ffe25250e10 in  ()
#22 0x00007ffe25250dc8 in  ()
#23 0x00007f15f182c150 in  ()
#24 0x00007f16223ab060 in js::jit::DoSetElemFallbackInfo () at /lib64/libmozjs-38.so
#25 0x00007f15f1675be0 in  ()
#26 0x00007f15a57022e7 in  ()
#27 0x0000000000001081 in  ()
#28 0x00007ffe25250ea8 in  ()
#29 0x0000559830603fb8 in  ()
#30 0x00007ffe25250e18 in  ()
#31 0xfffc7f157ad84980 in  ()
#32 0xfffaff15f16e2148 in  ()
#33 0x3fe999999999999a in  ()
#34 0x3fe999999999999a in  ()
#35 0xfffaff15f16e2148 in  ()
#36 0xfffc7f157ad84980 in  ()
#37 0xfffaff15f16e2148 in  ()
---Type <return> to continue, or q <return> to quit---
#38 0xfffc7f157d99c8b0 in  ()
#39 0xfffc7f15f182c1b0 in  ()
#40 0x3fe6666666666666 in  ()
#41 0xfffaff15f16e2148 in  ()
#42 0xfff9800000000001 in  ()
#43 0xfff9800000000001 in  ()
#44 0x3fe999999999999a in  ()
#45 0xfff9000000000000 in  ()
#46 0xfff9000000000000 in  ()
#47 0xfff9000000000000 in  ()
#48 0xfff9000000000000 in  ()
#49 0xfffc7f157ad84980 in  ()
#50 0x405ba8624dd30000 in  ()
#51 0xfffc7f15f182c2d0 in  ()
#52 0x3fe999999999999a in  ()
#53 0x000055982e56f578 in  ()
#54 0x00007ffe000000d8 in  ()
#55 0x00007f15f0a7d1c0 in  ()
#56 0xf753744eaa829200 in  ()
#57 0xfff8800000000001 in  ()
#58 0x0000000000000008 in  ()
#59 0x000000002eb3e1c8 in  ()
#60 0x00007ffe25250f20 in  ()
#61 0x00007f162b6fbf95 in  ()
#62 0x0000000000000202 in  ()
#63 0x00007f15f16b0980 in  ()
#64 0x0000000000000001 in  ()
#65 0xfffc7f15f0a77700 in  ()
#66 0xfff8800000000001 in  ()
#67 0x00007ffe25250ff8 in  ()
#68 0x0000559832021320 in  ()
#69 0x00007f15a699da72 in  ()
#70 0x0000000000000c01 in  ()
#71 0xfff8800000000001 in  ()
#72 0xfffc7f15f0a77700 in  ()
#73 0xfffc7f15f16b0980 in  ()
#74 0xfff8800000000000 in  ()
#75 0xfff8800000000001 in  ()
#76 0xfffc7f15f182c150 in  ()
#77 0xfffc7f15f182c2d0 in  ()
#78 0xfffc7f15f0971480 in  ()
#79 0xfff8800000000000 in  ()
#80 0xfff8800000000000 in  ()
#81 0xfff8800000000001 in  ()
#82 0xfffc7f15f182c010 in  ()
#83 0xfffaff15f16fac60 in  ()
#84 0xfffc7f15f182bdb0 in  ()
#85 0xfffc7f15f182bfd0 in  ()
#86 0xfffc7f15f182c250 in  ()
#87 0x00007ffe25251020 in  ()
#88 0x00007f16000000c0 in  ()
---Type <return> to continue, or q <return> to quit---
#89 0x00007f15f0a7d1c0 in  ()
#90 0x00007ffe25251030 in  ()
#91 0x000055982e56f578 in  ()
#92 0x00007ffe25251350 in  ()
#93 0x00000000f0a7d1c0 in  ()
#94 0x00007ffe25251040 in  ()
#95 0x00007f162b6fbf95 in  ()
#96 0x0000000000000302 in  ()
#97 0x00007f15f16b0ac0 in  ()
#98 0x0000000000000003 in  ()
#99 0xfffc7f15f0a77700 in  ()
#100 0xfffc7f157ad84980 in  ()
#101 0xfffc7f15f182bdb0 in  ()
#102 0xfff9800000000000 in  ()
#103 0x00007ffe252510c8 in  ()
#104 0x0000559831437790 in  ()
#105 0x00007f15a56ed6b3 in  ()
#106 0x0000000000000701 in  ()
#107 0xfff9800000000000 in  ()
#108 0xfffc7f15f182bdb0 in  ()
#109 0xfffc7f157ad84980 in  ()
#110 0xfffc7f15f0a77700 in  ()
#111 0xfffc7f15f16b0ac0 in  ()
#112 0x00007f1621ea07b7 in js::GetThisObject(JSContext*, JS::Handle<JSObject*>) (obj=..., cx=0x7ffe25250e10) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/jsobj.h:1042
#113 0x00007f1621ea07b7 in ComputeImplicitThis (vp=..., obj=..., cx=0x7ffe25250e10) at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:1262
#114 0x00007f1621ea07b7 in js::ImplicitThisOperation(JSContext*, JS::Handle<JSObject*>, JS::Handle<js::PropertyName*>, JS::MutableHandle<JS::Value>) (cx=0x7ffe25250e10, scopeObj=..., name=..., res=...)
    at /usr/src/debug/mozjs38-38.8.0-6.fc27.x86_64/vm/Interpreter.cpp:4003
(gdb) 


This is usually happens when I try open VM for watching in virt-manager

Comment 1 Mikhail 2017-09-10 08:24:22 UTC
Demonstration: https://youtu.be/tIo3rLv7SfY

Comment 2 Fedora Blocker Bugs Application 2017-09-10 21:14:59 UTC
Proposed as a Blocker and Freeze Exception for 27-beta by Fedora user mikhail using the blocker tracking app because:

 Very annoying bug because leads to lose all data in launched applications. And losing current logon session.

Comment 3 Kamil Páral 2017-09-11 16:55:56 UTC
Discussed during blocker review [1]:

punt (delay decision) - we don't have quite enough information on how common this crash is to make a decision yet; we'd like to ask folks to test launching VMs in virt-manager on F27 and see if this affects many people

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-11/

Comment 4 Adam Williamson 2017-09-12 00:08:16 UTC
I have also seen my desktop consistently crash when starting a VM in virt-manager, or shortly after doing so. I just tried this on my test box (which has a different graphics card) with a clean install of the current Fedora 27 Workstation nightly, and saw the same bug there, with the same backtrace (starting in _cogl_boxed_value_set_x). So this doesn't seem to be very hardware dependent, and does seem fairly easily reproducible.

https://bugzilla.gnome.org/show_bug.cgi?id=787240 has some discussion of this and some suggestions of commits that fix it.

Ubuntu has reports at https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1714330 and https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1715330 .

Comment 5 Parag Nemade 2017-09-12 04:51:21 UTC
I am happy to see this bug is already reported now. I wanted to get this bug reported last week but unable to do so due to abrt unable to report it. I too have been experiencing this whenever I try to use any VM image. So currently I can't use any VM for my work on Fedora 27 installation.

Comment 6 Adam Williamson 2017-09-12 06:29:42 UTC
parag: the VM does actually run, and if you use the system libvirt session rather than a user libvirt session, will survive the session crash, so it'll be there when you log back in. still annoying, though! jonas has come up with a fix upstream, hopefully there'll be a fixed package build soon.

Comment 7 Adam Williamson 2017-09-12 06:30:04 UTC
https://bugzilla.gnome.org/attachment.cgi?id=359569

Comment 8 Adam Williamson 2017-09-13 00:20:03 UTC
I'm doing F27 and Rawhide builds with the fix for this backported. However, F27 git is rather ahead of frozen F27 at this point (3.26.0 vs. 3.25.91), so we need to take an overall look at Beta status and decide whether we want to do a build with just this fix on top of 3.25.91 for Beta, or if we're gonna slip in any case and should maybe just put the whole 3.26.0 into Beta...

Comment 9 Parag Nemade 2017-09-13 04:39:29 UTC
(In reply to Adam Williamson from comment #6)
> parag: the VM does actually run, and if you use the system libvirt session
> rather than a user libvirt session, will survive the session crash, so it'll
> be there when you log back in. still annoying, though! jonas has come up
> with a fix upstream, hopefully there'll be a fixed package build soon.

Yes you are right VM's are still running even after gnome-shell crashes.

Comment 10 Adam Williamson 2017-09-15 01:57:11 UTC
I've started a thread on desktop@ to ask about our strategy for GNOME 3.26 for Beta and for fixing this bug:

https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/thread/B6COT6IZKSZM43QW7VT44M7I57UF33TW/

Comment 11 Adam Williamson 2017-09-15 02:11:26 UTC
Discussed at 2017-09-14 Beta Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2017-09-14/f27-beta-go-no-go-meeting.2017-09-14-17.00.html . Accepted as a blocker as a violation of Beta criterion "The release must be able host virtual guest instances of the same release", as trying to do so with either of the standard apps in GNOME (Boxes or virt-manager) is very likely to crash your session.

Comment 12 Adam Williamson 2017-09-15 02:11:52 UTC
Kicking back to mutter as that's where this actually got fixed.

Comment 13 Fedora Update System 2017-09-15 11:24:18 UTC
adwaita-icon-theme-3.26.0-1.fc27 aisleriot-3.22.3-1.fc27 anjuta-3.26.0-1.fc27 at-spi2-atk-2.26.0-1.fc27 at-spi2-core-2.26.0-1.fc27 atk-2.26.0-1.fc27 baobab-3.26.0-1.fc27 bijiben-3.26.0-1.fc27 cheese-3.26.0-1.fc27 control-center-3.26.0-1.fc27 devhelp-3.26.0-1.fc27 eog-3.26.0-1.fc27 eog-plugins-3.26.0-1.fc27 epiphany-3.26.0-1.fc27 evince-3.26.0-1.fc27 evolution-3.26.0-1.fc27 evolution-data-server-3.26.0-1.fc27 evolution-ews-3.26.0-1.fc27 evolution-mapi-3.26.0-1.fc27 file-roller-3.26.0-1.fc27 five-or-more-3.26.0-1.fc27 four-in-a-row-3.22.2-1.fc27 gdk-pixbuf2-2.36.10-1.fc27 gdm-3.26.0-1.fc27 glib-networking-2.54.0-1.fc27 glib2-2.54.0-1.fc27 glibmm24-2.54.0-1.fc27 gmime30-3.0.2-1.fc27 gnome-backgrounds-3.26.1-1.fc27 gnome-bluetooth-3.26.0-1.fc27 gnome-boxes-3.26.0-1.fc27 gnome-builder-3.26.0-1.fc27 gnome-calculator-3.25.92-1.fc27 gnome-calendar-3.26.0-1.fc27 gnome-characters-3.25.92-1.fc27 gnome-chess-3.26.0-1.fc27 gnome-clocks-3.26.0-1.fc27 gnome-color-manager-3.26.0-1.fc27 gnome-contacts-3.26-1.fc27 gnome-desktop3-3.26.0-1.fc27 gnome-devel-docs-3.26.0-1.fc27 gnome-dictionary-3.26.0-1.fc27 gnome-disk-utility-3.26.0-1.fc27 gnome-documents-3.26.0-1.fc27 gnome-getting-started-docs-3.26.0-1.fc27 gnome-initial-setup-3.26.0-1.fc27 gnome-klotski-3.22.2-1.fc27 gnome-logs-3.26.0-1.fc27 gnome-maps-3.26.0-1.fc27 gnome-mines-3.26.0-1.fc27 gnome-multi-writer-3.26.0-1.fc27 gnome-music-3.26.0-1.fc27 gnome-online-accounts-3.26.0-1.fc27 gnome-online-miners-3.26.0-1.fc27 gnome-packagekit-3.26.0-1.fc27 gnome-photos-3.26.0-1.fc27 gnome-robots-3.22.2-1.fc27 gnome-session-3.26.0-1.fc27 gnome-settings-daemon-3.26.0-1.fc27 gnome-shell-3.26.0-1.fc27 gnome-shell-extensions-3.26.0-1.fc27 gnome-sudoku-3.26.0-1.fc27 gnome-system-monitor-3.26.0-1.fc27 gnome-terminal-3.26.0-1.fc27 gnome-tweak-tool-3.26.0-1.fc27 gnome-user-docs-3.26.0-1.fc27 gnote-3.25.0-1.fc27 gobject-introspection-1.54.0-1.fc27 grilo-plugins-0.3.5-2.fc27 gsettings-desktop-schemas-3.24.1-1.fc27 gspell-1.6.0-1.fc27 gtk3-3.22.21-1.fc27 gtkmm30-3.22.2-1.fc27 gtksourceview3-3.24.4-1.fc27 gtranslator-2.91.7-10.fc27 gucharmap-10.0.1-1.fc27 gupnp-tools-0.8.14-1.fc27 gvfs-1.34.0-1.fc27 json-glib-1.4.2-1.fc27 jsonrpc-glib-3.26.0-2.fc27 libchamplain-0.12.16-1.fc27 libdazzle-3.26.0-1.fc27 libgdl-3.26.0-1.fc27 libgnome-games-support-1.2.3-1.fc27 libgnomekbd-3.26.0-1.fc27 libgtop2-2.38.0-1.fc27 libgweather-3.26.0-1.fc27 libpeas-1.22.0-1.fc27 libsoup-2.60.0-1.fc27 lightsoff-3.26.0-1.fc27 mutter-3.26.0-4.fc27 nautilus-3.26.0-1.fc27 pango-1.40.12-1.fc27 pipewire-0.1.4-3.fc27 polari-3.26.0-1.fc27 pyatspi-2.26.0-2.fc27 pycairo-1.15.2-1.fc27 pygobject3-3.26.0-1.fc27 rygel-0.36.0-1.fc27 simple-scan-3.26.0-1.fc27 swell-foop-3.26.0-1.fc27 sysprof-3.25.92-1.fc27 template-glib-3.26.0-1.fc27 totem-3.26.0-1.fc27 totem-pl-parser-3.26.0-1.fc27 vala-0.38.1-1.fc27 vte291-0.50.0-1.fc27 webkitgtk4-2.18.0-2.fc27 yelp-3.26.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d8c9ac15c3

Comment 14 Fedora Update System 2017-09-15 16:55:47 UTC
adwaita-icon-theme-3.26.0-1.fc27, aisleriot-3.22.3-1.fc27, anjuta-3.26.0-1.fc27, at-spi2-atk-2.26.0-1.fc27, at-spi2-core-2.26.0-1.fc27, atk-2.26.0-1.fc27, baobab-3.26.0-1.fc27, bijiben-3.26.0-1.fc27, cheese-3.26.0-1.fc27, control-center-3.26.0-1.fc27, devhelp-3.26.0-1.fc27, eog-3.26.0-1.fc27, eog-plugins-3.26.0-1.fc27, epiphany-3.26.0-1.fc27, evince-3.26.0-1.fc27, evolution-3.26.0-1.fc27, evolution-data-server-3.26.0-1.fc27, evolution-ews-3.26.0-1.fc27, evolution-mapi-3.26.0-1.fc27, file-roller-3.26.0-1.fc27, five-or-more-3.26.0-1.fc27, four-in-a-row-3.22.2-1.fc27, gdk-pixbuf2-2.36.10-1.fc27, gdm-3.26.0-1.fc27, glib-networking-2.54.0-1.fc27, glib2-2.54.0-1.fc27, glibmm24-2.54.0-1.fc27, gmime30-3.0.2-1.fc27, gnome-backgrounds-3.26.1-1.fc27, gnome-bluetooth-3.26.0-1.fc27, gnome-boxes-3.26.0-1.fc27, gnome-builder-3.26.0-1.fc27, gnome-calculator-3.25.92-1.fc27, gnome-calendar-3.26.0-1.fc27, gnome-characters-3.25.92-1.fc27, gnome-chess-3.26.0-1.fc27, gnome-clocks-3.26.0-1.fc27, gnome-color-manager-3.26.0-1.fc27, gnome-contacts-3.26-1.fc27, gnome-desktop3-3.26.0-1.fc27, gnome-devel-docs-3.26.0-1.fc27, gnome-dictionary-3.26.0-1.fc27, gnome-disk-utility-3.26.0-1.fc27, gnome-documents-3.26.0-1.fc27, gnome-getting-started-docs-3.26.0-1.fc27, gnome-initial-setup-3.26.0-1.fc27, gnome-klotski-3.22.2-1.fc27, gnome-logs-3.26.0-1.fc27, gnome-maps-3.26.0-1.fc27, gnome-mines-3.26.0-1.fc27, gnome-multi-writer-3.26.0-1.fc27, gnome-music-3.26.0-1.fc27, gnome-online-accounts-3.26.0-1.fc27, gnome-online-miners-3.26.0-1.fc27, gnome-packagekit-3.26.0-1.fc27, gnome-photos-3.26.0-1.fc27, gnome-robots-3.22.2-1.fc27, gnome-session-3.26.0-1.fc27, gnome-settings-daemon-3.26.0-1.fc27, gnome-shell-3.26.0-1.fc27, gnome-shell-extensions-3.26.0-1.fc27, gnome-sudoku-3.26.0-1.fc27, gnome-system-monitor-3.26.0-1.fc27, gnome-terminal-3.26.0-1.fc27, gnome-tweak-tool-3.26.0-1.fc27, gnome-user-docs-3.26.0-1.fc27, gnote-3.25.0-1.fc27, gobject-introspection-1.54.0-1.fc27, grilo-plugins-0.3.5-2.fc27, gsettings-desktop-schemas-3.24.1-1.fc27, gspell-1.6.0-1.fc27, gtk3-3.22.21-1.fc27, gtkmm30-3.22.2-1.fc27, gtksourceview3-3.24.4-1.fc27, gtranslator-2.91.7-10.fc27, gucharmap-10.0.1-1.fc27, gupnp-tools-0.8.14-1.fc27, gvfs-1.34.0-1.fc27, json-glib-1.4.2-1.fc27, jsonrpc-glib-3.26.0-2.fc27, libchamplain-0.12.16-1.fc27, libdazzle-3.26.0-1.fc27, libgdl-3.26.0-1.fc27, libgnome-games-support-1.2.3-1.fc27, libgnomekbd-3.26.0-1.fc27, libgtop2-2.38.0-1.fc27, libgweather-3.26.0-1.fc27, libpeas-1.22.0-1.fc27, libsoup-2.60.0-1.fc27, lightsoff-3.26.0-1.fc27, mutter-3.26.0-4.fc27, nautilus-3.26.0-1.fc27, pango-1.40.12-1.fc27, pipewire-0.1.4-3.fc27, polari-3.26.0-1.fc27, pyatspi-2.26.0-2.fc27, pycairo-1.15.2-1.fc27, pygobject3-3.26.0-1.fc27, rygel-0.36.0-1.fc27, simple-scan-3.26.0-1.fc27, swell-foop-3.26.0-1.fc27, sysprof-3.25.92-1.fc27, template-glib-3.26.0-1.fc27, totem-3.26.0-1.fc27, totem-pl-parser-3.26.0-1.fc27, vala-0.38.1-1.fc27, vte291-0.50.0-1.fc27, webkitgtk4-2.18.0-2.fc27, yelp-3.26.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d8c9ac15c3

Comment 15 Fedora Update System 2017-09-15 21:52:23 UTC
adwaita-icon-theme-3.26.0-1.fc27 aisleriot-3.22.3-1.fc27 anjuta-3.26.0-1.fc27 at-spi2-atk-2.26.0-1.fc27 at-spi2-core-2.26.0-1.fc27 atk-2.26.0-1.fc27 baobab-3.26.0-1.fc27 bijiben-3.26.0-1.fc27 cheese-3.26.0-1.fc27 control-center-3.26.0-1.fc27 devhelp-3.26.0-1.fc27 eog-3.26.0-1.fc27 eog-plugins-3.26.0-1.fc27 epiphany-3.26.0-1.fc27 evince-3.26.0-1.fc27 evolution-3.26.0-1.fc27 evolution-data-server-3.26.0-1.fc27 evolution-ews-3.26.0-1.fc27 evolution-mapi-3.26.0-1.fc27 file-roller-3.26.0-1.fc27 five-or-more-3.26.0-1.fc27 four-in-a-row-3.22.2-1.fc27 gdk-pixbuf2-2.36.10-1.fc27 gdm-3.26.0-1.fc27 glib-networking-2.54.0-1.fc27 glib2-2.54.0-1.fc27 glibmm24-2.54.0-1.fc27 gmime30-3.0.2-1.fc27 gnome-backgrounds-3.26.2-1.fc27 gnome-bluetooth-3.26.1-1.fc27 gnome-boxes-3.26.0-1.fc27 gnome-builder-3.26.0-1.fc27 gnome-calculator-3.25.92-1.fc27 gnome-calendar-3.26.0-1.fc27 gnome-characters-3.25.92-1.fc27 gnome-chess-3.26.0-1.fc27 gnome-clocks-3.26.0-1.fc27 gnome-color-manager-3.26.0-1.fc27 gnome-contacts-3.26-1.fc27 gnome-desktop3-3.26.0-1.fc27 gnome-devel-docs-3.26.0-1.fc27 gnome-dictionary-3.26.0-1.fc27 gnome-disk-utility-3.26.0-1.fc27 gnome-documents-3.26.0-1.fc27 gnome-getting-started-docs-3.26.0-1.fc27 gnome-initial-setup-3.26.0-1.fc27 gnome-klotski-3.22.2-1.fc27 gnome-logs-3.26.0-1.fc27 gnome-maps-3.26.0-1.fc27 gnome-mines-3.26.0-1.fc27 gnome-multi-writer-3.26.0-1.fc27 gnome-music-3.26.0-1.fc27 gnome-online-accounts-3.26.0-1.fc27 gnome-online-miners-3.26.0-1.fc27 gnome-packagekit-3.26.0-1.fc27 gnome-photos-3.26.0-1.fc27 gnome-robots-3.22.2-1.fc27 gnome-session-3.26.0-1.fc27 gnome-settings-daemon-3.26.0-1.fc27 gnome-shell-3.26.0-1.fc27 gnome-shell-extensions-3.26.0-1.fc27 gnome-sudoku-3.26.0-1.fc27 gnome-system-monitor-3.26.0-1.fc27 gnome-terminal-3.26.0-1.fc27 gnome-tweak-tool-3.26.0-1.fc27 gnome-user-docs-3.26.0-1.fc27 gnote-3.25.0-1.fc27 gobject-introspection-1.54.0-1.fc27 grilo-plugins-0.3.5-2.fc27 gsettings-desktop-schemas-3.24.1-1.fc27 gspell-1.6.0-1.fc27 gtk3-3.22.21-1.fc27 gtkmm30-3.22.2-1.fc27 gtksourceview3-3.24.4-1.fc27 gtranslator-2.91.7-10.fc27 gucharmap-10.0.1-1.fc27 gupnp-tools-0.8.14-1.fc27 gvfs-1.34.0-1.fc27 json-glib-1.4.2-1.fc27 jsonrpc-glib-3.26.0-2.fc27 libchamplain-0.12.16-1.fc27 libdazzle-3.26.0-1.fc27 libgdl-3.26.0-1.fc27 libgnome-games-support-1.2.3-1.fc27 libgnomekbd-3.26.0-1.fc27 libgtop2-2.38.0-1.fc27 libgweather-3.26.0-1.fc27 libpeas-1.22.0-1.fc27 libsoup-2.60.0-1.fc27 lightsoff-3.26.0-1.fc27 mutter-3.26.0-4.fc27 nautilus-3.26.0-1.fc27 orca-3.26.0-1.fc27 pango-1.40.12-1.fc27 pipewire-0.1.4-3.fc27 polari-3.26.0-1.fc27 pyatspi-2.26.0-2.fc27 pycairo-1.15.2-1.fc27 pygobject3-3.26.0-1.fc27 rygel-0.36.0-1.fc27 simple-scan-3.26.0-1.fc27 swell-foop-3.26.0-1.fc27 sysprof-3.25.92-1.fc27 template-glib-3.26.0-1.fc27 totem-3.26.0-1.fc27 totem-pl-parser-3.26.0-1.fc27 tracker-2.0.0-2.fc27 tracker-miners-2.0.0-2.fc27 vala-0.38.1-1.fc27 vte291-0.50.0-1.fc27 webkitgtk4-2.18.0-2.fc27 yelp-3.26.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d8c9ac15c3

Comment 16 Adam Williamson 2017-09-16 04:33:22 UTC
Note the update currently proposed to fix this is the GNOME 3.26.0 mega-update. We're not sure yet whether we'll actually include that in the Beta, I am about to file a proposed FE bug for it. If we decide not to, we will send out an update more targeted to fix this (i.e. a mutter-only update).

Comment 17 Adam Williamson 2017-09-16 05:56:02 UTC
Tested with the mega-update, I can start a VM in virt-manager, the 'inhibit shortcuts' dialog displays correctly, and GNOME doesn't crash. A+ would run again!

Comment 18 Fedora Update System 2017-09-16 18:21:37 UTC
adwaita-icon-theme-3.26.0-1.fc27, aisleriot-3.22.3-1.fc27, anjuta-3.26.0-1.fc27, at-spi2-atk-2.26.0-1.fc27, at-spi2-core-2.26.0-1.fc27, atk-2.26.0-1.fc27, baobab-3.26.0-1.fc27, bijiben-3.26.0-1.fc27, cheese-3.26.0-1.fc27, control-center-3.26.0-1.fc27, devhelp-3.26.0-1.fc27, eog-3.26.0-1.fc27, eog-plugins-3.26.0-1.fc27, epiphany-3.26.0-1.fc27, evince-3.26.0-1.fc27, evolution-3.26.0-1.fc27, evolution-data-server-3.26.0-1.fc27, evolution-ews-3.26.0-1.fc27, evolution-mapi-3.26.0-1.fc27, file-roller-3.26.0-1.fc27, five-or-more-3.26.0-1.fc27, four-in-a-row-3.22.2-1.fc27, gdk-pixbuf2-2.36.10-1.fc27, gdm-3.26.0-1.fc27, glib-networking-2.54.0-1.fc27, glib2-2.54.0-1.fc27, glibmm24-2.54.0-1.fc27, gmime30-3.0.2-1.fc27, gnome-backgrounds-3.26.2-1.fc27, gnome-bluetooth-3.26.1-1.fc27, gnome-boxes-3.26.0-1.fc27, gnome-builder-3.26.0-1.fc27, gnome-calculator-3.25.92-1.fc27, gnome-calendar-3.26.0-1.fc27, gnome-characters-3.25.92-1.fc27, gnome-chess-3.26.0-1.fc27, gnome-clocks-3.26.0-1.fc27, gnome-color-manager-3.26.0-1.fc27, gnome-contacts-3.26-1.fc27, gnome-desktop3-3.26.0-1.fc27, gnome-devel-docs-3.26.0-1.fc27, gnome-dictionary-3.26.0-1.fc27, gnome-disk-utility-3.26.0-1.fc27, gnome-documents-3.26.0-1.fc27, gnome-getting-started-docs-3.26.0-1.fc27, gnome-initial-setup-3.26.0-1.fc27, gnome-klotski-3.22.2-1.fc27, gnome-logs-3.26.0-1.fc27, gnome-maps-3.26.0-1.fc27, gnome-mines-3.26.0-1.fc27, gnome-multi-writer-3.26.0-1.fc27, gnome-music-3.26.0-1.fc27, gnome-online-accounts-3.26.0-1.fc27, gnome-online-miners-3.26.0-1.fc27, gnome-packagekit-3.26.0-1.fc27, gnome-photos-3.26.0-1.fc27, gnome-robots-3.22.2-1.fc27, gnome-session-3.26.0-1.fc27, gnome-settings-daemon-3.26.0-1.fc27, gnome-shell-3.26.0-1.fc27, gnome-shell-extensions-3.26.0-1.fc27, gnome-sudoku-3.26.0-1.fc27, gnome-system-monitor-3.26.0-1.fc27, gnome-terminal-3.26.0-1.fc27, gnome-tweak-tool-3.26.0-1.fc27, gnome-user-docs-3.26.0-1.fc27, gnote-3.25.0-1.fc27, gobject-introspection-1.54.0-1.fc27, grilo-plugins-0.3.5-2.fc27, gsettings-desktop-schemas-3.24.1-1.fc27, gspell-1.6.0-1.fc27, gtk3-3.22.21-1.fc27, gtkmm30-3.22.2-1.fc27, gtksourceview3-3.24.4-1.fc27, gtranslator-2.91.7-10.fc27, gucharmap-10.0.1-1.fc27, gupnp-tools-0.8.14-1.fc27, gvfs-1.34.0-1.fc27, json-glib-1.4.2-1.fc27, jsonrpc-glib-3.26.0-2.fc27, libchamplain-0.12.16-1.fc27, libdazzle-3.26.0-1.fc27, libgdl-3.26.0-1.fc27, libgnome-games-support-1.2.3-1.fc27, libgnomekbd-3.26.0-1.fc27, libgtop2-2.38.0-1.fc27, libgweather-3.26.0-1.fc27, libpeas-1.22.0-1.fc27, libsoup-2.60.0-1.fc27, lightsoff-3.26.0-1.fc27, mutter-3.26.0-4.fc27, nautilus-3.26.0-1.fc27, orca-3.26.0-1.fc27, pango-1.40.12-1.fc27, pipewire-0.1.4-3.fc27, polari-3.26.0-1.fc27, pyatspi-2.26.0-2.fc27, pycairo-1.15.2-1.fc27, pygobject3-3.26.0-1.fc27, rygel-0.36.0-1.fc27, simple-scan-3.26.0-1.fc27, swell-foop-3.26.0-1.fc27, sysprof-3.26.0-1.fc27, template-glib-3.26.0-1.fc27, totem-3.26.0-1.fc27, totem-pl-parser-3.26.0-1.fc27, tracker-2.0.0-2.fc27, tracker-miners-2.0.0-2.fc27, vala-0.38.1-1.fc27, vte291-0.50.0-1.fc27, webkitgtk4-2.18.0-2.fc27, yelp-3.26.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d8c9ac15c3

Comment 19 Kamil Páral 2017-09-18 18:22:33 UTC
Back to verified.

Comment 20 Fedora Update System 2017-09-18 19:41:32 UTC
adwaita-icon-theme-3.26.0-1.fc27, aisleriot-3.22.3-1.fc27, anjuta-3.26.0-1.fc27, at-spi2-atk-2.26.0-1.fc27, at-spi2-core-2.26.0-1.fc27, atk-2.26.0-1.fc27, baobab-3.26.0-1.fc27, bijiben-3.26.0-1.fc27, cheese-3.26.0-1.fc27, control-center-3.26.0-1.fc27, devhelp-3.26.0-1.fc27, eog-3.26.0-1.fc27, eog-plugins-3.26.0-1.fc27, epiphany-3.26.0-1.fc27, evince-3.26.0-1.fc27, evolution-3.26.0-1.fc27, evolution-data-server-3.26.0-1.fc27, evolution-ews-3.26.0-1.fc27, evolution-mapi-3.26.0-1.fc27, file-roller-3.26.0-1.fc27, five-or-more-3.26.0-1.fc27, four-in-a-row-3.22.2-1.fc27, gdk-pixbuf2-2.36.10-1.fc27, gdm-3.26.0-1.fc27, glib-networking-2.54.0-1.fc27, glib2-2.54.0-1.fc27, glibmm24-2.54.0-1.fc27, gmime30-3.0.2-1.fc27, gnome-backgrounds-3.26.2-1.fc27, gnome-bluetooth-3.26.1-1.fc27, gnome-boxes-3.26.0-1.fc27, gnome-builder-3.26.0-1.fc27, gnome-calculator-3.25.92-1.fc27, gnome-calendar-3.26.0-1.fc27, gnome-characters-3.25.92-1.fc27, gnome-chess-3.26.0-1.fc27, gnome-clocks-3.26.0-1.fc27, gnome-color-manager-3.26.0-1.fc27, gnome-contacts-3.26-1.fc27, gnome-desktop3-3.26.0-1.fc27, gnome-devel-docs-3.26.0-1.fc27, gnome-dictionary-3.26.0-1.fc27, gnome-disk-utility-3.26.0-1.fc27, gnome-documents-3.26.0-1.fc27, gnome-getting-started-docs-3.26.0-1.fc27, gnome-initial-setup-3.26.0-1.fc27, gnome-klotski-3.22.2-1.fc27, gnome-logs-3.26.0-1.fc27, gnome-maps-3.26.0-1.fc27, gnome-mines-3.26.0-1.fc27, gnome-multi-writer-3.26.0-1.fc27, gnome-music-3.26.0-1.fc27, gnome-online-accounts-3.26.0-1.fc27, gnome-online-miners-3.26.0-1.fc27, gnome-packagekit-3.26.0-1.fc27, gnome-photos-3.26.0-1.fc27, gnome-robots-3.22.2-1.fc27, gnome-session-3.26.0-1.fc27, gnome-settings-daemon-3.26.0-1.fc27, gnome-shell-3.26.0-1.fc27, gnome-shell-extensions-3.26.0-1.fc27, gnome-sudoku-3.26.0-1.fc27, gnome-system-monitor-3.26.0-1.fc27, gnome-terminal-3.26.0-1.fc27, gnome-tweak-tool-3.26.0-1.fc27, gnome-user-docs-3.26.0-1.fc27, gnote-3.25.0-1.fc27, gobject-introspection-1.54.0-1.fc27, grilo-plugins-0.3.5-2.fc27, gsettings-desktop-schemas-3.24.1-1.fc27, gspell-1.6.0-1.fc27, gtk3-3.22.21-1.fc27, gtkmm30-3.22.2-1.fc27, gtksourceview3-3.24.4-1.fc27, gtranslator-2.91.7-10.fc27, gucharmap-10.0.1-1.fc27, gupnp-tools-0.8.14-1.fc27, gvfs-1.34.0-1.fc27, json-glib-1.4.2-1.fc27, jsonrpc-glib-3.26.0-2.fc27, libchamplain-0.12.16-1.fc27, libdazzle-3.26.0-1.fc27, libgdl-3.26.0-1.fc27, libgnome-games-support-1.2.3-1.fc27, libgnomekbd-3.26.0-1.fc27, libgtop2-2.38.0-1.fc27, libgweather-3.26.0-1.fc27, libpeas-1.22.0-1.fc27, libsoup-2.60.0-1.fc27, lightsoff-3.26.0-1.fc27, mutter-3.26.0-4.fc27, nautilus-3.26.0-1.fc27, orca-3.26.0-1.fc27, pango-1.40.12-1.fc27, pipewire-0.1.4-3.fc27, polari-3.26.0-1.fc27, pyatspi-2.26.0-2.fc27, pycairo-1.15.2-1.fc27, pygobject3-3.26.0-1.fc27, rygel-0.36.0-1.fc27, simple-scan-3.26.0-1.fc27, swell-foop-3.26.0-1.fc27, sysprof-3.26.0-1.fc27, template-glib-3.26.0-1.fc27, totem-3.26.0-1.fc27, totem-pl-parser-3.26.0-1.fc27, tracker-2.0.0-2.fc27, tracker-miners-2.0.0-2.fc27, vala-0.38.1-1.fc27, vte291-0.50.0-1.fc27, webkitgtk4-2.18.0-2.fc27, yelp-3.26.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.