Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1490351 - gnome-shell crashes 10+ times a day due to gjs bug, we need to either upgrade to 1.49.92 or downgrade to 1.48.7
gnome-shell crashes 10+ times a day due to gjs bug, we need to either upgrade...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gjs (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks: F27FinalBlocker
  Show dependency treegraph
 
Reported: 2017-09-11 07:56 EDT by František Zatloukal
Modified: 2017-12-12 00:35 EST (History)
13 users (show)

See Also:
Fixed In Version: gjs-1.50.0-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-25 14:07:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description František Zatloukal 2017-09-11 07:56:04 EDT
Description of problem:
The version of gjs in Fedora 27 and 28 is pretty old and known to crash often[0] taking down whole session on Wayland.

This is pretty significant regression compared to state on Fedora 26 where is older gjs (1.48.x) but with fixed crashes.

Version-Release number of selected component (if applicable):
gjs-1.49.3-3.fc27.x86_64


I can think of two possible solutions:
*Get mozjs52 packaged to Fedora and upgrade gjs to latest version with fixes for crashes

*Downgrade gjs to 1.48.x which will fix crashing and does not depend on mozjs52

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1456293
Comment 1 Fedora Blocker Bugs Application 2017-09-11 09:33:13 EDT
Proposed as a Blocker for 27-final by Fedora user frantisekz using the blocker tracking app because:

 Fedora 26 has been plagued by https://bugzilla.redhat.com/show_bug.cgi?id=1456293 long after the release. These issues are fixed now in F26, but not in F27. Having them again would mean significant degradation in user experience.

Apart from that, because of "random nature" of crash, it could possibly occur during the installation and bring it down. (gjs crash on Wayland takes down the whole session).
Comment 2 Yanko Kaneti 2017-09-11 10:30:28 EDT
See also bug 1490432
Recent gnome-weather needs a newer gjs or some targeted reverts
Comment 3 Kamil Páral 2017-09-11 14:33:26 EDT
Discussed during blocker review [1]:

RejectedBlocker (Final) - this bug is simply about the availability of a new version, that is not a reasonable candidate for blocker status. We will ask reporters to nominate actual functional bugs that are fixed by the new version as blockers, and we'll evaluate those on their merits

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-11/
Comment 4 Hans de Goede 2017-09-14 05:08:36 EDT
Hi,

(In reply to Kamil Páral from comment #3)
> Discussed during blocker review [1]:
> 
> RejectedBlocker (Final) - this bug is simply about the availability of a new
> version, that is not a reasonable candidate for blocker status. We will ask
> reporters to nominate actual functional bugs that are fixed by the new
> version as blockers, and we'll evaluate those on their merits
> 
> [1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-09-11/

Hmm, it seems you (everyone in the meeting) is missing some background here, this is not about getting a new version in, this is about getting a version in which is not causing gnome-shell to crash 10-20 times a day (with certain use-patterns).

There been a number of gjs bug-fixes which are in F26-updates now, but which are lacking in in F27.

You are probably not going to like this, but since the motivation for not accepting this as a blocker has nothing to do with why this was proposed as a blocker, I'm going to ask you to reconsider and remove the RejectedBlocker from the whiteboard.  This is NOT about making sure we ship the latest version, as mentioned a downgrade to 1.48 may be an option (assuming gnome-3.26 can work with 1.48).

I've also updated the bug summary to reflect this.

This will likely get refused as a blocker again because it does not break installs, but IMHO shipping F27 final with a known and frequently happening gnome-shell crashing bug is unacceptable.

Regards,

Hans
Comment 5 Hans de Goede 2017-09-14 05:26:27 EDT
Ok, so I just downgraded my main workstation's gjs install from 1.49.3 to 1.48.7 and gnome still works fine. 

Can we please consider this as a solution to these crashes?
Comment 6 Kamil Páral 2017-09-14 10:34:53 EDT
Hi Hans. So what is the bug you're talking about, is it bug 1456293 or something else? We need to know the details.

If it's bug 1456293, we already voted on that regarding blocking Beta. We rejected it as a blocker, but accepted it as a freeze exception (so that a package fixing the issues can be pushed through Beta freeze). It hasn't been voted on regarding Final release. If you disagree with the decision, please raise your concerns there (remove RejectedBlocker). Please include useful details, e.g. what the usage patterns are to cause this crash, and how many users you estimate this affects.

If it's a different bug you're talking about, please propose that as a blocker or a freeze exception.

Thanks a lot.

Please note that rejecting a bug as a blocker doesn't mean the fix can't be pushed stable. After Beta freeze is over, there's nothing stopping gjs maintainer to update this package. Blocker status is simply to ensure that Fedora will not be released until this is fixed. If you want to achieve that, we need more details as mentioned (if it crashes often but for just a few people, we can't stop the whole release because of that). Also please note that freeze exception is a different concept, it means we will take the fix even when we're in freeze, even for non-blocker bugs, but rather annoying/inconvenient/safe-to-fix issues. Freeze exception is not required outside of update freeze.
Comment 7 Hans de Goede 2017-09-14 10:53:21 EDT
Hi Kamil,

Thank you for your response, yes the bug I and quite a few others are seeing is (more or less it is hard to pin down, but the symptoms are the same) bug 1456293.

I agree that that should not be a BetaBlocker, I do believe it should be a FinalBlocker. Since we're going to use that bug to track this I've re-added RejectedBlocker here.

Regards,

Hans
Comment 8 Fedora Update System 2017-09-20 22:30:03 EDT
gnome-weather-3.26.0-2.fc27 mozjs52-52.3.0-1.fc27 gjs-1.50.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-275b1e9bf2
Comment 9 Kamil Páral 2017-09-21 03:20:36 EDT
Those of you affected, please test update from comment 8 and add karma, thanks.
Comment 10 Fedora Update System 2017-09-21 19:58:37 EDT
gjs-1.50.0-1.fc27, gnome-weather-3.26.0-2.fc27, mozjs52-52.3.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-275b1e9bf2
Comment 11 Fedora Update System 2017-09-25 14:07:28 EDT
gjs-1.50.0-1.fc27, gnome-weather-3.26.0-2.fc27, mozjs52-52.3.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Shirley Zhou 2017-12-12 00:35:07 EST
I keep meeting gnome crash issue with builds as following
gjs-1.50.2-1.fc27.x86_64
mozjs52-52.5.0-1.fc27.x86_64
gnome-weather-3.26.0-2.fc27.noarch

Note You need to log in before you can comment on or make changes to this bug.