Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1490399 - RHEL 7 sap-hana and sap-hana-vmware tuned profiles using eth0 [NEEDINFO]
RHEL 7 sap-hana and sap-hana-vmware tuned profiles using eth0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.5
x86_64 Linux
medium Severity medium
: rc
: 7.5
Assigned To: Jaroslav Škarvada
Tereza Cerna
: Patch, Upstream
Depends On: TUNED-7.5-REBASE
Blocks: 1522983 1496921
  Show dependency treegraph
 
Reported: 2017-09-11 09:14 EDT by David Wood
Modified: 2018-04-10 12:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: tuned-2.9.0-0.1.rc1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 12:04:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fdanapfe: needinfo? (dwood)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0879 normal SHIPPED_LIVE tuned bug fix and enhancement update 2018-04-10 09:39:08 EDT

  None (edit)
Description David Wood 2017-09-11 09:14:20 EDT
Description of problem:
RHEL 7 sap-hana and sap-hana-vmware tuned profiles using eth0

Version-Release number of selected component (if applicable):
RHEL 7 sap-hana and sap-hana-vmware tuned profiles

How reproducible:


Steps to Reproduce:
1. Looking at script.sh for the profiles


Actual results:
start() {
        ethtool -K eth0 lro off
        return 0
}
stop() {
        ethtool -K eth0 lro on
        return 0
}

Expected results:
Instead of eth0 should be RHEL 7 NIC name

Additional info:
Comment 3 Jaroslav Škarvada 2017-09-19 10:04:32 EDT
Upstream pull request:
https://github.com/redhat-performance/tuned/pull/70
Comment 5 Jaroslav Škarvada 2017-09-19 10:56:24 EDT
Upstream commit fixing the problem:
https://github.com/redhat-performance/tuned/pull/70/commits/b970238a3da96caa2b6e77ad2a56fa65fe3a9661

There is now sap-hana-vmware-variables.conf file with the variable 'sap_hana_vmware_nic', just set it to the client NIC (or NICs) if you want the tuning, e.g. for eth0:

sap_hana_vmware_nic=eth0

Or for eth0, eth1:

sap_hana_vmware_nic=eth0, eth1

Or for anything with the eth prefix:

sap_hana_vmware_nic=eth*

Or for anything else than eth1:

sap_hana_vmware_nic=!eth1

I.e. anything the Tuned syntax supports can be used.
Comment 12 Tereza Cerna 2018-01-18 06:11:34 EST
=============================================
Verified in:
   tuned-2.9.0-1.el7.noarch
   tuned-profiles-sap-hana-2.9.0-1.el7.noarch
=============================================

>> Patch was applied. Source code corresponds to patches.

# ls /etc/tuned/
active_profile  bootcmdline  profile_mode  recommend.d  sap-hana-vmware-variables.conf  tuned-main.conf

>> There is file sap-hana-vmware-variables.conf to specify interface.

>> 1. TEST - no NIC will be applied

# cat /etc/tuned/sap-hana-vmware-variables.conf 
sap_hana_vmware_nic=!*
# tuned-adm profile sap-hana-vmware
# cat /var/log/tuned/tuned.log | grep 'tuned.plugins.base' | grep 'instance net'
2018-01-18 05:42:01,888 WARNING  tuned.plugins.base: instance net: no matching devices available

# ethtool -k eno1 |grep large-receive-offload
large-receive-offload: on
# ethtool -k eno2 |grep large-receive-offload
large-receive-offload: on

>> Profile sap-hana-vmware was applied. There was specified that no NIC would be set, so LRO was not set to 'off' value.

>> 2. TEST - all NIC will be applied

# cat /etc/tuned/sap-hana-vmware-variables.conf 
sap_hana_vmware_nic=*
# tuned-adm profile sap-hana-vmware 
# cat /var/log/tuned/tuned.log | grep 'tuned.plugins.base' | grep 'instance net'
2018-01-18 06:05:37,621 INFO     tuned.plugins.base: instance net: assigning devices eno1, eno2

# ethtool -k eno1 |grep large-receive-offload
large-receive-offload: off
# ethtool -k eno2 |grep large-receive-offload
large-receive-offload: off

>> Profile sap-hana-vmware was applied. There was specified that all NIC would be set, so LRO was disabled (set to 'off' value).

# tuned-adm profile balanced
# ethtool -k eno1 |grep large-receive-offload
large-receive-offload: on
# ethtool -k eno2 |grep large-receive-offload
large-receive-offload: on

>> When we applied another profile, LRO changed to 'on' values.

>> 3. TEST - only one NIC will be applied

# cat /etc/tuned/sap-hana-vmware-variables.conf 
sap_hana_vmware_nic=eno2
# tuned-adm profile sap-hana-vmware
# cat /var/log/tuned/tuned.log | grep 'tuned.plugins.base' | grep 'instance net'
2018-01-18 06:08:27,695 INFO     tuned.plugins.base: instance net: assigning devices eno2

# ethtool -k eno1 |grep large-receive-offload
large-receive-offload: on
# ethtool -k eno2 |grep large-receive-offload
large-receive-offload: off

=============================================
Reproduced in:
   tuned-2.8.0-5.el7.noarch
   tuned-profiles-sap-hana-2.8.0-5.el7.noarch
=============================================

This bug is new feature. There isn't possible to disable LRO for specified NIC.
Comment 13 Tereza Cerna 2018-01-18 06:19:16 EST
These variants of sap-hana-vmware-variables.conf were tested:
  sap_hana_vmware_nic=!*
  sap_hana_vmware_nic=*
  sap_hana_vmware_nic=eno1, eno2
  sap_hana_vmware_nic=eno2
  sap_hana_vmware_nic=eno1, !eno2
  sap_hana_vmware_nic=!eno1
Comment 14 Frank Danapfel 2018-01-18 07:57:59 EST
Tereza, thanks for the verification and for clarifying how to correctly configure the sap-hana-vmware-variables.conf. I wasn't aware that the file is actually located in /etc/tuned/.

This should be documented in a kbase or something so that we can reference it in the SAP documentation.
Comment 17 errata-xmlrpc 2018-04-10 12:04:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0879

Note You need to log in before you can comment on or make changes to this bug.