Bug 149081 - mk-images.ppc doesn't create 64-bit Mac bootable images.
Summary: mk-images.ppc doesn't create 64-bit Mac bootable images.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 151676 (view as bug list)
Depends On:
Blocks: fedora-ppc
TreeView+ depends on / blocked
 
Reported: 2005-02-18 16:00 UTC by David Woodhouse
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 10.2.0.20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 13:04:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to create 64-bit mac boot.iso (2.50 KB, patch)
2005-02-18 16:00 UTC, David Woodhouse
no flags Details | Diff

Description David Woodhouse 2005-02-18 16:00:08 UTC
Eventually it'd be nice to have single CD image which is bootable on
all machines, but for now it'll suffice just to build an
images/mac64/boot.iso

Comment 1 David Woodhouse 2005-02-18 16:00:51 UTC
Created attachment 111208 [details]
Patch to create 64-bit mac boot.iso

Comment 2 Paul Nasrat 2005-02-19 17:49:33 UTC
Thanks for the patch commited

Comment 3 David Woodhouse 2005-03-16 23:13:04 UTC
The patch added a new file bootdisk/ppc/yaboot.conf.mac64 which you didn't 'cvs
add'.

Comment 4 Paul Nasrat 2005-03-17 10:49:07 UTC
Oops, sorry. Done.

Comment 5 Andrew Cagney 2005-03-18 16:25:13 UTC
Fedora Core 4 Test 1 shipped with this bug.

The ISO boots, but yaboot can't load the kernel as yaboot.conf is missing.

Workaround (really messy):

- from OS-X create a small (100mb?) hfs (not hfs+) partition; make a note of the
parition number (how I'm not sure :-)

- from OS-X copy the contents of the 64-bit boot iso (in particular ppc/mac64/
vmlinuz, yaboot, and ramdisk.image.gz) to that disk (at the top level)

- from OS-X copy from the 32-bit ISO the file ppc/mac/yaboot.conf to the top level

- edit the copied yaboot.conf so that paths such as:
    cd:,\ppc\mac\vmlinuz
are replaced with simpler
    hd:,vmlinuz
(or is that)
    hd:2,\vmlinuz
(where 2 is that partition number)

- reboot machine, during <boing> hold down <apple><option><o><f>
(don't try doing this when using a microsoft keyboard :-/)

- at the OK> prompt enter
    boot hd:<PARTNUMBER>,yaboot
e.g.,
    boot hd:2,\yaboot
from the OK> prompt you can actually fish for that yaboot image vis:
    boot hd:1,\yaboot
    boot hd:2,\yaboot
....

- continue as normal

Comment 6 Paul Nasrat 2005-03-21 17:54:46 UTC
*** Bug 151676 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.