Bug 1491333 - kickstart installations using autopart fail with 'Kickstart insufficient'
Summary: kickstart installations using autopart fail with 'Kickstart insufficient'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F27BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-09-13 14:11 UTC by Paul Whalen
Modified: 2017-10-05 21:03 UTC (History)
17 users (show)

Fixed In Version: anaconda-27.20.1-4 anaconda-27.20.1-4.fc27 anaconda-27.20.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-05 21:03:24 UTC
Type: Bug


Attachments (Terms of Use)
anaconda.log (22.72 KB, text/plain)
2017-09-13 14:55 UTC, Paul Whalen
no flags Details
dnf.librepo.log (11.13 KB, text/plain)
2017-09-13 14:55 UTC, Paul Whalen
no flags Details
packaging.log (1.14 KB, text/plain)
2017-09-13 14:55 UTC, Paul Whalen
no flags Details
program.log (27.33 KB, text/plain)
2017-09-13 14:56 UTC, Paul Whalen
no flags Details
storage.log (99.20 KB, text/plain)
2017-09-13 14:56 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2017-09-13 14:11:40 UTC
Description of problem:
Automatic partitioning fails when using a kickstart with the Fedora-27-20170912.n.0 compose

Version-Release number of selected component (if applicable):
anaconda-27.20.1-1.fc27

How reproducible:
This also caused the Docker images to fail with the Fedora-27-20170912.n.0 compose. 

Docker:
https://koji.fedoraproject.org/koji/taskinfo?taskID=21818630

Comment 1 Paul Whalen 2017-09-13 14:28:47 UTC
Nominating as a blocker for Beta, this breaks unattended installations and Docker images.

Comment 2 Paul Whalen 2017-09-13 14:55:02 UTC
Created attachment 1325497 [details]
anaconda.log

Comment 3 Paul Whalen 2017-09-13 14:55:27 UTC
Created attachment 1325498 [details]
dnf.librepo.log

Comment 4 Paul Whalen 2017-09-13 14:55:59 UTC
Created attachment 1325499 [details]
packaging.log

Comment 5 Paul Whalen 2017-09-13 14:56:24 UTC
Created attachment 1325500 [details]
program.log

Comment 6 Paul Whalen 2017-09-13 14:56:49 UTC
Created attachment 1325501 [details]
storage.log

Comment 7 Martin Kolman 2017-09-13 15:14:18 UTC
This seems to be the cause for "Kickstart insufficient":

14:49:39,649 ERR ui.tui.spokes.storage: storage configuration failed: Not enough free space on disks for automatic partitioning (from anaconda.log)

Still unclear why that happens as clearpart has been used & there should be more than enough space (the docker build has a 5 GB disk and the ARM install seems to have a ~111 GB disk) once any previous on-disk data is cleared.

Comment 8 David Lehman 2017-09-13 16:13:07 UTC
It's trying to run clearpart & autopart twice. The first pass succeeds.

Comment 9 Vendula Poncova 2017-09-14 11:49:47 UTC
Should be fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1187

Comment 10 Dennis Gilmore 2017-09-14 17:16:56 UTC
+1 blocker

Comment 11 Adam Williamson 2017-09-15 02:01:27 UTC
Discussed at 2017-09-14 Beta Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2017-09-14/f27-beta-go-no-go-meeting.2017-09-14-17.00.html . Accepted as a blocker as a violation of Alpha criteria "The installer must be able to complete a scripted installation which duplicates the default interactive installation as closely as possible" and "Any installation method or process designed to run unattended must do so. There should be no prompts requiring user intervention" .

Comment 12 Peter Robinson 2017-09-18 12:25:18 UTC
Can we actually get this build done in koji?

Comment 13 Martin Kolman 2017-09-18 12:32:42 UTC
(In reply to Peter Robinson from comment #12)
> Can we actually get this build done in koji?
Build already running:
https://fedoraproject.org/wiki/Changes/Modular_Server

Will create a Bodhi update once the build is finished.

Comment 14 Fedora Update System 2017-09-18 12:47:09 UTC
anaconda-27.20.1-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7363380ee9

Comment 15 Fedora Update System 2017-09-18 22:23:05 UTC
anaconda-27.20.1-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7363380ee9

Comment 16 Fedora Update System 2017-09-20 15:26:17 UTC
anaconda-27.20.1-4.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Kamil Páral 2017-09-20 15:32:29 UTC
This is an accepted blocker, we still need to verify the fix.

Comment 18 Kamil Páral 2017-09-21 08:16:38 UTC
This needs to be tested with 20170921 compose. Can somebody (Paul) include the affected kickstart in the meantime?

Comment 19 Paul Whalen 2017-09-21 19:11:02 UTC
This is verified fixed with anaconda-27.20.1-4, kickstart install completed, docker images included.

Comment 20 Fedora Update System 2017-09-29 16:06:36 UTC
anaconda-27.20.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 21 Fedora Update System 2017-10-02 00:55:38 UTC
anaconda-27.20.2-1.fc27, pykickstart-2.39-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 22 Fedora Update System 2017-10-02 10:50:20 UTC
anaconda-27.20.2-1.fc27 pykickstart-2.39-1.fc27 python-simpleline-0.6-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 23 Fedora Update System 2017-10-02 21:25:57 UTC
anaconda-27.20.2-1.fc27, pykickstart-2.39-1.fc27, python-simpleline-0.6-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 24 Fedora Update System 2017-10-05 21:03:24 UTC
anaconda-27.20.2-1.fc27, pykickstart-2.39-1.fc27, python-simpleline-0.6-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.