This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 149137 - Dependency on gnome-python2-gnomevfs missing
Dependency on gnome-python2-gnomevfs missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
: 151577 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-02-18 22:43 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-07 10:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-02-18 22:43:56 EST
Firstboot failed to run on a fresh rawhide install because
gnome-python2-gnomevfs wasn't installed. It also failed because $LANG wasn't set.
Comment 1 Ricky Ng-Adam 2005-03-30 23:13:41 EST
The problem is still there with firstboot-1.3.39-3.
Comment 2 Ricky Ng-Adam 2005-03-31 22:08:14 EST
ok, in rawhide's firstboot-1.3.39-3 the program will silently fail even with
gnome-python2-gnomevfs.

If I start it with --debug, I get this:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 492, in loadModules
    vbox, pix, title = module.launch(self.doDebug)
  File "/usr/share/firstboot/modules/eula.py", line 47, in launch
    lang = os.environ["LANG"]
  File "/usr/lib/python2.4/UserDict.py", line 17, in __getitem__
    def __getitem__(self, key): return self.data[key]
KeyError: 'LANG'
Comment 3 Jeremy Katz 2005-07-06 18:15:26 EDT
*** Bug 151577 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2005-07-07 10:20:31 EDT
Works for me in Rawhide with version 1.3.42-1.  Please reopen if you are still
seeing problems.

Note You need to log in before you can comment on or make changes to this bug.