Bug 149161 - megaraid driver doesn't recognize logical RAID drives on install
megaraid driver doesn't recognize logical RAID drives on install
Status: CLOSED DUPLICATE of bug 140115
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-02-19 11:53 EST by Richard L. Goerwitz III
Modified: 2015-01-04 17:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-19 14:20:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard L. Goerwitz III 2005-02-19 11:53:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
RHEL AS 4.0 doesn't recognize old-style Dell PERC 2/DC cards (Megaraid/LSI) on install and forces the installer to pick a driver.  It loads the megaraid_mbox module, but sees nothing and prompts the installer to select one.  When the installer chooses the Megaraid driver (which is in fact already loaded), the installation proceeds but no logical drives are ever found, and the installation aborts.  There is no option to use the old, working 'megaraid' driver - only 'megaraid_mbox'.

Version-Release number of selected component (if applicable):
(RHEL AS 4.0 install disks)

How reproducible:

Steps to Reproduce:
1. Insert RHEL AS 4.0 install disk into drive
2. Begin install
3. Watch auto-detection fail and manually select LSI/Megaraid driver
4. Continue with install
5. Watch install bomb when RHEL can't find any drives

Actual Results:  The installation aborted

Expected Results:  The installation should not have aborted

Additional info:

This is exactly the same problem that affected Fedora core 3 and was widely discussed in a variety of threads, primarily bug # 138590.
Comment 1 Richard L. Goerwitz III 2005-02-19 12:30:15 EST
Just checked and it appears that the stock kernel no longer includes the
megaraid driver, only the new megaraid_mbox/megaraid_mm drivers.

Linux generally is known for running well with few resources on machines that
cost less, and that (for Windows purposes) would normally be considered 'old.'

It would be great therefore if RedHat left support in for the old megaraid
driver that worked perfectly well and won't need to change at this point.  A lot
of machines with the old megaraid cards are still running RedHat Linux and still
fully capable of running RHEL AS/ES 4.0 very well.  They're great test machines,
among other things.

Would be great if we could use them with RHEL 4.0.
Comment 2 Jay Turner 2005-02-19 14:20:19 EST

*** This bug has been marked as a duplicate of 140115 ***

Note You need to log in before you can comment on or make changes to this bug.