Bug 1491842 - rhsm.conf man page needs an update for new [rhsm] auto_enable_yum_plugins
Summary: rhsm.conf man page needs an update for new [rhsm] auto_enable_yum_plugins
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-14 20:00 UTC by John Sefler
Modified: 2018-04-10 09:52 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.20.6-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:52:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github /candlepin subscription-manager pull 1726 None None None 2017-11-10 08:46:16 UTC
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:52:27 UTC
Github candlepin subscription-manager pull 1708 None None None 2017-09-25 12:50:41 UTC

Description John Sefler 2017-09-14 20:00:20 UTC
Description of problem:
After implementation of Bug 1319927 - "[RFE] subscription-manager should automatically enable yum plugins" an update to the man page for rhsm.conf is needed for the new [rhsm]auto_enable_yum_plugins = 1 configuration.



Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q subscription-manager
subscription-manager-1.20.1-1.git.49.12d004d.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# grep -B1 auto_enable_yum_plugins /etc/rhsm/rhsm.conf
# Manage automatic enabling of yum plugins (product-id, subsription-manager)
auto_enable_yum_plugins = 1
[root@jsefler-rhel7 ~]# 
[root@jsefler-rhel7 ~]# man -P cat rhsm.conf | grep -A2 auto_enable_yum_plugins
[root@jsefler-rhel7 ~]# 


Actual results:
 no entry in rhsm.conf man page for auto_enable_yum_plugins

Expected results:
 an entry in rhsm.conf man page for auto_enable_yum_plugins

Additional info:

Comment 3 Shwetha Kallesh 2017-11-10 06:15:55 UTC
Verified!

[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription management rules: Unknown
subscription-manager: 1.20.5-1.el7


[root@dhcp35-121 ~]# grep -B1 auto_enable_yum_plugins /etc/rhsm/rhsm.conf
# Manage automatic enabling of yum plugins (product-id, subscription-manager)
auto_enable_yum_plugins = 1


[root@dhcp35-121 ~]# man -P cat rhsm.conf | grep -A2 auto_enable_yum_plugins
       auto_enable_yum_plugins
           When this option is enabled, then yum plugins subscription-manager and plugin-id are enabled every-time subscription-manager or subscription-manager-gui
           is executed.

Comment 4 Shwetha Kallesh 2017-11-10 08:30:03 UTC
Actually observe a typo in the man page ,
plugin-id should be changed to product-id so moving bug back to new

Comment 6 Shwetha Kallesh 2017-11-29 13:07:18 UTC
Plugin-id has been changed to product-id,so moving bug to verified state



[root@dhcp35-10 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.20.7-1.el7

[root@dhcp35-10 ~]# grep -B1 auto_enable_yum_plugins /etc/rhsm/rhsm.conf
# Manage automatic enabling of yum plugins (product-id, subscription-manager)
auto_enable_yum_plugins = 1


[root@dhcp35-10 ~]# man -P cat rhsm.conf | grep -A2 auto_enable_yum_plugins
       auto_enable_yum_plugins
           When this option is enabled, then yum plugins subscription-manager and product-id are enabled every-time subscription-manager or subscription-manager-
           gui is executed.

Comment 9 errata-xmlrpc 2018-04-10 09:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.