Bug 1491936 - Fresh installed RHV-H shows upgrade that doesn't exist.
Summary: Fresh installed RHV-H shows upgrade that doesn't exist.
Keywords:
Status: CLOSED DUPLICATE of bug 1474268
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng
Version: 4.1.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Ryan Barry
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-15 05:22 UTC by Germano Veit Michel
Modified: 2021-03-11 17:13 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-18 22:54:21 UTC
oVirt Team: Node
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)

Description Germano Veit Michel 2017-09-15 05:22:20 UTC
Description of problem:

An upgrade that does not exist is found on fresh host installation. It "upgrades" to the same version it's currently running and then the icon goes away.

1. Fresh install latest RHV-H 4.1.5

2. Subscribe and add to RHV-M

3. RHV-M shows upgrade:

2017-09-15 05:03:34,597+10 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-1) [37188b92-91f1-448b-9526-658031a8a8e6] EVENT_ID: HOST_AVAILABLE_UPDATES_FINISHED(885), Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Check for available updates on host host2.rhv.laptop was completed successfully with message 'found updates for packages redhat-virtualization-host-image-update-4.1-20170816.2.el7_4'.

But this is the exact version it's currently running: rhvh-4.1-0.20170817.0

4. Then I install this "upgrade" and the package is installed, host rebooted.
Sep 15 15:05:13 Installed: redhat-virtualization-host-image-update-4.1-20170816.2.el7_4.noarch

5. But as it's the same thing it was running, nothing new is added, we are still  on the same image. But at least the upgrade icon is gone, it's not finding any more "upgrades".

# imgbase layout
rhvh-4.1-0.20170817.0
 +- rhvh-4.1-0.20170817.0+1

Version-Release number of selected component (if applicable):
rhevm-4.1.5.2-0.1.el7.noarch
RHVH-4.1-20170817.0-RHVH-x86_64-dvd1.iso

How reproducible:
100%

Steps to Reproduce:
As above

Actual results:
Fake upgrade available

Comment 3 Ryan Barry 2017-09-18 20:13:56 UTC
This very much appears to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1474268

Comment 4 Germano Veit Michel 2017-09-18 22:54:21 UTC
(In reply to Ryan Barry from comment #3)
> This very much appears to be a duplicate of
> https://bugzilla.redhat.com/show_bug.cgi?id=1474268

It is. Thanks for pointing it out.

*** This bug has been marked as a duplicate of bug 1474268 ***


Note You need to log in before you can comment on or make changes to this bug.