Bug 149200 - kernel freezes soon after it switches to fbdev on iBook G4
kernel freezes soon after it switches to fbdev on iBook G4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
: 152385 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-20 19:54 EST by Gabriel Schulhof
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 10:30:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Schulhof 2005-02-20 19:54:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Here's the screen it freezes on:
+----------+
|          |
| Penguin  |
|  Logo    |
|          |
|          |
|          |
+----------+
Apple USB OHCI 0001:10:19.0 disabled by firmware
usbcore: registered new driver usbfs
usbcore: registered new driver hub
Thermal assist unit not available
Registering PowerMac CPU frequency driver
Low: 707 Mhz, High: 931 Mhz, Boot: 707 Mhz
audit: initializing knetlink socket (disabled)
audit(1108919135.453:0): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key D5ABE686CE6001A6
- User ID: Red Hat, Inc. (Kernel Module GPG key)
PCI: Enabling device 0000:00:10.0 (0006 -> 0007)
radeonfb (0000:00:10.0): Invalid ROM signature 0 should be0xaa55
radeonfb: Retreived PLL infos from Open Firmware
radeonfb: Reference=27.00 MHz (RefDiv=12) Memory=190.00 Mhz,
System=183.00 MHz
radeonfb: PLL min 12000 max 35000
radeonfb: Monitor 1 type LCD found
radeonfb: EDID probed
radeonfb: Monitor 2 type not found
Console: switching to colour frame buffer device 128x48
radeonfb: Dynamic Clock Power Management enabled
Registered "mnca" backlight controller, level: 15/15
radeonfb (0000:00:10.0): ATI Radeon \c
Generic RTC Driver v1.07
Macintosh non-volatile memory driver v1.1
Linux agpgart interface v0.100  (c) Dave Jones
agpgart: Detected Apple UniNorth 2 chipset
agpgart: Maximum main memory to use for agp memory: 565M
agpgart: configuring for size idx: 4
agpgart: AGP aperture is 16M @ 0x0
[drm] Initialized drm 1.0.0.20040925
Serial: 8250/16550 driver $Revision: 1.90 $ 76 ports, IRQ sharing enabled


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.1148_FC4

How reproducible:
Always

Steps to Reproduce:
Well, almost every time. I have to try 3-4-5 times before it boots.
1. Boot 1148 on an iBook G4

Actual Results:  kernel freezes as described above

Expected Results:  Normal boot ...

Additional info:

This problem has been present since I started testing FC for PPC
(kernel 2.6.9-1.667, IIRC).
Comment 1 Gabriel Schulhof 2005-03-03 11:19:29 EST
Well, things are going from bad to worse. With
kernel-2.6.10-1.1162_FC4 it freezes even before it starts the frame
buffer. This time, it freezes every time (tried it about 8-9 times in
a row). It doesn't get past this point:

Welcome to Linux, kernel 2.6.10-1.1162_FC4

linked at        : 0xc0000000
frame buffer at  : 0x9c000000  (phys), 0xd0000000  (log)
klimit           : 0xc0405888
MSR              : 0x00003030
HID0             : 0x8410c0bc

pmac_init(): exit
id mach(): done
MMU:enter
MMU: hw init
hash:enter
hash:find piece
hash:patch
hash:done
MMU:mapin
MMU:setio
MMU:edxit
setup_arch: enter
setup_arch: bootmem
arch: exit
openpic: enter
openpic: timer
openpic: external
openpic: spurious
openpic: exit
Comment 2 Gabriel Schulhof 2005-03-03 11:22:12 EST
P.S.: If there are speling errors, it's because i copied this
information by hand.

s/0xd0000000/0xd0008000/
Comment 3 Gabriel Schulhof 2005-05-14 21:58:52 EDT
Well, the problem went away for a few kernel versions, but, as of
2.6.11-1.1305_FC4, the problem is back. Please fix it !
Comment 4 Gabriel Schulhof 2005-05-20 00:43:29 EDT
The problem, as originally stated, persists when using kernel 2.6.11-1.1319_FC4.
Comment 5 David Woodhouse 2005-05-20 05:16:18 EDT
The real problem is with catching the machine check when we access nonexistent
I/O addresses. I'll see if we can track that down -- can you show the full
contents of /proc/cpuinfo?

It was originally triggered by the serial driver, but that is now not probing
for PC serial ports so it doesn't happen.

In 1.1305 we turned on CONFIG_ISA (and with it CONFIG_ISAPNP) for the benefit of
RS/6000 users. That's why it broke then.

We've now turned off CONFIG_ISAPNP, in 1.1327 and later. Please test that. If it
doesn't work we'll turn CONFIG_ISA off again, and for RS/6000 we'll either have
to have a separate kernel or we'll have to fix your _real_ underlying problem first.
Comment 6 Gabriel Schulhof 2005-05-20 13:06:51 EDT
/proc/cpuinfo:

processor       : 0
cpu             : 7455, altivec supported
clock           : 707MHz
revision        : 0.3 (pvr 8001 0303)
bogomips        : 710.65
machine         : PowerBook6,3
motherboard     : PowerBook6,3 MacRISC3 Power Macintosh
detected as     : 287 (iBook G4)
pmac flags      : 0000001b
L2 cache        : 256K unified
memory          : 640MB
pmac-generation : NewWorld
Comment 7 Gabriel Schulhof 2005-05-20 13:35:42 EDT
Well, 1.1327 is not yet available via yum, but 1.1323 booted successfully twice
in a row.
Comment 8 David Woodhouse 2005-05-24 06:44:04 EDT
*** Bug 152385 has been marked as a duplicate of this bug. ***
Comment 9 Gabriel Schulhof 2005-05-25 03:49:00 EDT
kernel-2.6.11-1.1341 freezes as described at the top of this thread.
Comment 10 David Woodhouse 2005-05-25 04:52:54 EDT
OK, then we need to turn CONFIG_ISA back off. Done in 2.6.11-1.1356, which will
hopefully squeeze its way into the FC4 release. 
Comment 11 Dave Jones 2005-05-26 20:12:02 EDT
This did make it into the FC4 release kernel.
Comment 12 Gabriel Schulhof 2005-06-07 16:21:13 EDT
Well, as of kernel-2.6.11-1.1369_FC4, the kernel /still/ freezes occasionally
(approximately 1/4 of the time) as described at the beginning of this bug.
Comment 13 Dave Jones 2005-10-06 01:03:33 EDT
How does the latest errata kernel fare ?
Comment 14 Andrew Overholt 2005-10-19 19:03:07 EDT
The latest errata kernel no longer boots for me.  I updated some stuff the other
day (from FC4 updates ... it was just a few things like PostgreSQL but I can't
remember what else) and now it won't boot.  I get a hang at "Red Hat nash
version 4.2.15 starting".  The cursor is blinking but there is no disk activity
and it's not doing anything.  Before I get to this point, I can hear some disk
activity but then it stops.  Caps Lock and Num Lock function and I can type
things, but the boot appears to just be stopped.
Comment 15 David Woodhouse 2005-10-20 10:30:20 EDT
I think the current kernel should have the 8250 bug fixed though. What you
describe in comment #14 sounds like something entirely different. 

I'll commit the 8250 patch to rawhide (it was only in FC4 before) and close this
bug.
Comment 16 Andrew Overholt 2005-10-20 11:30:08 EDT
David helped me on IRC and it turns out that my problem was due to the fact that
I had updated to rawhide glibc (by way of gcc) but not rawhide prelink.  Thanks,
David!

Note You need to log in before you can comment on or make changes to this bug.