Bug 1492342 - [iSCSI]: LUN resize on target side ceph not reflected on clients
Summary: [iSCSI]: LUN resize on target side ceph not reflected on clients
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: iSCSI
Version: 3.0
Hardware: Unspecified
OS: Linux
high
medium
Target Milestone: rc
: 3.1
Assignee: Mike Christie
QA Contact: Madhavi Kasturi
URL:
Whiteboard:
: 1499652 (view as bug list)
Depends On:
Blocks: 1494421 1584264
TreeView+ depends on / blocked
 
Reported: 2017-09-16 15:04 UTC by Tejas
Modified: 2018-09-26 18:18 UTC (History)
10 users (show)

Fixed In Version: ceph-iscsi-config-2.6-1.el7cp
Doc Type: Bug Fix
Doc Text:
.LUN resize on target side Ceph is now reflected on clients Previously, when using the iSCSI gateway, resized Logical Unit Numbers (LUNs) were not immediately visible to initiators. This required a work around of restarting the iSCSI gateway after resizing a LUN to expose it to the initiators. With this update to {product}, iSCSI initiators can now see a resized LUN immediately after rescan.
Clone Of:
: 1492491 (view as bug list)
Environment:
Last Closed: 2018-09-26 18:16:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-iscsi-config pull 27 None None None 2017-09-29 14:03:31 UTC
Red Hat Product Errata RHBA-2018:2819 None None None 2018-09-26 18:18:17 UTC

Description Tejas 2017-09-16 15:04:13 UTC
Description of problem:
    LUN resize done through gwcli is not getting reflected on client leading to issues.

[Tejas]
   In my functional testing had a few observations.
>>>> >> >
>>>> >> > 1. Lun resize( disk resize ) on the ceph target does not reflect on any
>>>> >> > of
>>>> >> > the clients(RHEL,ESX,Win), even after re-scanning the storage.

[Jason]:
I looked at the config on banshee where rbd/test1 was a 40GB image but
> buckeye was seeing it as 10GB.
>
> The configfs on banshee appears to be correct:
>
> # cat /sys/kernel/config/target/core/user_3/rbd.test1/info
> Status: ACTIVATED  Max Queue Depth: 0  SectorSize: 512  HwMaxSectors: 128
>         Config: rbd/rbd/test1/osd_op_timeout=30 Size: 42949672960
>
> The device size on buckeye is incorrect:
>
> # blockdev --getsize64 /dev/sdh
> 10737418240


[Mike]:
This is a tcmu-runner and kernel issue. It's on my TODO. I have a simple
userspace patch for downstream only to work around some RHEL kernel issues.

Comment 4 Jason Dillaman 2017-09-28 21:33:11 UTC
@Mike: look like this just needs the change in ceph-iscsi-config to alert target of the size change? I used gwcli to resize the image and restarted rbd-target-gw and the initiator was able to detect the change.

Comment 5 Mike Christie 2017-09-29 03:08:11 UTC
Yeah, ceph-iscsi-config needs to do a rtslib call. Something like:

stg_object.set_attribute("dev_size", new_size)

Comment 6 Mike Christie 2017-10-09 16:38:07 UTC
*** Bug 1499652 has been marked as a duplicate of this bug. ***

Comment 13 John Brier 2018-08-31 18:09:25 UTC
Thanks Jason!

Comment 15 errata-xmlrpc 2018-09-26 18:16:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.