Bug 1492464 - Clearer message when trying to upload a plan with a name that already exists
Summary: Clearer message when trying to upload a plan with a name that already exists
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-17 13:49 UTC by Udi
Modified: 2018-06-27 13:37 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-8.4.1-0.20180224032817.d51ed49.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing the UI displays the relevant error message (30.26 KB, image/png)
2018-01-29 12:19 UTC, Ana Krivokapic
no flags Details
Plan Creation Failed (109.76 KB, image/png)
2018-01-29 13:15 UTC, Udi
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1745944 None None None 2018-01-29 15:55:19 UTC
OpenStack gerrit 538844 None master: MERGED tripleo-ui: Set error names explicitly (Id0ae3b9427a07a1910e7a6976da76a06abb104f1) 2018-02-28 13:36:02 UTC
Red Hat Bugzilla 1492728 None CLOSED Occasionally, you get "Deployment parameters could not be loaded" when editing parameters of enabled environment files 2018-07-16 13:18:44 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:03 UTC

Description Udi 2017-09-17 13:49:54 UTC
Description of problem:
When you upload 2 plans with the same name, you get an error message saying "plan creation failed" with no details why.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.2.1-0.20170819031831.070a522.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Upload the same plan twice, with the same name


Actual results:
The error message says "plan creation failed"


Expected results:
The error message should say "a plan with this name already exists"

Comment 4 Ana Krivokapic 2018-01-29 12:19:51 UTC
Created attachment 1387732 [details]
Screenshot showing the UI displays the relevant error message

Comment 5 Ana Krivokapic 2018-01-29 12:20:25 UTC
Could not reproduce this (see screenshot). Could you re-test please.

Comment 6 Udi 2018-01-29 13:15:51 UTC
Created attachment 1387790 [details]
Plan Creation Failed

I'm only getting "Plan Creation Failed" with no additional info. See my screenshot. 

Jiri said he fixed a similar bug, in which the details of the error message did not appear in the minified version of the code. Maybe you can ask him if we're lucky and his fix will cover this bug too (or if he only fixed it for errors coming from heat).

Comment 7 Ana Krivokapic 2018-01-29 13:30:36 UTC
Jirka, any ideas on this one?

Comment 8 Jiri Tomasek 2018-01-29 13:54:58 UTC
Yes, https://bugzilla.redhat.com/show_bug.cgi?id=1492728#c8 fixes the error handling issues in production. This bug should be fixed by it too.

Comment 9 Ana Krivokapic 2018-01-29 15:53:45 UTC
So this is caused by the same underlying issue as BZ1492728. I'll link the appropriate patches and re-assign to Jirka.

Comment 11 Udi 2018-04-15 09:45:52 UTC
Verified in: 
openstack-tripleo-ui-8.3.1-2.el7ost.noarch
openstack-tripleo-common-8.5.1-0.20180326153322.91f52e9.el7ost.noarch

Comment 13 errata-xmlrpc 2018-06-27 13:36:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.