Bug 1492728 - Occasionally, you get "Deployment parameters could not be loaded" when editing parameters of enabled environment files
Summary: Occasionally, you get "Deployment parameters could not be loaded" when editin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On: 1567893
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-18 14:24 UTC by Udi
Modified: 2018-06-27 13:37 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-ui-8.2.1-0.20180227100337.517cd78.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1745944 None None None 2018-01-29 09:00:04 UTC
OpenStack gerrit 538844 None master: MERGED tripleo-ui: Set error names explicitly (Id0ae3b9427a07a1910e7a6976da76a06abb104f1) 2018-02-28 13:36:13 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:03 UTC

Internal Links: 1492464

Description Udi 2017-09-18 14:24:38 UTC
Description of problem:
This is a bit of a random bug, but if you enable many environment files you can recreate it easily. When you switch to the "Parameters" tab in the configuration dialog and click on the various enabled environments to edit their parameters - you eventually get an error "Deployment parameters could not be loaded".

ConsoleAdapter.js:33 Deployment parameters could not be loaded t t
    at m (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:38:13704)
    at https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:38:13556
    at V (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:137:3076)
    at j (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:137:2708)
    at C.when (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:137:6557)
    at E.run (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:137:5385)
    at e._drain (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:126:542)
    at drain (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:126:196)
    at MutationObserver.t (https://puma01.scl.lab.tlv.redhat.com/tripleo_ui.js:62:322)s.value @ ConsoleAdapter.js:33
132 console messages are not shown.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.1-0.20170911164240.16684db.el7ost.noarch


How reproducible:
Randomly


Steps to Reproduce:
1. Enable many environments (I selected all the Cinder backends)
2. Switch to the "Parameters" tab
3. Click to edit the parameters of some of the enabled environments


Actual results:
You get "Deployment parameters could not be loaded". It seems like maybe the operation took too long.


Expected results:
You should never get an error.

Comment 5 Udi 2017-11-30 15:13:08 UTC
Proposing to make this a blocker for 12. This error, and other related websocket disconnection errors, occur now in an intolerable frequency during normal working with the UI (at all stages and not just in the configuration dialog). If you press F5 there is a good chance you'll get the error a second time in a row. Many times the error seems to have no real affect on the app, but still a user will get very upset that it doesn't stop happening.

Comment 6 Jason E. Rist 2017-11-30 18:21:25 UTC
Cannot easily reproduce.  Not seeing it on other environments at this time I propose to not make it a blocker.

Comment 7 Jiri Tomasek 2018-01-25 16:16:14 UTC
This error is usually caused by error in selected environments. If there is an error in environment file which gets enabled, Heat validation will fail and GUI/tripleo-common will fail to retrieve parameters.

Problem I see here is with the error message. It seems that error names are affected by minification in production code in GUI and that causes the relevant error message not to appear. I am going to try to reproduce this in production built code.

Comment 8 Jiri Tomasek 2018-01-29 09:00:04 UTC
Fixing the launchpad bug ensures that production code correctly shows error message coming from Heat. Example:

Deployment parameters could not be loaded
404 Client Error: Not Found for url: http://192.168.24.1:8080/v1/AUTH_bca7e29c655a42d1b7018befd2a2e8a0/test-broken-environment/environments/puppet/extraconfig/tls/tls-cert-inject.yaml

Comment 11 Udi 2018-04-18 05:38:46 UTC
Testing is blocked by bug https://bugzilla.redhat.com/show_bug.cgi?id=1567893

Comment 12 Udi 2018-05-22 06:56:30 UTC
Verified in openstack-tripleo-ui-8.3.1-2.el7ost.noarch.

There are still references to non-existent yamls in the templates, but the error message you get is clear enough so from the GUI's point of view this bug is now handled properly.

Comment 14 errata-xmlrpc 2018-06-27 13:36:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.