Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1492549 - [Docs][RFE] RHVM 4.2 requires PostgreSQL 9.5 from Software Collections
Summary: [Docs][RFE] RHVM 4.2 requires PostgreSQL 9.5 from Software Collections
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Avital Pinnick
QA Contact: Byron Gravenorst
URL:
Whiteboard:
: 1490273 (view as bug list)
Depends On: RHV_PG_95
Blocks: 1611038
TreeView+ depends on / blocked
 
Reported: 2017-09-18 06:49 UTC by Martin Perina
Modified: 2019-05-07 12:58 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 07:42:41 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Perina 2017-09-18 06:49:30 UTC
Description of problem:

RHVM 4.2 requires PostgreSQL 9.5 from Software Collections, which means:

1. Local database installed on RHVM host will be upgraded automatically from PG 9.2 to SCL PG 9.5
2. Remote databases has to be upgraded manually so upgrade to 4.2 could finish successfully

We need to update RHVM 4.2 documentation to work only with SCL PG 9.5 for both engine and DWH. I've found following sections mentioning PG, but there may be more of them:

[1] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/installation_guide/appe-Preparing_a_Remote_PostgreSQL_Database_for_Use_with_the_Red_Hat_Enterprise_Virtualization_Manager

[2] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/installation_guide/appe-preparing_a_local_manually-configured_postgresql_database_for_use_with_the_red_hat_enterprise_virtualization_manager

[3] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/data_warehouse_guide/installing_and_configuring_data_warehouse_on_a_separate_machine

[4] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/data_warehouse_guide/sect-migrating_data_warehouse_to_a_separate_machine

[5] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/administration_guide/chap-backups_and_migration

[6] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/upgrade_guide/chap-upgrading_to_red_hat_virtualization_4.1


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Avital Pinnick 2017-10-29 07:26:13 UTC
*** Bug 1490273 has been marked as a duplicate of this bug. ***

Comment 29 Byron Gravenorst 2017-11-27 02:51:38 UTC
Reviewed and merged.


Note You need to log in before you can comment on or make changes to this bug.