Bug 149333 - unable to set Hungarian key layout
unable to set Hungarian key layout
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
: Triaged
: 151737 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-22 10:28 EST by Ivan Szanto
Modified: 2012-04-20 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 12:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Workaround to make some of the layouts work (55 bytes, text/plain)
2005-03-09 11:58 EST, Ivan Szanto
no flags Details

  None (edit)
Description Ivan Szanto 2005-02-22 10:28:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
We would like to be able to use the keyboard switcher applet to switch from US English to Hungarian layout and back.

Unfortunately it is impossible to set up the Hungarian layout in addition to the default US English layout.

Our company is the official distributor of RedHat systems in Hungary. It is crucial for us that localizations work. This bug is a major problem in local usage. 

Version-Release number of selected component (if applicable):
control-center-2.8.0-12

How reproducible:
Always

Steps to Reproduce:
1.Create a new user
2.Log in as the new user under the graphical console (gnome)
3.Choose Preferences/Keyboard from the Applications menu
4.Choose the Layout tab
5.Choose "Hungarian (qwerty)" from the "Available layouts:" column
6.Click "Add"
  

Actual Results:  Two error windows popped up with the following text:

--- beginning of first error message ----
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60801000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
--- end of first error message ----

The result of xprop -root | grep XKB is

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us_intl", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "intl", "grp:alts_toggle"

The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb is

 layouts = [us  intl,hu_qwerty]
 model = pc105
 overrideSettings = false
 options = [grp grp:alts_toggle]
 update_handlers = []


Expected Results:  No error message, and this should enable me to switch between the two
different keyboard layouts by using the keyboard-switching applet

Additional info:

I tried to add several other of the existing Hungarian layouts, with the same results.
Comment 1 Leon Ho 2005-02-24 02:21:53 EST
For this look like it is a xorg bug:
$ setxkbmap -rules xorg -layout "us" -option "grp:alts_toggle"
$ setxkbmap -rules xorg -layout "us,hu" -option "grp:alts_toggle"
Error loading new keyboard description

Try to move to suitable component.
Comment 2 Ivan Szanto 2005-03-09 11:58:28 EST
Created attachment 111816 [details]
Workaround to make some of the layouts work

The following two commands make some of the layouts work as an alternative to
the us layout:

cd /usr/X11R6/lib/X11/xkb/symbols
cp hu* pc

Please consider using this (or a suitable variation of it) as a patch.
Comment 3 Mike A. Harris 2005-03-09 12:41:30 EST
Please report this problem to X.Org bugzilla, via the following URL:

http://bugs.freedesktop.org in the 'xorg' component.

Once this issue is reported to X.Org, it will be reviewed by the xkb
maintainers, who will provide expert feedback about the proposed solution,
and may additionally provide alternative proposals.

When they have decided upon a particular solution to use and have committed
it to X.Org CVS, the same solution can be recommended as a proposed addition
to the XORG-6_8-branch of CVS via X.Org bugzilla as well, which is very likely
to occur.  Once it is approved for 6.8.x, it will then be scheduled to
get committed to the stable branch.

Paste your X.Org bug report URL here, and we will track the issue in the
X.Org bugzilla, and once it is approved for 6.8.x, we will review the
final patches for consideration in future updates to our xorg-x11 rpms.

Thanks in advance.
Comment 5 tusi 2005-04-22 02:46:23 EDT
*** Bug 151737 has been marked as a duplicate of this bug. ***
Comment 7 Levente Farkas 2005-09-23 05:03:16 EDT
imho it should have to be fixed even the above just a workaround! this had not
been working since fedora 1. and what happends if it will not fixed until fedora
10? so Mike _please_ include the above workaround until xorg fix it then you can
remove the workaround!
and for ivan thank you!
Comment 9 Matěj Cepl 2007-06-26 05:16:02 EDT
Reporter, could you please confirm, that this bug is not reproducible anymore on
the latest upgrades of your system (both RHEL4 and RHEL5 would be interesting)?
Thank you.
Comment 10 Ivan Szanto 2007-06-27 07:30:01 EDT
I tried it on the latest upgrade of RHEL4 and this bug is still there.
Comment 11 Adam Jackson 2012-04-20 12:53:41 EDT
No further non-security updates are planned for Xorg in RHEL4.  If this issue is still present in RHEL5 or RHEL6, please update the affected product version and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.