Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1493390 - [downstream clone - 4.1.6 Async] Engine VM has no external connectivity due to unconfigured default gateway if deployed with static IP
Summary: [downstream clone - 4.1.6 Async] Engine VM has no external connectivity due t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.1.6-1
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On: 1492791
Blocks: 1493397
TreeView+ depends on / blocked
 
Reported: 2017-09-20 05:56 UTC by rhev-integ
Modified: 2021-03-11 17:37 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1492791
Environment:
Last Closed: 2017-09-26 13:22:57 UTC
oVirt Team: Integration
Target Upstream Version:
nsednev: testing_plan_complete+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1686856 0 None None None 2017-09-20 05:56:21 UTC
Red Hat Product Errata RHBA-2017:2807 0 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix update 2017-09-26 17:22:42 UTC
oVirt gerrit 81934 0 master MERGED network: force gateway address on the engine VM if static 2017-09-20 05:56:21 UTC
oVirt gerrit 81958 0 ovirt-hosted-engine-setup-2.1 MERGED network: force gateway address on the engine VM if static 2017-09-20 05:56:21 UTC
oVirt gerrit 82025 0 ovirt-hosted-engine-setup-2.1.3.z MERGED network: force gateway address on the engine VM if static 2017-09-20 06:08:19 UTC

Description rhev-integ 2017-09-20 05:56:03 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1492791 +++
======================================================================

Description of problem:
Due to an upstream cloud-init bug ( https://bugs.launchpad.net/cloud-init/+bug/1686856 ), the default gateway is not configured on the Engine VM if deployed with static IP.

It affects RHEL 7.4 and Centos 7.4 (used as the base of the engine-appliance, not related to host OS).

Version-Release number of selected component (if applicable):
The issue is cloud-init on the engine VM OS: 7.4

How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine with static IP for the engine VM
2.
3.

Actual results:
The engine VM has no gateway and so no network connectivity

Expected results:
The default gateway on the engine VM is correctly configured

Additional info:

It affects RHEL 7.4 and Centos 7.4 (used as the base of the engine-appliance, not related to host OS)

(Originally by Simone Tiraboschi)

Comment 1 rhev-integ 2017-09-20 05:56:09 UTC
Not depending on bug #1492726 since we can workaround it. Moved bug #1492726 to see also.

(Originally by Sandro Bonazzola)

Comment 2 rhev-integ 2017-09-20 05:56:12 UTC
*** Bug 1493070 has been marked as a duplicate of this bug. ***

(Originally by didi)

Comment 4 Nikolai Sednev 2017-09-24 13:53:40 UTC
Successfully deployed ovirt-hosted-engine-setup-2.1.4-1.el7ev.noarch with rhvm-appliance-4.1.20170914.0-1.el7.noarch and ovirt-engine-setup-4.1.6.2-0.1.el7.noarch inside, on RHEL7.4, using static IP configuration on SHE-VM, did not seen any default gateway issues with the deployment.
Moving to verified.

Comment 5 Yihui Zhao 2017-09-25 08:19:02 UTC
SHE-VM with static ip deployed successfully.

Test version:
rhvh-4.1-0.20170925.0+1
ovirt-hosted-engine-setup-2.1.3.9-1.el7ev.noarch
cockpit-ovirt-dashboard-0.10.8-2.2.ovirt41.el7ev.noarch
rhvm-appliance-4.1.20170914.0-1.el7.noarch
ovirt-host-deploy-1.6.6-1.el7ev.noarch


Steps:
1. deploy hosted-engine with static IP for the engine VM


Result: Deploy successfully and didn't see any default gateway issues with the deployment.

Comment 6 errata-xmlrpc 2017-09-26 13:22:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2807


Note You need to log in before you can comment on or make changes to this bug.