Bug 149514 - LVM2 and LVM only get re-initialized if /etc/raidtab exists
LVM2 and LVM only get re-initialized if /etc/raidtab exists
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 158949 165877 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 13:36 EST by Murray Schwalbaum
Modified: 2014-03-16 22:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-25 12:09:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murray Schwalbaum 2005-02-23 13:36:07 EST
Description of problem:

If you have a /dev/md* devices setup as a physical volume and do not use
/etc/raidtab (you use only mdadm.conf), the sections to do the vgcans do not
run. They are enclosed in an if statement of  [ -f /etc/raidtab ].


Version-Release number of selected component (if applicable):


How reproducible:
See steps below.


Steps to Reproduce:
Install FC3.
Create /dev/md0.
Create a physical volume on /dev/md0.
Create a volume group called vol00 including /dev/md0.
Create a logical volume called lvol0 with vol00.

Reboot. 
  
Actual results:
It should not initialize until you touch /etc/raidtab.


Expected results:
The lvm should be setup properly.

Additional info:

Look at /etc/rc.sysinit. The code comented with 
"# LVM2 initialization, take 2" only gets run if /etc/raidtab exists. This file
is not created if you create md devices with anaconda.

Fix:

Move the "take 2" initialization out of the -f /etc/raidtab statement.
Comment 1 Bill Nottingham 2005-02-23 13:54:49 EST
What release are you looking at - you filed this against 'test3'.
Comment 2 Murray Schwalbaum 2005-02-24 21:23:14 EST
Sorry. Core 3. I'll check to see if it exists on RHEL/CentOS 4.
Comment 3 Murray Schwalbaum 2005-02-25 08:35:30 EST
It exists on RHEL/CentOS 4 (supprise supprise). I haven't tested it, because it
would mean reinstalling the system to get an older kernel and mean downtime for
the system.

If you verify that what I am experiencing is a bug, I can put in an RHEL 4
ticket (if you think that would get it solved faster).
Comment 4 Bill Nottingham 2005-02-25 12:09:29 EST
Fixed on the RHEL4 & FC3 branches. Note that when it gets pushed as an
update for either probably depends on what other bugs are found.

This code isn't in the current devel tree, so the problem is already
fixed there. Closing as fixed in rawhide.
Comment 5 Bill Nottingham 2005-05-26 22:41:58 EDT
*** Bug 158949 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2005-08-19 02:57:41 EDT
*** Bug 165877 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.