Bug 165877 - LVM volumes built on top of mdadm.conf-declared RAID arrays do not get activated
LVM volumes built on top of mdadm.conf-declared RAID arrays do not get activated
Status: CLOSED DUPLICATE of bug 149514
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-13 05:37 EDT by Need Real Name
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 02:57:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-08-13 05:37:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
If you setup an LVM volume on top of a RAID array declared in /etc/mdadm.conf, instead of raidtab, it does not get activated at boot.

LVM volumes are initially searched for before RAID arrays are activated.

rc.sysinit makes two more tries to search for LVM volumes, but only if RAID arrays are declared through /etc/raidtab.

Since raidtools and, by extension, /etc/raidtab are not installed/used by default in RHEL4 anymore, LVM volumes can get overlooked.

It seems like the second shot at LVM initialization that currently only happens if raidtab exists should probably occur if any RAID arrays have been activated, not only if raidtab exists (see line 620 in rc.sysinit).


Version-Release number of selected component (if applicable):
initscripts-7.93.13.EL-2

How reproducible:
Always

Steps to Reproduce:
1. Declare RAID array in /etc/mdadm.conf.  Make sure no /etc/raidtab exists.
2. Create LVM volume
3. Reboot.  It will not be activated.
  

Additional info:
Comment 1 Bill Nottingham 2005-08-19 02:57:29 EDT

*** This bug has been marked as a duplicate of 149514 ***

Note You need to log in before you can comment on or make changes to this bug.