Bug 1495204 - TypeError: list indices must be integers or slices, not str
Summary: TypeError: list indices must be integers or slices, not str
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Konecny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e9016016776c0bb3779f730e3bb...
Depends On:
Blocks: F27BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-09-25 13:31 UTC by lnie
Modified: 2017-10-05 21:03 UTC (History)
20 users (show)

Fixed In Version: anaconda-27.20.1-6.fc27 anaconda-27.20.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-05 21:03:00 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (746.71 KB, text/plain)
2017-09-25 13:33 UTC, lnie
no flags Details
File: anaconda.log (15.61 KB, text/plain)
2017-09-25 13:33 UTC, lnie
no flags Details
File: dnf.librepo.log (10.33 KB, text/plain)
2017-09-25 13:33 UTC, lnie
no flags Details
File: environ (530 bytes, text/plain)
2017-09-25 13:33 UTC, lnie
no flags Details
File: hawkey.log (762 bytes, text/plain)
2017-09-25 13:33 UTC, lnie
no flags Details
File: lorax-packages.log (25.98 KB, text/plain)
2017-09-25 13:34 UTC, lnie
no flags Details
File: lsblk_output (1.51 KB, text/plain)
2017-09-25 13:34 UTC, lnie
no flags Details
File: lvm.log (125.98 KB, text/plain)
2017-09-25 13:34 UTC, lnie
no flags Details
File: nmcli_dev_list (1.21 KB, text/plain)
2017-09-25 13:34 UTC, lnie
no flags Details
File: os_info (529 bytes, text/plain)
2017-09-25 13:34 UTC, lnie
no flags Details
File: program.log (34.17 KB, text/plain)
2017-09-25 13:34 UTC, lnie
no flags Details
File: storage.log (94.20 KB, text/plain)
2017-09-25 13:34 UTC, lnie
no flags Details
File: syslog (224.73 KB, text/plain)
2017-09-25 13:35 UTC, lnie
no flags Details
File: ifcfg.log (2.99 KB, text/plain)
2017-09-25 13:35 UTC, lnie
no flags Details
File: packaging.log (14.23 KB, text/plain)
2017-09-25 13:35 UTC, lnie
no flags Details
screenshot (45.11 KB, image/png)
2017-09-25 15:13 UTC, lnie
no flags Details

Description lnie 2017-09-25 13:31:50 UTC
Description of problem:


Version-Release number of selected component:
anaconda-27.20.1-1

The following was filed automatically by anaconda:
anaconda 27.20.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/tui/spokes/software_selection.py", line 125, in _translate_env_selection_to_name
    return self.payload.environments[selection]
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/tui/spokes/software_selection.py", line 262, in input
    environment = self._translate_env_selection_to_name(self._selected_environment)
  File "/usr/lib/python3.6/site-packages/simpleline/render/io_manager.py", line 244, in _process_input
    key = active_screen.ui_screen.input(active_screen.args, key)
  File "/usr/lib/python3.6/site-packages/simpleline/render/io_manager.py", line 142, in process_input
    result = self._process_input(active_screen, c)
  File "/usr/lib/python3.6/site-packages/simpleline/render/screen_scheduler.py", line 265, in _process_input
    input_result = self._io_manager.process_input(active_screen)
TypeError: list indices must be integers or slices, not str

Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-27 rd.live.check quiet inst.text
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.13.3-300.fc27.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        27

Comment 1 lnie 2017-09-25 13:33:46 UTC
Created attachment 1330535 [details]
File: anaconda-tb

Comment 2 lnie 2017-09-25 13:33:51 UTC
Created attachment 1330536 [details]
File: anaconda.log

Comment 3 lnie 2017-09-25 13:33:53 UTC
Created attachment 1330537 [details]
File: dnf.librepo.log

Comment 4 lnie 2017-09-25 13:33:55 UTC
Created attachment 1330538 [details]
File: environ

Comment 5 lnie 2017-09-25 13:33:58 UTC
Created attachment 1330539 [details]
File: hawkey.log

Comment 6 lnie 2017-09-25 13:34:03 UTC
Created attachment 1330540 [details]
File: lorax-packages.log

Comment 7 lnie 2017-09-25 13:34:05 UTC
Created attachment 1330541 [details]
File: lsblk_output

Comment 8 lnie 2017-09-25 13:34:29 UTC
Created attachment 1330542 [details]
File: lvm.log

Comment 9 lnie 2017-09-25 13:34:32 UTC
Created attachment 1330543 [details]
File: nmcli_dev_list

Comment 10 lnie 2017-09-25 13:34:34 UTC
Created attachment 1330544 [details]
File: os_info

Comment 11 lnie 2017-09-25 13:34:38 UTC
Created attachment 1330545 [details]
File: program.log

Comment 12 lnie 2017-09-25 13:34:54 UTC
Created attachment 1330546 [details]
File: storage.log

Comment 13 lnie 2017-09-25 13:35:39 UTC
Created attachment 1330547 [details]
File: syslog

Comment 14 lnie 2017-09-25 13:35:42 UTC
Created attachment 1330548 [details]
File: ifcfg.log

Comment 15 lnie 2017-09-25 13:35:46 UTC
Created attachment 1330549 [details]
File: packaging.log

Comment 16 lnie 2017-09-25 13:47:56 UTC
The reproducer is:  choose Fedora server Edition for software selection with server.iso text mode installation

Comment 17 Fedora Blocker Bugs Application 2017-09-25 14:51:33 UTC
Proposed as a Blocker for 27-beta by Fedora user lnie using the blocker tracking app because:

 Looks like a blocker for me, affects:
When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces

Comment 18 lnie 2017-09-25 15:13:20 UTC
Created attachment 1330598 [details]
screenshot

Comment 19 Kamil Páral 2017-09-25 15:54:01 UTC
Lili, please always specify which exact image you tested with. Is that Beta 1.2 Server DVD or something else? Thank you.

Comment 20 Kamil Páral 2017-09-25 16:08:44 UTC
This is unique to Server, so keeping on the proposed list, but skipping until we do modular server-specific blocker reviews.

Comment 21 lnie 2017-09-26 02:57:25 UTC
(In reply to Kamil Páral from comment #19)
> Lili, please always specify which exact image you tested with. Is that Beta
> 1.2 Server DVD or something else? Thank you.

  Sure,will keep it on mind.

Comment 22 Jiri Konecny 2017-09-26 08:15:42 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1201

Comment 23 Paul Whalen 2017-09-26 16:45:10 UTC
Similar problem has been detected:

Text installation using the Everything repo, attempt to use the software selection spoke and select 'Minimal'.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
cmdline_file:   console=ttyS0,115200 inst.stage2=nfs://192.168.0.99:/srv/fedora/fedora-release/Fedora-27-20170925.0/everything/armhfp/ inst.repo=https://kojipkgs.fedoraproject.org/compose/27//Fedora-27-20170925.0/compose/Everything/armhfp/os/
hashmarkername: anaconda
kernel:         4.13.3-300.fc27.armv7hl
package:        anaconda-27.20.1-1
product:        Fedora
reason:         TypeError: list indices must be integers or slices, not str
release:        Cannot get release name.
version:        27

Comment 24 Paul Whalen 2017-09-26 16:58:08 UTC
Similar problem has been detected:

Same issue on x86 when using the Everything repo and selecting 'Minimal' in the software spoke, then 'c' to continue.

addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-27 quiet inst.text
hashmarkername: anaconda
kernel:         4.13.3-300.fc27.x86_64
package:        anaconda-27.20.1-1
product:        Fedora
reason:         TypeError: list indices must be integers or slices, not str
release:        Cannot get release name.
version:        27

Comment 25 lnie 2017-09-27 03:07:43 UTC
I saw this crash with Fedora-Server-dvd-x86_64-27_Beta-1.2.iso.Checked with 
Fedora-Server-dvd-x86_64-27_Beta-1.3.iso,Fedora-Workstation-netinst-x86_64-27_Beta-1.3.iso and Fedora-Workstation-netinst-x86_64-27_Beta-1.3.iso,all of them are affected.

Comment 26 lnie 2017-09-27 04:37:07 UTC
Hi kamil, see the same issue with Fedora-Everything-netinst-x86_64-27_Beta-1.3.iso when choose "Fedora Workstation" ,so this is definitely not server specific,right?Seems like more serious,as you are unable to finish a text mode installation.

Comment 27 Kamil Páral 2017-09-27 08:27:54 UTC
I can reproduce this with Everything RC1.3, selecting e.g. Workstation product :/

Comment 28 Stephen Gallagher 2017-09-27 11:07:13 UTC
Ugh, I don’t see any way around this. +1 blocker

Comment 29 Petr Schindler 2017-09-27 11:11:40 UTC
I also reproduced this. +1 blocker

Comment 30 Fedora Update System 2017-09-27 11:21:20 UTC
anaconda-27.20.1-6.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a8adecb3c5

Comment 31 Kalev Lember 2017-09-27 11:24:52 UTC
+1 blocker

Comment 32 Jan Kurik 2017-09-27 11:39:01 UTC
This is definitely a blocker :-(
+1 to block.

Comment 33 Kamil Páral 2017-09-27 11:41:00 UTC
Accepting as a blocker.

Comment 34 Kamil Páral 2017-09-27 12:20:22 UTC
(In reply to Fedora Update System from comment #30)
> anaconda-27.20.1-6.fc27 has been submitted as an update to Fedora 27.
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-a8adecb3c5

I tested this with a custom boot.iso built by lorax, tested Minimal and Workstation package set, works.

Comment 35 Fedora Update System 2017-09-27 15:54:02 UTC
anaconda-27.20.1-6.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a8adecb3c5

Comment 36 lnie 2017-09-28 07:21:44 UTC
Tested with Fedora-Workstation-netinst-x86_64-27_Beta-1.5.iso and 
Fedora-Everything-netinst-x86_64-27_Beta-1.5.iso,
confirmed Server Edition,Minimal and Workstation, works fine.

Comment 37 Paul Whalen 2017-09-28 16:49:12 UTC
Tested on arm and aarch64, working as expected.

Comment 38 Fedora Update System 2017-09-29 03:20:45 UTC
anaconda-27.20.1-6.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 39 Fedora Update System 2017-09-29 16:06:08 UTC
anaconda-27.20.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 40 Fedora Update System 2017-10-02 00:55:09 UTC
anaconda-27.20.2-1.fc27, pykickstart-2.39-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 41 Fedora Update System 2017-10-02 10:49:37 UTC
anaconda-27.20.2-1.fc27 pykickstart-2.39-1.fc27 python-simpleline-0.6-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 42 Fedora Update System 2017-10-02 21:25:31 UTC
anaconda-27.20.2-1.fc27, pykickstart-2.39-1.fc27, python-simpleline-0.6-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6dd3da2595

Comment 43 Fedora Update System 2017-10-05 21:03:00 UTC
anaconda-27.20.2-1.fc27, pykickstart-2.39-1.fc27, python-simpleline-0.6-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.