Bug 1495543 - [RFE] Show an indicator in cockpit if there are updates available
Summary: [RFE] Show an indicator in cockpit if there are updates available
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 7.6
Assignee: Martin Pitt
QA Contact: Jan Ščotka
URL: https://github.com/cockpit-project/co...
Whiteboard:
Keywords: FutureFeature
: 1497409 (view as bug list)
Depends On:
Blocks: 1589370
TreeView+ depends on / blocked
 
Reported: 2017-09-26 09:34 UTC by Ryan Barry
Modified: 2018-10-30 10:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 10:34:55 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3148 None None None 2018-10-30 10:35 UTC

Description Ryan Barry 2017-09-26 09:34:23 UTC
Description of problem:
Currently, cockpit supports managing subscriptions downstream, but there is no obvious indicator from the cockpit dashboard whether or not there are updates pending.

It would be ideal if there was some 'globally' visible indicator for whether or not the host being managed had updates visible from PackageKit.

Comment 3 Peter 2017-09-26 14:14:13 UTC
This is a discussion that I think it better to have upstream. Work is underway on cockpit-packagekit that allows users to manage system updates. But how exactly this is done is probably better talked about upstream.

Comment 4 Andreas Nilsson 2017-09-27 09:39:34 UTC
Filed issue 7758 in the Cockpit issue tracker and added a design there.
https://github.com/cockpit-project/cockpit/issues/7758

Comment 5 Martin Pitt 2018-01-23 12:09:16 UTC
*** Bug 1497409 has been marked as a duplicate of this bug. ***

Comment 6 Martin Pitt 2018-03-19 10:23:48 UTC
https://github.com/cockpit-project/cockpit/pull/8822 shows both pending package updates and unregistered machines on the front ("System") page now. As this is in RHEL Base, and 7.5 is deeply frozen already, targetting for 7.6.

Comment 10 errata-xmlrpc 2018-10-30 10:34:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3148


Note You need to log in before you can comment on or make changes to this bug.