Bug 1497409 - [RFE] Show available update on the status page in cockpit of rhvh
Summary: [RFE] Show available update on the status page in cockpit of rhvh
Keywords:
Status: CLOSED DUPLICATE of bug 1495543
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Pitt
QA Contact: qe-baseos-daemons
URL: https://github.com/cockpit-project/co...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-30 08:16 UTC by Huijuan Zhao
Modified: 2018-01-24 02:13 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-23 12:09:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Huijuan Zhao 2017-09-30 08:16:36 UTC
Description of problem:
As now users use cockpit do administration for rhvh-4.x(ovirt-node), it should can upgrade via cockpit.
There should be an exclamation mark in the 'System' tab of cockpit when update is available.
When clicks there, it shows 'update is available - would you like to update now?' dialog.


Steps to Reproduce:
1. Anaconda install rhvh-4.x.
2. Logs in to Cockpit, sees in the 'System' tab that there's an exclamation mark.
   When click there, it shows 'update is available - would you like to update now?' dialog.
3. If click yes, a dialog opens up with a progress bar:
        Downloading new image
        Updating
4. When it's done - either:
        "VMs are running on this host - please switch to to maintenance before rebooting"
        Press 'Reboot' to reboot the host into the updated image

 

Actual results:


Expected results:


Additional info:
Generated from https://bugzilla.redhat.com/show_bug.cgi?id=1330891#c8

Comment 3 Martin Pitt 2018-01-23 12:08:29 UTC
This was recently discussed upstream, and Andreas made an initial design for this: https://github.com/cockpit-project/cockpit/issues/7758

Can you please have a look and see if that's what you had in mind?

Comment 4 Martin Pitt 2018-01-23 12:09:16 UTC

*** This bug has been marked as a duplicate of bug 1495543 ***

Comment 5 Huijuan Zhao 2018-01-24 02:13:24 UTC
(In reply to Martin Pitt from comment #3)
> This was recently discussed upstream, and Andreas made an initial design for
> this: https://github.com/cockpit-project/cockpit/issues/7758
> 
> Can you please have a look and see if that's what you had in mind?

Yes, Martin. This design is very good. 

And for RHVH, in my opinion, maybe need to show the update builds in detail menu, and users can choose the specific build they need to update.


Note You need to log in before you can comment on or make changes to this bug.