Bug 1496190 - Button groups created on orchestration type (heat) service catalog items are not seen on services
Summary: Button groups created on orchestration type (heat) service catalog items are ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.8.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: cfme-future
Assignee: Bill Wei
QA Contact: Shveta
URL:
Whiteboard:
: 1496601 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 15:48 UTC by Franck Grosjean
Modified: 2018-12-11 16:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 16:53:54 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Franck Grosjean 2017-09-26 15:48:05 UTC
Description of problem:
Button groups created on orchestration type service catalog items are not seen on services based on this service catalog item

Version-Release number of selected component (if applicable):
Version 5.8.1.5.20170725160636_e433fc0 

How reproducible:
Create a button group on a service catalog item type orchestration
Service -> Catalog Item -> Configuration -> Add new button group

Steps to Reproduce:
1. Create a button group on a service catalog item type orchestration
2. Check services based on this catalog item

Actual results:
Button group created on the service catalog item is not seen

Expected results:
Button group and associated button(s) should be seen on services created from the service catalog item like any other service catalog template

Additional info:
---

Comment 2 Chris Hale 2017-09-26 18:58:17 UTC
Can you reproduce this issue?

Comment 3 Dave Johnson 2017-09-26 21:35:37 UTC
Shveta, can you take a peek here.  Please see if you can reproduce and review our test coverage for any blind spots.  THX!

Comment 4 Shveta 2017-09-27 19:37:55 UTC
Appliance : 
https://10.8.198.50.

The issue can be seen in OPS UI too .
Service -orchestration_Service . Button group is not seen.

In SUI . Service is not displayed. Shows error .

Comment 5 Chris Hale 2017-09-27 20:52:07 UTC
Shveta.  Can you create a bug for the API team because we are getting a http 500 error on that appliance with that Service you created.  I think we should have them resolve that and get it to where the SUI doesn't throw an error before we dig further on why this button doesn't show up.

Comment 7 Shveta 2017-09-27 22:22:19 UTC
Created https://bugzilla.redhat.com/show_bug.cgi?id=1496601

Comment 8 Chris Kacerguis 2017-09-29 17:45:25 UTC
*** Bug 1496601 has been marked as a duplicate of this bug. ***

Comment 9 Jillian Tullo 2017-10-05 17:33:15 UTC
PR: https://github.com/ManageIQ/manageiq-api/pull/110

Comment 10 CFME Bot 2017-10-05 18:16:41 UTC
New commit detected on ManageIQ/manageiq-api/master:
https://github.com/ManageIQ/manageiq-api/commit/ec54de6a85f15fb4bbf614e62378995c7ad8e863

commit ec54de6a85f15fb4bbf614e62378995c7ad8e863
Author:     Jillian Tullo <jtullo@redhat.com>
AuthorDate: Thu Oct 5 13:24:40 2017 -0400
Commit:     Jillian Tullo <jtullo@redhat.com>
CommitDate: Thu Oct 5 13:24:40 2017 -0400

    https://bugzilla.redhat.com/show_bug.cgi?id=1496190

 app/controllers/api/subcollections/orchestration_stacks.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 11 Shveta 2018-02-09 06:45:19 UTC
It is fixed in SUI .

But I  don't see this fixed in 5.9.0.20.20180206200727_d1873b9 in OPS UI

appliance : https://10.8.196.135
Service : Orchestration.

I can open a new bug for OPS UI if required.

Comment 13 Jillian Tullo 2018-02-15 15:24:14 UTC
From what I can tell, the OPS UI does not use the API for this particular part. I would suggest that there be an additional ticket for the OPS UI

Comment 14 Tim Wade 2018-04-17 21:43:25 UTC
Assigning to Bill as per https://github.com/ManageIQ/manageiq-api/pull/110#issuecomment-334547036


Note You need to log in before you can comment on or make changes to this bug.