Bug 1496686 - When remove ntp package we broke the ovirt-node.
Summary: When remove ntp package we broke the ovirt-node.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Packaging.rpm
Version: 4.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.4.0
: ---
Assignee: Yuval Turgeman
QA Contact: shiyi lei
URL:
Whiteboard:
Depends On: 1206608 1456863
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-28 06:50 UTC by Kobi Hakimi
Modified: 2020-11-27 01:38 UTC (History)
15 users (show)

Fixed In Version: redhat-virtualization-host-4.2-20171123.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-20 20:04:04 UTC
oVirt Team: Node
rbarry: needinfo-
rule-engine: ovirt-4.4+
aoconnor: blocker-
cshao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1503148 0 low CLOSED [RFE] translate between basic ntp configurations and chrony configurations 2021-02-22 00:41:40 UTC
Red Hat Knowledge Base (Solution) 5604431 0 None None None 2020-11-27 01:37:23 UTC
oVirt gerrit 84051 0 'None' MERGED host-node: remove ntp 2020-11-26 08:42:55 UTC
oVirt gerrit 84052 0 'None' MERGED host-node: remove ntp 2020-11-26 08:42:54 UTC

Internal Links: 1503148

Description Kobi Hakimi 2017-09-28 06:50:41 UTC
Description of problem:
When remove ntp package we broke the ovirt-node.

Version-Release number of selected component (if applicable):
ovirt-node-ng-4.2.0-0.20170918.0
ovirt-release-host-node-4.2.0-0.0.master.20170915014927.git09a1769.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy the ovirt-node-ng-4.2.0-0.20170918.0
2. Run the command: "yum remove -y ntp"


Actual results:
We broke the ovirt node since ovirt-release-host-node depend on ntp and we remove ovirt-release-host-node in this case.
from this point the server is pingable but you can't reach it in ssh and get only black screen with ipmi


Expected results:
1. To protect critical packages like ovirt-release-host-node.
2. Maybe we can remove the dependency of ovirt-release-host-node in ntp.
(for example in our case we want to work with chrony and we broke the node because of this dependencies).

Additional info:
[root@ovirt-node-master-test ~]# yum remove ntp
Loaded plugins: fastestmirror, imgbased-persist
Resolving Dependencies
--> Running transaction check
---> Package ntp.x86_64 0:4.2.6p5-25.el7.centos.2 will be erased
--> Processing Dependency: ntp for package: ovirt-release-host-node-4.2.0-0.0.master.20170915014927.git09a1769.el7.centos.noarch
--> Running transaction check
---> Package ovirt-release-host-node.noarch 0:4.2.0-0.0.master.20170915014927.git09a1769.el7.centos will be erased
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                            Arch                              Version                                                                           Repository                            Size
===================================================================================================================================================================================================================
Removing:
 ntp                                                x86_64                            4.2.6p5-25.el7.centos.2                                                           installed                            1.4 M
Removing for dependencies:
 ovirt-release-host-node                            noarch                            4.2.0-0.0.master.20170915014927.git09a1769.el7.centos                             installed                            315 k

Transaction Summary
===================================================================================================================================================================================================================
Remove  1 Package (+1 Dependent package)

Installed size: 1.7 M
Is this ok [y/N]: n


[root@ovirt-node-master-test ~]# rpm -ql ovirt-release-host-node-4.2.0-0.0.master.20170915014927.git09a1769.el7.centos.noarch
/data/images/rhev
/usr/lib/os.release.d/ovirt-release-host-node
/usr/lib/systemd/system-preset/98-ovirt-host-node.preset
/usr/share/ovirt-release-host-node
/usr/share/ovirt-release-host-node/branding
/usr/share/ovirt-release-host-node/branding/bg-login.png
/usr/share/ovirt-release-host-node/branding/branding.css
/usr/share/ovirt-release-host-node/branding/favicon.ico
/usr/share/ovirt-release-host-node/branding/logo.png


[root@ovirt-node-master-test ~]# cat /usr/lib/systemd/system-preset/98-ovirt-host-node.preset
# System stuff
# https://fedoraproject.org/w/index.php?title=Starting_services_by_default&oldid=377748
enable cockpit.socket
enable sshd.service
enable NetworkManager.service
enable imgbase-motd.service
enable libvirtd.service
enable ovirt-vmconsole-host-sshd.service

Comment 1 cshao 2017-09-28 07:09:45 UTC
Test version:
ovirt-node-ng-4.2.0-0.20170927.0+1

Test steps:
1. Deploy the ovirt-node-ng-4.2.0-0.20170927.0+1.
2. Run the command: "yum remove -y ntp"

# yum remove -y ntp
Loaded plugins: fastestmirror, imgbased-persist
Resolving Dependencies
--> Running transaction check
---> Package ntp.x86_64 0:4.2.6p5-25.el7.centos.2 will be erased
--> Processing Dependency: ntp for package: ovirt-release-host-node-4.2.0-0.0.master.20170926014924.gitf5d3c3d.el7.centos.noarch
--> Running transaction check
---> Package ovirt-release-host-node.noarch 0:4.2.0-0.0.master.20170926014924.gitf5d3c3d.el7.centos will be erased
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                            Arch                              Version                                                                           Repository                            Size
===================================================================================================================================================================================================================
Removing:
 ntp                                                x86_64                            4.2.6p5-25.el7.centos.2                                                           installed                            1.4 M
Removing for dependencies:
 ovirt-release-host-node                            noarch                            4.2.0-0.0.master.20170926014924.gitf5d3c3d.el7.centos                             installed                            315 k

Transaction Summary
===================================================================================================================================================================================================================
Remove  1 Package (+1 Dependent package)

Installed size: 1.7 M
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Erasing    : ovirt-release-host-node-4.2.0-0.0.master.20170926014924.gitf5d3c3d.el7.centos.noarch                                                                                                            1/2 
  Erasing    : ntp-4.2.6p5-25.el7.centos.2.x86_64                                                                                                                                                              2/2 
warning: /etc/ntp.conf saved as /etc/ntp.conf.rpmsave
  Verifying  : ovirt-release-host-node-4.2.0-0.0.master.20170926014924.gitf5d3c3d.el7.centos.noarch                                                                                                            1/2 
  Verifying  : ntp-4.2.6p5-25.el7.centos.2.x86_64                                                                                                                                                              2/2 

Removed:
  ntp.x86_64 0:4.2.6p5-25.el7.centos.2                                                                                                                                                                             

Dependency Removed:
  ovirt-release-host-node.noarch 0:4.2.0-0.0.master.20170926014924.gitf5d3c3d.el7.centos  

# rpm -ql ovirt-release-host-node
package ovirt-release-host-node is not installed

QE can reproduce this issue.

Comment 2 Ryan Barry 2017-09-28 12:28:19 UTC
ssh is unavailable because the firewall preset is removed. This should definitely not affect anything with IPMI.

We can protect ovirt-release-host-node/redhat-release-virtualization-host from removal with yum, but it is not possible to protect it from removal with "rpm -e --nodeps", just to make the scope of a solution clear.

Additionally, since we just added ntp back in 4.1.5, I would say that we should not remove this (and whatever automation script you have which is removing it should stop). With PM approval, we may be able to remove this from 4.2, but I am not optimistic about this.

See also http://bugzilla.redhat.com/show_bug.cgi?id=1476650

Comment 3 Kobi Hakimi 2017-10-01 10:09:20 UTC
We have the same issue with:
[3.6 NG] packages like vdsm got removed when the ntp removed
https://projects.engineering.redhat.com/browse/RHEVM-3118

Comment 4 Ryan Barry 2017-10-01 13:00:43 UTC
What is removing ntp?

This is expected depsolving behavior. Not a bug. It is extremely unlikely to get a 3.6 backport.

Comment 5 Kobi Hakimi 2017-10-01 13:16:32 UTC
@Ryan,
I don't want to do 3.6 backport.
I just added a similar issue that we had in 3.6

Comment 6 Ryan Barry 2017-10-01 13:33:58 UTC
I understand. I'm just conveying that this is only an issue in the sense that whatever is removing ntp should not be doing it.

We can protect ovirt-release-host-node, but that means it will not be possible to remove ntp, and whatever script/playbook is doing it will fail.

Comment 7 Kobi Hakimi 2017-10-01 14:42:34 UTC
Ryan,
IMHO since we could remove the ntp in rhvh-4.1 we should be able to remove it in 4.2 too.
Also, as you can see in [Docs][Planning] Recommend chrony for time synchronization https://bugzilla.redhat.com/show_bug.cgi?id=1478768

The preferred option is chrony.

Comment 8 Red Hat Bugzilla Rules Engine 2017-10-01 14:43:05 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 9 Ryan Barry 2017-10-01 14:52:29 UTC
That was changed in 4.1

However, see the bug in comment#2

Allowing the removal of ntp in rhvh potentially causes problems unless we track this outside of the normal dep tree.

Until there is PM approval for removing ntp (which will also require an obvious docs note), any fix for this bug will protect ovirt-release-host-node/redhat-release-virtualization-host, not allow removal of ntp, which is part of the base image again since 4.1 to resolve a customer case.

With that in mind, comment#6 applies here. Protecting the release file will ensure that vdsm is not removed to depsolve. It will also not allow ntp to be removed.

Again, what process is trying to remove ntp?

Comment 10 Kobi Hakimi 2017-10-01 15:15:25 UTC
The process that removed the ntp is part of our automation setting to use the chrony instead of ntp.

Comment 11 Ryan Barry 2017-10-01 16:19:56 UTC
I would suggest disabling ntp.service and enabling chrony on Node instead of the equivalent of "yum -y remove" for now

Comment 12 Sandro Bonazzola 2017-10-12 12:31:30 UTC
I agree with Ryan here, please disable ntp instead of removing the package.
Even if we allow to remove it, it would probably be back as soon as you update.
Lowering severity.

Comment 13 Kobi Hakimi 2017-10-15 12:25:29 UTC
(In reply to Sandro Bonazzola from comment #12)
> I agree with Ryan here, please disable ntp instead of removing the package.
> Even if we allow to remove it, it would probably be back as soon as you
> update.
> Lowering severity.

Added PR to disable it:
https://github.com/ericsysmin/ansible-role-chrony/pull/1

Comment 14 Moran Goldboim 2017-10-15 13:19:29 UTC
(In reply to Ryan Barry from comment #11)
> I would suggest disabling ntp.service and enabling chrony on Node instead of
> the equivalent of "yum -y remove" for now

sounds right to me, however let's try to figure out the longer term approach, if when and how should we remove ntp

Comment 15 Ryan Barry 2017-10-15 13:25:14 UTC
4.2 seems a reasonable target for removal to me, as suggested in comment#2

Comment 16 Moran Goldboim 2017-10-17 09:31:45 UTC
(In reply to Ryan Barry from comment #15)
> 4.2 seems a reasonable target for removal to me, as suggested in comment#2

ack from my side to remove in 4.2.

Comment 17 cshao 2017-12-13 10:39:06 UTC
Test version:
rhvh-4.2.0.5-0.20171207.0+1
imgbased-1.0.4-0.1.el7ev.noarch

I have to assigned this bug due to we broke lots of package during remove ntp package.

# yum remove -y ntp
......
Dependencies Resolved

================================================================================
 Package                                                                  Arch                                 Version                                               Repository                               Size
================================================================================
Removing:
 ntp                                                                      x86_64                               4.2.6p5-25.el7_3.2                                    installed                               1.4 M
Removing for dependencies:
 cockpit-ovirt-dashboard                                                  noarch                               0.11.1-0.6.el7ev                                      installed                                15 M
 ipa-client                                                               x86_64                               4.5.0-22.el7_4                                        installed                               250 k
 ovirt-host                                                               x86_64                               4.2.0-1.el7ev                                         installed                                11 k
 ovirt-hosted-engine-setup                                                noarch                               2.2.0-2.el7ev                                         installed                               2.1 M
 redhat-release-virtualization-host-content                               x86_64                               4.2-0.5.el7                                           installed                               0.0  
 rhvm-appliance                                                           noarch                               1:4.2-20171207.0.el7                                  installed                               1.4 G

Transaction Summary
================================================================================
Remove  1 Package (+6 Dependent packages)

Installed size: 1.4 G
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Erasing    : redhat-release-virtualization-host-content-4.2-0.5.el7.x86_64                                                                                                                                   1/7 
  Erasing    : 1:rhvm-appliance-4.2-20171207.0.el7.noarch                                                                                                                                                      2/7 
  Erasing    : cockpit-ovirt-dashboard-0.11.1-0.6.el7ev.noarch                                                                                                                                                 3/7 
  Erasing    : ovirt-host-4.2.0-1.el7ev.x86_64                                                                                                                                                                 4/7 
  Erasing    : ovirt-hosted-engine-setup-2.2.0-2.el7ev.noarch                                                                                                                                                  5/7 
  Erasing    : ipa-client-4.5.0-22.el7_4.x86_64                                                                                                                                                                6/7 
  Erasing    : ntp-4.2.6p5-25.el7_3.2.x86_64                                                                                                                                                                   7/7 
warning: /etc/ntp.conf saved as /etc/ntp.conf.rpmsave
  Verifying  : 1:rhvm-appliance-4.2-20171207.0.el7.noarch                                                                                                                                                      1/7 
  Verifying  : cockpit-ovirt-dashboard-0.11.1-0.6.el7ev.noarch                                                                                                                                                 2/7 
  Verifying  : ovirt-host-4.2.0-1.el7ev.x86_64                                                                                                                                                                 3/7 
  Verifying  : redhat-release-virtualization-host-content-4.2-0.5.el7.x86_64                                                                                                                                   4/7 
  Verifying  : ovirt-hosted-engine-setup-2.2.0-2.el7ev.noarch                                                                                                                                                  5/7 
  Verifying  : ntp-4.2.6p5-25.el7_3.2.x86_64                                                                                                                                                                   6/7 
  Verifying  : ipa-client-4.5.0-22.el7_4.x86_64                                                                                                                                                                7/7 

Removed:
  ntp.x86_64 0:4.2.6p5-25.el7_3.2                                                                                                                                                                                  

Dependency Removed:
  cockpit-ovirt-dashboard.noarch 0:0.11.1-0.6.el7ev                    ipa-client.x86_64 0:4.5.0-22.el7_4              ovirt-host.x86_64 0:4.2.0-1.el7ev      ovirt-hosted-engine-setup.noarch 0:2.2.0-2.el7ev     
  redhat-release-virtualization-host-content.x86_64 0:4.2-0.5.el7      rhvm-appliance.noarch 1:4.2-20171207.0.el7

Comment 18 Yuval Turgeman 2017-12-13 12:59:30 UTC
Removed from redhat-release-virtualization-host-content-4.2-0.6.el7.x86_64

Comment 19 cshao 2017-12-15 04:56:41 UTC
# imgbase w 
You are on rhvh-4.2.0.6-0.20171213.0+1

# rpm -qa| grep ntp
ntp-4.2.6p5-25.el7_3.2.x86_64
ntpdate-4.2.6p5-25.el7_3.2.x86_64

# ll /etc/ntp.conf 
-rw-r--r--. 1 root root 2098 Dec 14 22:54 /etc/ntp.conf


Yuval,
The ntp package still existing in 4.2. may I ask the final solution for ntp package?  Do we need remove it from node?

Thanks.

Comment 20 Ryan Barry 2017-12-16 17:18:08 UTC
ntp is now removed from all RHV dependencies.

It is required by ipa-client, though. Which is, in turn, required by ovirt-host, so removing ntp will remove:

ipa-client ->
ovirt-host ->
everything else

We'll need to work with the IPA team to move to chrony instead of ntp now

Comment 21 cshao 2017-12-18 02:38:33 UTC
(In reply to Ryan Barry from comment #20)
> ntp is now removed from all RHV dependencies.
> 
> It is required by ipa-client, though. Which is, in turn, required by
> ovirt-host, so removing ntp will remove:
> 
> ipa-client ->
> ovirt-host ->
> everything else
> 
> We'll need to work with the IPA team to move to chrony instead of ntp now

Thanks Ryan, so move to assigned status.

Comment 22 Red Hat Bugzilla Rules Engine 2017-12-18 02:38:43 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 23 Yaniv Kaul 2018-04-02 08:01:21 UTC
(In reply to Ryan Barry from comment #20)
> ntp is now removed from all RHV dependencies.
> 
> It is required by ipa-client, though. Which is, in turn, required by
> ovirt-host, so removing ntp will remove:
> 
> ipa-client ->
> ovirt-host ->
> everything else
> 
> We'll need to work with the IPA team to move to chrony instead of ntp now

Where's the BZ for IPA to move to chrony?

Comment 24 Yuval Turgeman 2018-04-02 08:12:11 UTC
Looks like bug 1206608 and bug 1456863 cover this

Comment 26 Raz Tamir 2018-08-22 14:23:21 UTC
Please retarget this to 4.2.7 as this is a regression and 100% reproducible

Comment 31 Yuval Turgeman 2018-11-25 09:35:41 UTC
We do not require ntp anymore, this looks like an ipa-client bug, can this be closed or moved to a different component ?

Comment 32 Kobi Hakimi 2018-11-25 15:22:31 UTC
after try to reproduce with the following:
[root@lynx09 ~]# imgbase w
You are on rhvh-4.3.0.0-0.20181122.0+1
[root@lynx09 ~]# rpm -qa|grep chrony
chrony-3.2-2.el7.x86_64
[root@lynx09 ~]# rpm -qa|grep ntp
ntp-4.2.6p5-28.el7.x86_64
ntpdate-4.2.6p5-28.el7.x86_64
[root@lynx09 ~]# yum remove ntp
Loaded plugins: enabled_repos_upload, imgbased-persist, package_upload, product-id, search-disabled-repos, subscription-manager, vdsmupgrade
This system is not registered with an entitlement server. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package ntp.x86_64 0:4.2.6p5-28.el7 will be erased
--> Processing Dependency: ntp for package: ipa-client-4.6.4-10.el7.x86_64
--> Running transaction check
---> Package ipa-client.x86_64 0:4.6.4-10.el7 will be erased
--> Processing Dependency: ipa-client for package: ovirt-host-4.3.0-0.1.beta.el7ev.x86_64
--> Running transaction check
---> Package ovirt-host.x86_64 0:4.3.0-0.1.beta.el7ev will be erased
--> Processing Dependency: ovirt-host for package: redhat-release-virtualization-host-content-4.3-0.0.el7.x86_64
--> Processing Dependency: ovirt-host >= 4.3 for package: ovirt-hosted-engine-setup-2.3.0-0.1.alpha.gitd1b8dbb.el7ev.noarch
--> Running transaction check
---> Package ovirt-hosted-engine-setup.noarch 0:2.3.0-0.1.alpha.gitd1b8dbb.el7ev will be erased
--> Processing Dependency: ovirt-hosted-engine-setup for package: 2:rhvm-appliance-4.3-20181122.1.el7.noarch
--> Processing Dependency: ovirt-hosted-engine-setup >= 2.3.0 for package: cockpit-ovirt-dashboard-0.12.0-0.0.beta1.el7ev.noarch
---> Package redhat-release-virtualization-host-content.x86_64 0:4.3-0.0.el7 will be erased
--> Running transaction check
---> Package cockpit-ovirt-dashboard.noarch 0:0.12.0-0.0.beta1.el7ev will be erased
---> Package rhvm-appliance.noarch 2:4.3-20181122.1.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================================================================================
 Package                                                                     Arch                                    Version                                                              Repository                                   Size
============================================================================================================================================================================================================================================
Removing:
 ntp                                                                         x86_64                                  4.2.6p5-28.el7                                                       installed                                   1.4 M
Removing for dependencies:
 cockpit-ovirt-dashboard                                                     noarch                                  0.12.0-0.0.beta1.el7ev                                               installed                                    15 M
 ipa-client                                                                  x86_64                                  4.6.4-10.el7                                                         installed                                   254 k
 ovirt-host                                                                  x86_64                                  4.3.0-0.1.beta.el7ev                                                 installed                                    11 k
 ovirt-hosted-engine-setup                                                   noarch                                  2.3.0-0.1.alpha.gitd1b8dbb.el7ev                                     installed                                   2.3 M
 redhat-release-virtualization-host-content                                  x86_64                                  4.3-0.0.el7                                                          installed                                   0.0
 rhvm-appliance                                                              noarch                                  2:4.3-20181122.1.el7                                                 @rhv-4.3.0                                  1.6 G

Transaction Summary
============================================================================================================================================================================================================================================
Remove  1 Package (+6 Dependent packages)

Installed size: 1.6 G
Is this ok [y/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Erasing    : redhat-release-virtualization-host-content-4.3-0.0.el7.x86_64                                                                                                                                                            1/7
  Erasing    : 2:rhvm-appliance-4.3-20181122.1.el7.noarch                                                                                                                                                                               2/7
  Erasing    : cockpit-ovirt-dashboard-0.12.0-0.0.beta1.el7ev.noarch                                                                                                                                                                    3/7
  Erasing    : ovirt-host-4.3.0-0.1.beta.el7ev.x86_64                                                                                                                                                                                   4/7
  Erasing    : ovirt-hosted-engine-setup-2.3.0-0.1.alpha.gitd1b8dbb.el7ev.noarch                                                                                                                                                        5/7
  Erasing    : ipa-client-4.6.4-10.el7.x86_64                                                                                                                                                                                           6/7
  Erasing    : ntp-4.2.6p5-28.el7.x86_64                                                                                                                                                                                                7/7
warning: /etc/ntp.conf saved as /etc/ntp.conf.rpmsave
Uploading Package Profile
Cannot upload package profile. Is this client registered?
ansible-27-nightly/x86_64                                                                                                                                                                                            | 4.2 kB  00:00:00
jboss-eap-7.1/x86_64                                                                                                                                                                                                 | 3.8 kB  00:00:00
rhel-7-server-fast-datapath-nightly/x86_64                                                                                                                                                                           | 3.0 kB  00:00:00
rhel-7-server-rhv-manager-tools                                                                                                                                                                                      | 4.0 kB  00:00:00
rhel-7-server-rhv-mgmt-agent-ppc                                                                                                                                                                                     | 4.0 kB  00:00:00
rhel-7-server-rhv-mgmt-agent-x86                                                                                                                                                                                     | 4.1 kB  00:00:00
rhel-7-server-rhv-tools-ppc                                                                                                                                                                                          | 4.0 kB  00:00:00
rhel-7-server-rhvh                                                                                                                                                                                                   | 4.0 kB  00:00:00
rhel-7-server-rhvh-build                                                                                                                                                                                             | 4.0 kB  00:00:00
rhevh-76/x86_64                                                                                                                                                                                                      | 2.6 kB  00:00:00
rhv-4.3.0/7RedHatVirtualizationHost                                                                                                                                                                                  | 3.0 kB  00:00:00
xtra                                                                                                                                                                                                                 | 2.9 kB  00:00:00
  Verifying  : ovirt-hosted-engine-setup-2.3.0-0.1.alpha.gitd1b8dbb.el7ev.noarch                                                                                                                                                        1/7
  Verifying  : redhat-release-virtualization-host-content-4.3-0.0.el7.x86_64                                                                                                                                                            2/7
  Verifying  : cockpit-ovirt-dashboard-0.12.0-0.0.beta1.el7ev.noarch                                                                                                                                                                    3/7
  Verifying  : 2:rhvm-appliance-4.3-20181122.1.el7.noarch                                                                                                                                                                               4/7
  Verifying  : ovirt-host-4.3.0-0.1.beta.el7ev.x86_64                                                                                                                                                                                   5/7
  Verifying  : ipa-client-4.6.4-10.el7.x86_64                                                                                                                                                                                           6/7
  Verifying  : ntp-4.2.6p5-28.el7.x86_64                                                                                                                                                                                                7/7

Removed:
  ntp.x86_64 0:4.2.6p5-28.el7

Dependency Removed:
  cockpit-ovirt-dashboard.noarch 0:0.12.0-0.0.beta1.el7ev             ipa-client.x86_64 0:4.6.4-10.el7               ovirt-host.x86_64 0:4.3.0-0.1.beta.el7ev     ovirt-hosted-engine-setup.noarch 0:2.3.0-0.1.alpha.gitd1b8dbb.el7ev
  redhat-release-virtualization-host-content.x86_64 0:4.3-0.0.el7     rhvm-appliance.noarch 2:4.3-20181122.1.el7

Complete!
Uploading Enabled Repositories Report
Cannot upload enabled repos report, is this client registered?
[root@lynx09 ~]#

The rhvh is up and running (even after maintenance and reboot) but I don't really know all the side effects that can happen as a result of the removed packages above.

Comment 33 Sandro Bonazzola 2018-12-20 10:08:32 UTC
Moving this out to 4.4:  it doesn't look like ipa-client will stop requiring ntp in RHEL 7.6

Comment 34 Sandro Bonazzola 2019-06-21 05:49:55 UTC
Yuval, this should be solved in latest IPA on fedora 29 and CentOS 8, can you please check?

Comment 35 Yuval Turgeman 2019-11-19 15:26:07 UTC
ipa-client pulls in chrony on 4.4, and ntp is not installed

Comment 36 shiyi lei 2019-12-02 04:53:19 UTC
Test Version:
redhat-release-virtualization-host-4.4.0-9.el8ev.x86_64
ovirt-host-4.4.0-0.2.alpha.el8ev.x86_64

Steps:
1. install rhvh-4.4.0.9-0.20191201.0

2. check chrony package:
[root@dhcp-8-157 ~]# rpm -qa|grep chrony
chrony-3.5-1.el8.x86_64

3. check ntp package:
[root@dhcp-8-157 ~]# rpm -qa|grep ntp
fontpackages-filesystem-1.44-22.el8.noarch


Test result:
There is chrony package pre-installed and there is no ntp package both before and after enable repos.
This bug has been fixed in the latest version of RHVH-4.4.0, QE will move the status to "VERIFIED" after devel change it to "ON_QA".

Comment 37 shiyi lei 2019-12-02 04:53:40 UTC
Test Version:
redhat-release-virtualization-host-4.4.0-9.el8ev.x86_64
ovirt-host-4.4.0-0.2.alpha.el8ev.x86_64

Steps:
1. install rhvh-4.4.0.9-0.20191201.0

2. check chrony package:
[root@dhcp-8-157 ~]# rpm -qa|grep chrony
chrony-3.5-1.el8.x86_64

3. check ntp package:
[root@dhcp-8-157 ~]# rpm -qa|grep ntp
fontpackages-filesystem-1.44-22.el8.noarch


Test result:
There is chrony package pre-installed and there is no ntp package both before and after enable repos.
This bug has been fixed in the latest version of RHVH-4.4.0, QE will move the status to "VERIFIED" after devel change it to "ON_QA".

Comment 38 Wei Wang 2019-12-16 03:15:05 UTC
According to comment 36, move bug status to "VERIFIED".

Comment 39 Sandro Bonazzola 2020-05-20 20:04:04 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.