Bug 149798 - kernel on x86_64 is not doing NFS mounts
kernel on x86_64 is not doing NFS mounts
Status: CLOSED DUPLICATE of bug 149790
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-27 00:37 EST by Michal Jaegermann
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-01 13:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-02-27 00:37:44 EST
Description of problem:

With current development kernels I see the following:

# showmount -e smok
Export list for smok:
/     192.168.xx.yy/255.255.255.0
/home 192.168.xx.yy/255.255.255.0

This is expected; but

# mount -v -t nfs smok:/home /mnt/srv/
mount to NFS server 'smok' failed: server is down.
RPC Error: 0 ( Success )

No error messages in logs I can find.

With the same version of a devel kernel but on i686 the same
file system is mounted over NFS without any problems.  Ditto
for x86_64 but running updated FC3.

For autofs results are even stranger.  Corresponding directories
do show up under /net/smok/ but if you will try access them they
disappear.

Version-Release number of selected component (if applicable):
At least kernel-2.6.10-1.1154_FC4 and kernel-2.6.10-1.1149_FC4.
I cannot really tell when it started.
Comment 1 Michal Jaegermann 2005-03-01 17:40:36 EST
I did a bit of tracing.  Here is what strace shows in a test x86
installation (only that fragment which seems to be relevant):

.....
munmap(0xb7d0a000, 4096)                = 0
time(NULL)                              = 1109622812
socket(PF_INET, SOCK_STREAM, IPPROTO_TCP) = 3
bind(3, {sa_family=AF_INET, sin_port=htons(629),
sin_addr=inet_addr("0.0.0.0")}, 16) = -1 EADDRINUSE (Address already
in use)
bind(3, {sa_family=AF_INET, sin_port=htons(630),
sin_addr=inet_addr("0.0.0.0")}, 16) = 0
connect(3, {sa_family=AF_INET, sin_port=htons(111),
sin_addr=inet_addr("192.168.xx.yy")}, 16) = 0
gettimeofday({1109622812, 897687}, NULL) = 0
write(3, "\200\0\0(}y\345\5\0\0\0\0\0\0\0\2\0\1\206\240\0\0\0\2\0"...,
44) = 44
poll([{fd=3, events=POLLIN, revents=POLLIN}], 1, 60000) = 1
read(3, "\0\0\1\214}y\345\5\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0"...,
500) = 456
close(3)                                = 0
socket(PF_INET, SOCK_DGRAM, IPPROTO_UDP) = 3
.....

and we are off to the races with an NFS-mounte file system.

And here is something from a similar system but x86_64:
....
munmap(0x2aaaaae44000, 4096)            = 0
socket(PF_INET, SOCK_STREAM, IPPROTO_TCP) = 3
bind(3, {sa_family=AF_INET, sin_port=htons(0),
sin_addr=inet_addr("0.0.0.0")}, 16) = 0
connect(3, {sa_family=AF_INET, sin_port=htons(111),
sin_addr=inet_addr("192.168.xx.yy")}, 16) = 0
write(3, "\200\0\0008nBp\205\0\0\0\0\0\0\0\2\0\1\206\240\0\0\0\2"...,
60) = 60
poll([{fd=3, events=POLLIN, revents=POLLIN}], 1, 20000) = 1
read(3, "\200\0\0\34nBp\205\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0"...,
500) = 32
close(3)                                = 0
write(2, "mount to NFS server \'smok\' faile"..., 33mount to NFS
server 'smok' failed) = 33
write(2, ": server is down.\n", 18: server is down.
)     = 18
....

I am not sure where the fault really lies but it sure looks
different.  This used to work a while ago with the same general
configuration.
Comment 2 Michal Jaegermann 2005-03-31 21:27:16 EST
This is really utils-linux issue and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=152956
is a duplicate.  Adding '-o udp' to mount options makes NFS work again
even with those servers which fail to respond to TCP attempts.
Comment 3 Michal Jaegermann 2005-04-01 13:14:45 EST

*** This bug has been marked as a duplicate of 149790 ***

Note You need to log in before you can comment on or make changes to this bug.