Bug 149790 - fail to mount nfs
fail to mount nfs
Status: CLOSED DUPLICATE of bug 150775
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
: 149798 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-26 16:51 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 16:47:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/debug (21.60 KB, text/plain)
2005-03-31 13:08 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2005-02-26 16:51:41 EST
Description of problem:
NFS fails to mount directories from local NFS server.
/var/log/messages show problem with "lookup(program)" - whatever that
is???

Presumably this change today is what broke it:

util-linux-2.12p-2
------------------
* Fri Feb 25 2005 Steve Dickson <SteveD@RedHat.com> 2.12p-2
- Changed nfsmount to only use reserve ports when necessary
  (bz# 141773)


Version-Release number of selected component (if applicable):
util-linux-2.12p-2

How reproducible:
100%

Steps to Reproduce:
1. Local NFS server with entry in /etc/hosts, but not in DNS
2. attempt to access any file or directory under NFS mount
3.
  
Actual results:
Feb 26 16:36:16 ontap automount[7136]: >> mount to NFS server 'barrel'
failed: server is down.
Feb 26 16:36:16 ontap automount[7136]: mount(nfs): nfs: mount failure
barrel:/usr/export on /net/barrel/usr/export
Feb 26 16:36:16 ontap automount[7142]: >> /usr/sbin/showmount: can't
get address for barrel/usr/export
Feb 26 16:36:16 ontap automount[7142]: lookup(program): lookup for
barrel/usr/export failed
Feb 26 16:36:16 ontap automount[7142]: failed to mount
/net/barrel/usr/export
Feb 26 16:36:16 ontap automount[7148]: >> /usr/sbin/showmount: can't
get address for barrel/usr
Feb 26 16:36:16 ontap automount[7148]: lookup(program): lookup for
barrel/usr failed
Feb 26 16:36:16 ontap automount[7148]: failed to mount /net/barrel/usr
Feb 26 16:36:16 ontap automount[7156]: >> /usr/sbin/showmount: can't
get address for barrel/usr
Feb 26 16:36:17 ontap automount[7156]: lookup(program): lookup for
barrel/usr failed
Feb 26 16:36:17 ontap automount[7156]: failed to mount /net/barrel/usr


Expected results:
Working NFS.

Additional info:
Problem cleared by reverting to: util-linux-2.12p-1
Comment 1 John Ellson 2005-03-17 07:58:40 EST
Still broken in util-linux-2.12p-3
Comment 4 Jeffrey Moyer 2005-03-30 14:12:39 EST
This looks to be an autofs bug.  What version of autofs are you using?
Comment 5 John Ellson 2005-03-30 15:41:22 EST
autofs-4.1.3-107

The bug may be in autofs, but it is definitely triggered by the util-linux upgrade.

I'm surprised that "ls /net/barrel" and "ls /net/barrel/usr" work while
"ls /net/barrel/usr/export" does not.   Must be significant somehow?

root@ontap:~# rpm -Uvh util-linux-2.12p-3.x86_64.rpm
Preparing...                ########################################### [100%]
   1:util-linux             ########################################### [100%]
root@ontap:~# service autofs restart
Stopping automount:                                        [  OK  ]
Starting automount:                                        [  OK  ]
root@ontap:~# ls -l /net/barrel
total 0
dr-xr-xr-x  3 root root 0 Mar 30 15:38 usr
root@ontap:~# ls -l /net/barrel/usr
total 0
dr-xr-xr-x  2 root root 0 Mar 30 15:38 export
root@ontap:~# ls -l /net/barrel/usr/export
ls: /net/barrel/usr/export: No such file or directory





root@ontap:~# rpm -Uvh --oldpackage util-linux-2.12p-1.x86_64.rpm
Preparing...                ########################################### [100%]
   1:util-linux             ########################################### [100%]
root@ontap:~# service autofs restart
Stopping automount:                                        [  OK  ]
Starting automount:                                        [  OK  ]
root@ontap:~# ls -l /net/barrel
total 0
dr-xr-xr-x  3 root root 0 Mar 30 15:39 usr
root@ontap:~# ls -l /net/barrel/usr
total 4
drwxr-xr-x  9 root root 4096 Mar 14 09:07 export
root@ontap:~# ls -l /net/barrel/usr/export
total 28
drwxrwxr-x   7 ellson ellson 4096 Jul  8  2004 backgrounds
drwxr-xr-x   3 root   root   4096 Jan 27  2004 backup
drwxr-xrwx  10 ellson ellson 8192 Mar 20 09:35 mirrors
drwxr-xrwx  30 ellson ellson 4096 Dec  5 12:24 music
drwxr-xr-x  25 root   root   4096 Feb 15  2004 pat
drwxr-xr-x   5 root   root   4096 Nov 26 18:15 vernors
Comment 6 John Ellson 2005-03-30 15:44:46 EST
BTW  I get the same problem on multiple clients to this NFS server, both x86_64
and i386.
Comment 7 Jeffrey Moyer 2005-03-31 12:22:21 EST
Strange.  Could you enable debugging for this specific mount point in your
/etc/auto.master (simply append a --debug to the line for /net)?  Then, make
sure all messages are dumped to a debug log.  You could add a line to
/etc/syslog.conf like so:
*.*    /var/log/debug

restart syslogd, restart the automounter, and send me the logs after performing
your test.

It would also be useful to get the output from the following command:

/etc/auto.net barrel

Thanks!
Comment 8 John Ellson 2005-03-31 13:08:58 EST
Created attachment 112527 [details]
/var/log/debug
Comment 9 John Ellson 2005-03-31 13:11:24 EST
The preceding /var/log/debug was with util-linux-2.12p-4 installed


root@ontap:~# /etc/auto.net barrel
-fstype=nfs,hard,intr,nodev,nosuid \
        /usr/export barrel:/usr/export
Comment 10 Jeffrey Moyer 2005-03-31 13:14:25 EST
Mar 31 13:01:55 ontap automount[24342]: mount(nfs): calling mount -t nfs -s  -o
hard,intr,nodev,nosuid barrel:/usr/export /net/barrel/usr/export
Mar 31 13:01:55 ontap automount[24342]: >> mount to NFS server 'barrel' failed:
server is down.
Mar 31 13:01:55 ontap automount[24342]: mount(nfs): nfs: mount failure
barrel:/usr/export on /net/barrel/usr/export

Okay, given the logs above, you are absolutely correct in implicating
util-linux!  (but you already knew that, right?)

Thanks for the quick turn-around on testing!

Steve, back in your court.
Comment 11 Jeffrey Moyer 2005-03-31 13:18:59 EST
John,

Can you perform a manual mount using the command line provided in the logs
(after creating the proper directory hierarchy, of course)?

My guess on this is that it's doing a UDP probe, and your server only responds
to TCP.  Does that make any sense?
Comment 12 John Ellson 2005-03-31 13:31:45 EST
root@ontap:~#  mount -t nfs -s  -o hard,intr,nodev,nosuid barrel:/usr/export
/net/barrel/usr/export
mount to NFS server 'barrel' failed: server is down.


The server is an "old faithful" RedHat-9 machine running nfs-utils-1.0.1-3.9
No ipchains or iptables running.

Comment 13 Karel Zak 2005-03-31 15:16:35 EST
It's util-linux problem in FC3|4. We have more reports:

bug #150775 – NFSv2 UDP mounts broken in FC4test1
bug #152956 – NFS-Mount fails after update to util-linux-2.12a-21

the problem is with old NFS servers like RH9, AS2.1, ... the current mount
command doens't  switch automatically to UDP for these servers. You can use
workaround "mount -oudp"

I think Steve is working on solution.
Comment 14 Steve Dickson 2005-03-31 16:47:08 EST

*** This bug has been marked as a duplicate of 150775 ***
Comment 15 Michal Jaegermann 2005-04-01 13:15:03 EST
*** Bug 149798 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.