Bug 149855 - "rpmdb-redhat" suggests obsolete/wrong resolutions and needs update
Summary: "rpmdb-redhat" suggests obsolete/wrong resolutions and needs update
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpmdb-redhat (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Mike McLean
QA Contact:
URL:
Whiteboard:
Keywords:
: 109733 145030 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-28 12:12 UTC by Joachim Frieben
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 16:39:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2005-02-28 12:12:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041115 Epiphany/1.4.4

Description of problem:
When trying to install abiword-2.0.12-9 from the FC3 updates, "rpm" notifies about failed dependencies which is pretty normal:

error: Failed dependencies:
        aiksaurus-gtk >= 1.2.1 is needed by abiword-2.0.12-9.i386
        libAiksaurus-1.2.so.0 is needed by abiword-2.0.12-9.i386
        libAiksaurusGTK-1.2.so.0 is needed by abiword-2.0.12-9.i386
        libgda-2.so.1 is needed by abiword-2.0.12-9.i386
        libgnomedb >= 1.0.4 is needed by abiword-2.0.12-9.i386
        libgnomedb-2.so.3 is needed by abiword-2.0.12-9.i386
        libots-1.so.0 is needed by abiword-2.0.12-9.i386
        libwpd-1.so.7 is needed by abiword-2.0.12-9.i386
    Suggested resolutions:
        aiksaurus-1.2.1-2.i386.rpm
        aiksaurus-gtk-1.2.1-2.i386.rpm
        libgda-1.0.4-3.rhel4.i386.rpm
        libgnomedb-1.0.4-3.i386.rpm
        libwpd-0.7.2-1.i386.rpm
        ots-0.4.2-2.i386.rpm

The surprising thing is that libgda-1.0.4-3.rhel4 simply does not exist among the available RHEL4 packages.

Version-Release number of selected component (if applicable):
rpmdb-redhat-4-0.20050107

How reproducible:
Always

Steps to Reproduce:
1. Try to install abiword-2.0.12-9.
2. Check error message issued by "rpm".


Actual Results:  "rpm" tells which packages need to be installed to resolve failed dependencies including the not existing "libgda-1.0.4-3.rhel4" package.

Expected Results:  "rpmdb-redhat" should suggest existing packages only. The "libgda-1.0.4-3" does exist (without the "rhel4" suffix though) as part of FC3.

Additional info:

A couple of missing RPMs seem to have been dropped for the final RHEL4 release. As of RHEL4B2 (Nahant), e.g. libgda-1.0.4-3 and libgnomedb-1.0.4 were still part of the "distro".

Comment 1 Jay Turner 2005-03-01 09:20:14 UTC
I suspect they were dropped because nothing in RHEL4 depended on them.  Will
have to check into why rpmdb-redhat thinks that the package is included in the
distribution.

Comment 2 Mike McLean 2005-03-21 21:56:21 UTC
*** Bug 145030 has been marked as a duplicate of this bug. ***

Comment 4 Mike McLean 2005-04-25 20:21:03 UTC
should be fixed in next compose

Comment 5 Dennis Gregorovic 2005-05-02 03:18:59 UTC
*** Bug 109733 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Johnson 2006-01-06 16:39:55 UTC
Long since fixed or doesn't matter anymore.


Note You need to log in before you can comment on or make changes to this bug.