Bug 14990 - Beta 5 Perl breaks Net::FTP module
Beta 5 Perl breaks Net::FTP module
Status: CLOSED DUPLICATE of bug 14779
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On: 15199
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-01 12:22 EDT by Shane Painter
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 07:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Painter 2000-08-01 12:22:57 EDT
The rev from 5.6.0-4 in beta3 to 5.6.0-6 in Beta5 breaks Net::FTP. (libnet)
The following perl script will work fine on a RH6.2SBE2 system and Beta3 
system, but will fail on Beta4 & 5.


#!/usr/bin/perl
use Net::FTP;
@ISA = qw(Net::Cmd);
$ip="10.180.30.70";
$ftp = Net::FTP->new("$ip", Debug => 0);

print "Connecting...\n";

$ftp->login("anonymous",'ftp@dell.com');
$ftp->binary();
$ftp->cwd("/pub");
print "Current DIR is now /pub\n";
$reps = 0;
while($reps <=100)
{
	foreach $file (test1, test2)
	{
		print "Getting $file\n";
		$ftp->get("$file");
	}
	$reps = $reps + 1;
}

print "DONE.\n";
Comment 1 Nalin Dahyabhai 2000-08-03 07:42:27 EDT
The fix for #14779 appears to have fixed this as well.  Modifying the values
forthe $ip, test1, and test2 variables to pull README and README.roughcuts from
ourFTP server works.

*** This bug has been marked as a duplicate of 14779 ***

Note You need to log in before you can comment on or make changes to this bug.