Bug 1499158 - client-io-threads option not working for replicated volumes
Summary: client-io-threads option not working for replicated volumes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.12
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1487495 1498570
Blocks: glusterfs-3.12.2 1598416
TreeView+ depends on / blocked
 
Reported: 2017-10-06 09:36 UTC by Ravishankar N
Modified: 2018-07-05 12:06 UTC (History)
7 users (show)

Fixed In Version: glusterfs-glusterfs-3.12.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1498570
Environment:
Last Closed: 2017-10-13 12:47:15 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2017-10-06 09:36:41 UTC
+++ This bug was initially created as a clone of Bug #1498570 +++

+++ This bug was initially created as a clone of Bug #1487495 +++

Description of problem:
The option "performance.client-io-threads on" is needed in some scenarios where the fuse thread becomes a bottleneck. But this option seems to be disabled for replicated volumes i.e. setting the option on via the "gluster v set ..." command has no effect.

It is fine to set the option to off by default for replicated volumes. But we need the option of turning it on in scenarios where we see that the fuse thread is bottlenecked.

Version-Release number of selected component (if applicable):

glusterfs-libs-3.8.4-43.el7rhgs.x86_64
glusterfs-3.8.4-43.el7rhgs.x86_64
glusterfs-client-xlators-3.8.4-43.el7rhgs.x86_64
glusterfs-fuse-3.8.4-43.el7rhgs.x86_64

kernel-3.10.0-693.el7.x86_64


How reproducible:
always

--- Additional comment from Worker Ant on 2017-10-04 12:15:53 EDT ---

REVIEW: https://review.gluster.org/18430 (glusterd : fixes for client io-threads for replicate volumes) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-10-04 21:41:34 EDT ---

REVIEW: https://review.gluster.org/18430 (glusterd : fixes for client io-threads for replicate volumes) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-10-06 01:18:00 EDT ---

REVIEW: https://review.gluster.org/18430 (glusterd : fix client io-threads option for replicate volumes) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2017-10-06 05:33:38 EDT ---

REVIEW: https://review.gluster.org/18430 (glusterd : fix client io-threads option for replicate volumes) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 1 Worker Ant 2017-10-09 12:21:19 UTC
REVIEW: https://review.gluster.org/18452 (glusterd: fix client io-threads option for replicate volumes) posted (#1) for review on release-3.12 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Worker Ant 2017-10-10 05:28:36 UTC
COMMIT: https://review.gluster.org/18452 committed in release-3.12 by jiffin tony Thottan (jthottan@redhat.com) 
------
commit 47604fad4c2a3951077e41e0c007ceb979bb2c24
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Oct 9 17:46:16 2017 +0530

    glusterd: fix client io-threads option for replicate volumes
    
    Backport of https://review.gluster.org/#/c/18430/
    
    Problem:
    Commit ff075a3d6f9b142911d25c27fd209838782bfff0 disabled loading
    client-io-threads for replicate volumes (it was set to on by default in
    commit e068c1997314046658dd502e9118dab32decf879) due to performance
    issues but in doing so, inadvertently failed to load the xlator even if
    the user explicitly enabled the option using the volume set command.
    This was despite returning returning sucess for the volume set.
    
    Fix:
    Modify the check in perfxl_option_handler() and add checks in volume
    create/add-brick/remove-brick code paths, tying it all to
    GD_OP_VERSION_3_12_2.
    
    Change-Id: Ib612973a999a7da818cc926f5c2601b1f0794fcf
    BUG: 1499158
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>

Comment 3 Jiffin 2017-10-13 12:47:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.12.2, please open a new bug report.

glusterfs-glusterfs-3.12.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-October/032684.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.