Bug 150022 - RFE: mid-air collision should have a 3rd option
Summary: RFE: mid-air collision should have a 3rd option
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 3.2
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: Mike MacKenzie
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 474287
TreeView+ depends on / blocked
 
Reported: 2005-03-01 18:22 UTC by Rik van Riel
Modified: 2008-12-08 16:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 16:26:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow submitting comment only in event of midair collision (v1) (1.31 KB, patch)
2008-12-05 22:13 UTC, David Lawrence
nelhawar: review+
Details | Diff

Description Rik van Riel 2005-03-01 18:22:22 UTC
On a mid-air collision, it should be possible to still save the added comment,
but throw away any added state changes.  It has happened way too often that I
lost paragraphs worth of text because of this bugzilla limitation.

Comment 1 David Lawrence 2005-03-02 21:34:36 UTC
Good idea. Changing to enhancement request for implementation post production
push of current beta.

Comment 2 David Lawrence 2008-09-16 16:52:06 UTC
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Comment 3 David Lawrence 2008-12-05 22:13:33 UTC
Created attachment 325917 [details]
Patch to allow submitting comment only in event of midair collision (v1)

Noura, please take a minute to review this patch. It allows the comment to still be submitted in the event of a midair collision. This should only post the new comment and no other changes. It should also honor the privacy flag properly.
I have this on bz-web2-test for testing already.

Thanks
Dave

Comment 4 Noura El hawary 2008-12-08 03:55:25 UTC
Comment on attachment 325917 [details]
Patch to allow submitting comment only in event of midair collision (v1)

Hey Dave,

Patch looks good to me, I tested it and it works fine

Noura

Comment 5 David Lawrence 2008-12-08 16:26:59 UTC
Thanks Noura. Committed to CVS. Will be in the next update.


Note You need to log in before you can comment on or make changes to this bug.