Bug 150051 - default VolGroup00 naming scheme causes problems
default VolGroup00 naming scheme causes problems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 17:38 EST by Joshua Daniel Franklin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 12:06:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Daniel Franklin 2005-03-01 17:38:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
As reported in bug #144012, the default naming scheme of
/dev/mapper/VolGroup00-XXX filesystem names are too long for normal df
output, which cause problems with logwatch (and other custom scripts that parse df output).

I suggest changing the default scheme to vg00 which creates a mnemonic with the related commands (vgdisplay, etc.) and matches the man page examples more closely.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run installer
2. Use autopartition
3. Look at default naming scheme
  

Additional info:
Comment 1 Jeremy Katz 2005-03-14 12:06:14 EST
The problem is that vg isn't very obvious.  VolGroup is the shortest thing that
was considered relatively obvious.  You really want to be using df -P in scripts
anyway (for this reason... some of the cciss devices can tickle problems like
this as well)
Comment 2 Joshua Daniel Franklin 2005-03-15 02:30:11 EST
Will you be renaming vgdisplay to VolGroupDisplay, too, then? 

Obviously there are trade-offs with vg00 vs. VolGroup00, but I'm
thinking the vg mnemonic would actually make it more obvious to
the average Linux admin reading fstab or man pages. The only place
I might find VolGroup00 more helpful would be in installing using
LVM for the first time--but then, I should have read up on it 
and know what I'm doing.

Note You need to log in before you can comment on or make changes to this bug.