Bug 150071 - kernel doesn't load with Virtual PC 7
kernel doesn't load with Virtual PC 7
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Robert Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 22:30 EST by Christophe Dupre
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 21:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christophe Dupre 2005-03-01 22:30:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
I want to install RHEL 4 on my Mac running OS-X 10.3 under Microsoft
Virtual PC 7. After mounting the CD image and turn on the virtual
machine, I get the linux loader prompt. I select 'linux text' and see
the kernel being loaded from the CD. After getting 'Ok, booting the
kernel.', Virtual PC stops the virtual machine with the error:
An unrecoverage processor error has been encountered.

This seems to be related to bug 136018. Seems like many virtual
machines don't like the 4G/4G kernel patch. If that is indeed the
case, I don't understand why it's the default.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Mount CD image
2. Start virtual machine
3. select any boot option

Actual Results:  Virtual machine crashes

Expected Results:  proceed with installation process

Additional info:
Comment 1 Rik van Riel 2005-03-02 10:08:15 EST
The 4G/4G kernel is not the default in RHEL4, so are you sure that is the problem?
Comment 2 Christophe Dupre 2005-03-02 13:30:01 EST
No, not 100% sure. I know I can boot using disk1 of RHEL 3AS update 2. I haven't
tried any of the Fedora distributions, but the only problems I could find with
google related to Fedora Core & RHEL4 were somehow related to the bug I'm
referencing. 

I'd really like to get RHEL4 going with Virtual PC, I'm ready to try different
things but I just don't know where to start.
Comment 3 Dave Jones 2005-03-02 14:39:36 EST
there's really not much we can work with here.  The only thing I can suggest is
trying to disable various features (like execshield=0 etc)
Comment 4 Christophe Dupre 2005-03-02 21:08:35 EST
I'll do more experimenting and try to bring more data. Is there a list
somewhere of the features that can be disabled on the loader command
line ? I tried execshield=0 but it didn't help.
Comment 5 Dave Jones 2005-03-02 21:37:35 EST
actually, that should have been exec-shield=0
Comment 6 Dave Jones 2005-04-21 21:13:00 EDT
As virtualpc isn't something we list as a supported configuration, this isn't
going to get fixed anytime soon.

Note You need to log in before you can comment on or make changes to this bug.