Bug 1500996 - Engine logs don't indicate the option chosen for a snapshot preview
Summary: Engine logs don't indicate the option chosen for a snapshot preview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: shani
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks: 1507315
TreeView+ depends on / blocked
 
Reported: 2017-10-12 00:39 UTC by Gordon Watson
Modified: 2019-05-16 13:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1507315 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:45:44 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:46:48 UTC
oVirt gerrit 83158 0 master MERGED core: Indicate previewed image disks in engine log 2017-10-29 12:41:05 UTC

Description Gordon Watson 2017-10-12 00:39:45 UTC
Description of problem:

When a snapshot preview is performed, depending upon the disk configuration, the user is prompted to select one of following options;

- Include all disks in the preview virtual machine (save the disks that are not included in the snapshot as it is).
- Include in the VM displayed only the disks that are included in the snapshot.
- None of the above options, take me to the "Custom Preview" dialog box.


However, the option selected is not reported in the engine log.


Version-Release number of selected component (if applicable):

RHV 4.1


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Avihai 2017-11-07 12:30:44 UTC
Verified.

Engine:
ovirt-engine-4.2.0-0.0.master.20171106202508.gitf5140b9.el7.centos.noarch

Log:
2017-11-07 14:22:50,732+02 INFO  [org.ovirt.engine.core.bll.snapshots.TryBackToAllSnapshotsOfVmCommand] (default task-5) [8ed81d75-8b34-4da3-bbb8-1d8c82cba479] Previewing snapshot s1 with the disks:


VDSM:
4.20.6-33.git54a784e

Comment 9 errata-xmlrpc 2018-05-15 17:45:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 10 Franta Kust 2019-05-16 13:09:11 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.