Bug 1507315 - [downstream clone - 4.1.7] Engine logs don't indicate the option chosen for a snapshot preview
Summary: [downstream clone - 4.1.7] Engine logs don't indicate the option chosen for a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.1.7
: ---
Assignee: shani
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On: 1500996
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-29 15:41 UTC by rhev-integ
Modified: 2019-04-28 13:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1500996
Environment:
Last Closed: 2017-11-07 17:27:54 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3138 0 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.1.7 2017-11-07 22:22:33 UTC
oVirt gerrit 83158 0 master MERGED core: Indicate previewed image disks in engine log 2017-10-29 15:41:48 UTC
oVirt gerrit 83369 0 ovirt-engine-4.1 MERGED core: Indicate previewed image disks in engine log 2017-10-30 10:24:11 UTC

Description rhev-integ 2017-10-29 15:41:29 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1500996 +++
======================================================================

Description of problem:

When a snapshot preview is performed, depending upon the disk configuration, the user is prompted to select one of following options;

- Include all disks in the preview virtual machine (save the disks that are not included in the snapshot as it is).
- Include in the VM displayed only the disks that are included in the snapshot.
- None of the above options, take me to the "Custom Preview" dialog box.


However, the option selected is not reported in the engine log.


Version-Release number of selected component (if applicable):

RHV 4.1


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

(Originally by Gordon Watson)

Comment 5 Israel Pinto 2017-11-01 13:00:25 UTC
Verify with:

Steps:
Create snapshot for VM and do preview
search for message in engine log.

Results:
# cat  engine.log | grep "Previewing snapshot"
2017-11-01 14:58:15,994+02 INFO  [org.ovirt.engine.core.bll.snapshots.TryBackToAllSnapshotsOfVmCommand] (default task-6) [7a8f7ef4-a00c-444d-9ed0-8d48b04b2eab] Previewing snapshot 1 with the disks:


PASS

Comment 8 errata-xmlrpc 2017-11-07 17:27:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3138


Note You need to log in before you can comment on or make changes to this bug.