Bug 1501212 - when registering, "--name" option seems to be ignored
Summary: when registering, "--name" option seems to be ignored
Keywords:
Status: CLOSED DUPLICATE of bug 1344011
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Registration
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-12 08:55 UTC by Jan Hutař
Modified: 2019-08-12 14:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-16 20:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2017-10-12 08:55:37 UTC
Description of problem:
When registering with `subscription-manager register`, "--name" option seems to be ignored.


Version-Release number of selected component (if applicable):
Satellite: satellite-6.3.0-19.0.beta.el7sat.noarch
Client: python-rhsm-1.19.9-1.el7.x86_64
        subscription-manager-1.19.21-1.el7.x86_64


How reproducible:
always on my setup


Steps to Reproduce:
1. # subscription-manager register --activationkey ActivationKey --org 'Default_Organization' --name "Our database server"
2. Check on Satellite resulting name


Actual results:
[root@client ~]# hostname
client.example.com
[root@client ~]# yum upgrade \*subscription\* \*rhsm\*
Loaded plugins: enabled_repos_upload, package_upload, product-id, search-disabled-repos, subscription-manager
rhel-7-server-rh-common-rpms             | 2.1 kB  00:00:00     
rhel-7-server-rpms                       | 2.0 kB  00:00:00     
rhel-7-server-satellite-tools-6.2-rpms   | 2.1 kB  00:00:00     
No packages marked for update
Uploading Enabled Repositories Report
Loaded plugins: product-id

[root@sat630 ~]# hammer -u admin -p changeme host list --organization "Default Organization" --search "name ~ client OR name ~ database"
---|--------------------|------------------|------------|-----------------|-------------------|---------------------------|----------------------
ID | NAME               | OPERATING SYSTEM | HOST GROUP | IP              | MAC               | CONTENT VIEW              | LIFECYCLE ENVIRONMENT
---|--------------------|------------------|------------|-----------------|-------------------|---------------------------|----------------------
31 | client.example.com | RedHat 7.3       |            | 192.168.122.102 | 52:54:00:71:b1:b6 | Default Organization View | Library              
---|--------------------|------------------|------------|-----------------|-------------------|---------------------------|----------------------

Name is also not present in any fact:

[root@sat630 ~]# hammer -u admin -p changeme host facts --id 31 | grep -e client -e database
uname::nodename                               | client.example.com                                                              
network::hostname                             | client.example.com                                                              
network::fqdn                                 | client.example.com


Expected results:
Systems should be registered with specified name or at least name should be present in some of its metadata


Additional info:
Noticed when working on bug 1480346.

Comment 2 Brad Buckingham 2017-10-16 20:03:45 UTC

*** This bug has been marked as a duplicate of bug 1344011 ***


Note You need to log in before you can comment on or make changes to this bug.