Bug 1344011 - subscription-manager register w/ --name fails to create host of that name
Summary: subscription-manager register w/ --name fails to create host of that name
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Registration
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Stephen Wadeley
URL:
Whiteboard:
: 1376808 1501212 1653330 1843591 (view as bug list)
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2016-06-08 13:47 UTC by Tom McKay
Modified: 2021-12-10 14:40 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-01 12:07:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3433701 0 None None None 2018-05-19 05:09:24 UTC

Description Tom McKay 2016-06-08 13:47:50 UTC
1. register a system: subscription-manager register ...
2. clean the system: subscription-manager clean
3. re-register w/ name: subscription-manager register --name name.example.com ...
4. check identity: subscription-manager identity -> name: name.example.com
5. check content hosts and note that only the first system is listed

Comment 2 Mike McCune 2016-06-13 17:13:44 UTC
Tom, isn't this by design now with 6.2 and the uniqueness constraint that we can only have a host with a name exist once within the Satellite?

Comment 3 Tom McKay 2016-09-26 14:31:08 UTC
Yes, it's true that there cannot be two hosts with the same name in any org on the server. However, should I be able to use --name w/ sub-mgr at all? If, for example, I spin up a local VM and register it to katello and its fqdn is katello.example.com but another dev has already registered with that name, what happens? Should I not be able to register w/ --name to pick a unique name, overriding fqdn?

If we're removing --name as an option, it should/could return an error to sub-mgr.

Comment 4 Chris Duryee 2016-09-26 18:54:58 UTC
I am moving this from z to backlog since it's not a straightforward issue per #3. We can move it back to z if needed, once the questions in #3 are resolved.

Comment 9 Brad Buckingham 2017-10-16 20:03:45 UTC
*** Bug 1501212 has been marked as a duplicate of this bug. ***

Comment 12 Peter Vreman 2018-05-08 08:26:32 UTC
Tom,

Is this not a a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1376808 ?

Peter

Comment 13 Brad Buckingham 2018-06-21 21:55:54 UTC
*** Bug 1376808 has been marked as a duplicate of this bug. ***

Comment 14 Brad Buckingham 2018-06-21 21:57:31 UTC
Peter,

I agree.  Thanks!  I happened to observe the same while doing some queries earlier this week.  I closed bug 1376808 as a duplicate.

Comment 15 Bryan Kearney 2018-09-04 18:03:33 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 16 Brad Buckingham 2018-12-07 12:57:37 UTC
*** Bug 1653330 has been marked as a duplicate of this bug. ***

Comment 17 Anand Agrawal 2019-02-19 09:40:36 UTC
Hello Team,

I have a customer looking for this feature. They mentioned that the current `subscription-manager register --name <name-of-the-client>` command does not perform what it is expected to do.  

So, either the name flag should be removed and documented, or it should do what it says it will in the documentation.  

Can someone review and confirm?

Regards,
Anand

Comment 18 Bryan Kearney 2019-02-28 19:39:54 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 19 Bryan Kearney 2019-04-01 12:07:07 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 20 Bryan Kearney 2019-04-02 13:33:49 UTC
Wrond closure reason.

Comment 21 Brad Buckingham 2020-06-04 15:56:21 UTC
*** Bug 1843591 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.