Bug 150123 - [PATCH] pciReadDrivers doesn't fallback and read kernel modules.pcimap if needed
Summary: [PATCH] pciReadDrivers doesn't fallback and read kernel modules.pcimap if needed
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-03-02 18:33 UTC by David Lehman
Modified: 2014-03-17 02:52 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-667
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 16:56:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
read /lib/modules/`uname -r`/modules/pcimap if /usr/share/hwdata/pci* not available (554 bytes, patch)
2005-03-02 18:33 UTC, David Lehman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:667 qe-ready SHIPPED_LIVE kudzu bug fix update 2005-10-05 04:00:00 UTC

Description David Lehman 2005-03-02 18:33:17 UTC
Description of problem:
ICBW, but I don't see anything using the id_file_name field of pacc in pciProbe.
More importantly, pciReadDrivers returns in two places I believe it should
instead jump to the pcimap label. This makes all the difference when kudzu is
run without /usr mounted. This happens when /sbin/kmodule is called early in
/etc/rc.sysinit with /usr on a separate partition and since kudzu can't read
/usr/share/hwdata/pci.ids it only generates a partial list. Attached is a patch
to kudzu to correct this behavior.

Version-Release number of selected component (if applicable):
kudzu-1.1.95.11-1

How reproducible:
Always

Steps to Reproduce:
1. Run kmodule from initscripts without /usr mounted, *OR*
2. move pcitable and pci.ids out of /usr/share/hwdata/
3. run kudzu -s -p
  
Actual results:
Multiple devices have "unknown" driver

Expected results:
Devices have drivers as specified in /lib/modules/`uname -r`/modules.pcimap

Additional info:
This is another part of the same problem (see Issue Tracker ref) that caused me
to reopen bug 130350. So after fixing the test for /dev/hw_random in rc.sysinit,
and with this fix and a rebuild of initscripts (/sbin/kmodule statically links
probeDevices from kudzu) the rngd daemon is started at bootup. Unfortunately, on
my laptop /sbin/rngd hangs trying to read from /dev/hw_random. I guess I'll be
opening a bug there against kernel-utils.

Comment 1 David Lehman 2005-03-02 18:33:17 UTC
Created attachment 111587 [details]
read /lib/modules/`uname -r`/modules/pcimap if /usr/share/hwdata/pci* not available

Comment 6 Bill Nottingham 2005-07-13 01:50:40 UTC
Fixed in 1.1.95.13-1.

Comment 9 Red Hat Bugzilla 2005-10-05 16:56:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-667.html



Note You need to log in before you can comment on or make changes to this bug.